Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Using Sata PCI-e card in T420

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
dmdsoftware
Junior Member
Junior Member
Posts: 424
Joined: Mon Apr 11, 2005 2:24 pm
Location: Mississauga, Ontario, Canada

Using Sata PCI-e card in T420

#1 Post by dmdsoftware » Tue Dec 03, 2013 3:38 pm

I bought one of these -> http://www.newegg.com/Product/Product.a ... 6816124059

I was hoping to essentially add some extra ports to allow for additional drives connected over sata/esata. I know about exprescard esata cards, and I'm currently using one for this purpose on this machine. But I was hoping on using this card instead, so I don't have an ugly dongle hanging off the system.

I installed the card and booted up, but it doesn't seem to be recognized at all.

I'm using Debian. Tried kernels 3.10, 3.11, 3.7. I checked the kernel source code, and these kernels are supposed to load the appropriate driver for the ASM1061 chipset (I can see this in the code). However, I don't see anything under dmesg with regard to detecting any additional achi or sata devices.

So now I have to wonder. Will this card work in the T420? Or is the issue a "linux" thing. I can't see to find much about the particular card with regard to linux, but the desktop version of the card has many documented success stories.

I know the SATA II connection works in my WWAN slot. I normally have a SSD plugged into it that I boot from. I was going to relocate that to the 2.5" HD slot.
X62 & X62s & X62T SXGA+ i7 5600u 8-16GB
Helix i7
Carbon X1 i5 UHD
W520 4x-i7
Sony Vaio P799 (8" LED 1600x768)
"Think" Ultrabook i7
LegoThinkpad 11"

in storage:
X131e AMD
X60/X60s, X61/X61s/X61T, T61, T420, X30

past:
X20-X24, 390X

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2368
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: Using Sata PCI-e card in T420

#2 Post by axur-delmeria » Wed Dec 04, 2013 9:51 am

Have you checked the output of lspci?

If it's not detected, then the pcie slot might be turned off in the BIOS config.

If it still doesn't work, it may be a BIOS problem (BIOS doesn't recognize card and refuse to initialize it). or a hardware error (defective card).
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 11 guests