t450s - trackpoint not working after keyboard replacement

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
m-blue
Freshman Member
Posts: 56
Joined: Sun May 18, 2008 2:08 am
Location: Czestochowa, Poland

t450s - trackpoint not working after keyboard replacement

#1 Post by m-blue » Sun Sep 17, 2017 3:36 pm

hi,
I changed keyboard to brand new, and after replace tracpoint not working... old one, after go back - still ok, I am wondering is it possible, that it is driver problem ( different tracpoint device in new keyboard? ) . It is possible, that it is hardware problem, but I found info about drivers and not working tracpoint...
I try to uninstall driver, new windows, turn on and off in bios... still tracpoint death.

Three buttons under space are not working too.
Michal
Regards,
Michal

RealBlackStuff
Admin
Admin
Posts: 18077
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: t450s - trackpoint not working after keyboard replacement

#2 Post by RealBlackStuff » Mon Sep 18, 2017 4:29 am

Try to (re)insert the keyboard connector.
You might also have dirt in the motherboard's KB-connector.
Or you got a bad keyboard.
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1427
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: t450s - trackpoint not working after keyboard replacement

#3 Post by axur-delmeria » Mon Sep 18, 2017 10:29 am

Is the trackpoint cable separate from the keyboard cable? If yes, maybe it's possible to transplant the trackpoint module from the old keyboard to the new one.
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

m-blue
Freshman Member
Posts: 56
Joined: Sun May 18, 2008 2:08 am
Location: Czestochowa, Poland

Re: t450s - trackpoint not working after keyboard replacement

#4 Post by m-blue » Mon Sep 18, 2017 1:57 pm

I checked connections etc. looks fine, a few times. Keyboard is brand new under thinkpad warranty, send from service to replace so I can just call and tell that it is not working, but I still belive that it is not keyboard problem:)
Regards,
Michal

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1427
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: t450s - trackpoint not working after keyboard replacement

#5 Post by axur-delmeria » Mon Sep 18, 2017 2:06 pm

Can you check the touchpad cable?
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

m-blue
Freshman Member
Posts: 56
Joined: Sun May 18, 2008 2:08 am
Location: Czestochowa, Poland

Re: t450s - trackpoint not working after keyboard replacement

#6 Post by m-blue » Mon Sep 18, 2017 2:25 pm

yes, I checked cable, connection looks brand new;/
Regards,
Michal

bit_twiddler
Junior Member
Junior Member
Posts: 428
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: t450s - trackpoint not working after keyboard replacement

#7 Post by bit_twiddler » Tue Sep 19, 2017 7:25 am

Sometimes the trackpoint goes bad, either by failing completely, or by drifting uncontrollably.
However, the fact that the 3 buttons are also dead probably means that a connection somewhere
is bad, or that part of the cable itself got damaged.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 6 guests