Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

CD ROM not recognized

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
jwjensen356
Freshman Member
Posts: 51
Joined: Thu Jul 27, 2006 2:53 pm
Location: San Mateo, California

CD ROM not recognized

#1 Post by jwjensen356 » Thu Dec 29, 2016 2:42 am

I've got a T420, very stock. W10. Not used very much so running hours are quite low. The CD ROM is not being recognized. After a boot-up it is recognized in File Explorer but when I click on it I get a message "Location Currently Not Available". It allows me to open the drive with the eject button and also by a key command. And then, eventually, it disappears from File Explorer (but shows up again after a reboot). CD Rom was working OK months ago. I tried a reset to an earlier state (of about a month ago). No luck. Any ideas?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21192
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: CD ROM not recognized

#2 Post by RealBlackStuff » Thu Dec 29, 2016 8:10 am

Try to remove and reinsert the drive, it might just be a bad/dirty contact.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

jwjensen356
Freshman Member
Posts: 51
Joined: Thu Jul 27, 2006 2:53 pm
Location: San Mateo, California

Re: CD ROM not recognized

#3 Post by jwjensen356 » Thu Dec 29, 2016 2:53 pm

I thought that might be the case. I pulled it and put it back in. No luck. I gave it a shot of DeoxIT to make sure. Still won't work. I wish I had someone nearby to be able to plug this UltraBay unit in to check if it is OK.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21192
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: CD ROM not recognized

#4 Post by RealBlackStuff » Thu Dec 29, 2016 3:08 pm

I'd also check with a Linux Live-CD, it wouldn't be the first time that W10 Micro$hafts someone...

jwjensen356
Freshman Member
Posts: 51
Joined: Thu Jul 27, 2006 2:53 pm
Location: San Mateo, California

Re: CD ROM not recognized

#5 Post by jwjensen356 » Thu Dec 29, 2016 3:29 pm

I'm giving up until I get a new UltraBay drive (I just ordered one from newegg, $30+).

jwjensen356
Freshman Member
Posts: 51
Joined: Thu Jul 27, 2006 2:53 pm
Location: San Mateo, California

Re: CD ROM not recognized

#6 Post by jwjensen356 » Tue Jan 03, 2017 7:19 pm

Back again. Installed a new CD drive received from newegg (speedy delivery, discussed below). That was it, a failed drive. Now back with an operating drive and was able to install some new software But it was not an easy installation. I ordered it according to the Lenovo FRU number but that is not what I received. This one had HP references on it. What I had to do was disassemble the original by removing several plastic items and put them on the replacement drive (the screw holes all matched). A pain. The actual drive is constructed differently but everything fits in the TP OK.

I was provided tracking info and I saw that it was shipped from the Chinese factory and made it to NY and then shipped here by USPS. All in about 5 days time. Amazing.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 27 guests