T410s (291-W6H) Intel chipset drivers

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
Brainer
Posts: 5
Joined: Thu Feb 14, 2013 12:06 am
Location: Toronto, Canada

T410s (291-W6H) Intel chipset drivers

#1 Post by Brainer » Fri Apr 14, 2017 5:30 pm

Hi everyone:

I have a T410s (2912-W6H). The machine is running Windows 7 SP1 SP1 x32 with Convenience Rollup .
The chipset drivers are dated:

6/4/2009
(version 8.9.0.1023).

It seems to me there must have been later Intel chipset driver versions than that. I tried installing the latest one for that model from Lenovo's website, labelled as v. 9.3.0.1021. These appear to install, but when I go into device manager, the driver tab still reads 8.9.0.1023 . I've tried uninstalling and reinstalling again.

Can anyone suggest what's going wrong?

Also, can anyone tell me if my 2912-W6H has WWAN card and GPS function? There's a sticker on the top that says broadband, but I don't know if there's hardware inventory software that detects that type of hardware.

Thanks

cynicx
Posts: 7
Joined: Wed Apr 19, 2017 5:04 pm
Location: Harford, MD

Re: T410s (291-W6H) Intel chipset drivers

#2 Post by cynicx » Sat Apr 22, 2017 7:20 am

Are you having a problem? Speaking from a Linux mindset, if it ain't broke don't fix it because you will break it.

That said Lenovo has a driver utility to scan all the hardware for the latest drivers for your operating system.

http://www.....
[Admin warning:
That was NOT a Lenovo utility!
Link removed, while considered unsafe and from a moneymaking racket.


It may just be the latest driver available for Win 7. Most drivers are only updated to fix bugs or update for later operating systems.

Brainer
Posts: 5
Joined: Thu Feb 14, 2013 12:06 am
Location: Toronto, Canada

Re: T410s (291-W6H) Intel chipset drivers

#3 Post by Brainer » Sat Apr 22, 2017 9:48 am

I already ran the Lenovo Thinkvantage System Update. It found almost zero updates, and none for the chipset.

I read from a reputable source on another forum that, (other than RST/MEI/USB) Intel's Chipset "drivers" are mostly just for display purposes. If you look at the actual INF they generally don't even load any actual drivers, they just provide a name to what Windows would otherwise identify as "unknown device" / exclamation points in device manager.

So, later versions of the Chipset "drivers" installers are unlikely to provide anything... and the Chipset installer may determine that they are unnecessary. You can of course force the procedure with either device manager, or pnputil, but that isn't actually doing anything other then bumping some version numbers on the screen.

In my particular case, with the the age of the hardware, Windows 7 has enough built-in code that it doesn't need much in the way of drivers to function. And even with later chipsets, the inf files are not doing anything but identifying otherwise "unknown" devices.
While all the other devices will require a driver, and so will USB3.x if you are using a Windows version below Windows 8, most of the on-board devices do not need any special drivers or don't need to interact with those device IDs at all.

Since no major changes were done to these ICH5 drivers, it apparently doesn't matter that I'm using the "old" versions, cause a newer version doesn't change anything important. Assuming this is true, I have to wonder why they even bother to post udpates, except for things like USB.

Furthermore, due to a bug in Intel's chipset installer, which lists the date as 1970, most of these packages will not even install enough to change the version numbers, because the system sees them as earlier than the original installed "driver". Strange.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: RagingShargon and 5 guests