TP 500 - Ericsson F3507g 3G modul no network access?

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
Insomniac1971
Freshman Member
Posts: 115
Joined: Sun Jun 26, 2005 2:00 pm
Location: Søllested, Denmark
Contact:

TP 500 - Ericsson F3507g 3G modul no network access?

#1 Post by Insomniac1971 » Wed Sep 06, 2017 6:12 am

Hi, I have this TP 500 that came with the Ericsson 3G modul already installed - But no drivers installed for it, So i got what I could from the EOL site for this laptop:

https://download.lenovo.com/eol/index.html

And then the modem were discovered correctly and I have no yellow exclamation marks in device manager. Also Access Connection 6 can see the modem and dial out, so can windows own network manager - problem is that it connects but I don't get internet access. If I leave the mouse on the conection( in systray) then it tells me its connected to "Telenor DK(roaming) (don't know why its writting that, since its not roaming - my ISP lease the line from Telenor DK). It also tells me that the connection quality is good/excellent and that its using EDGE protocol - but also say "no network access".

If i diagnose modem in device manager there are only a few error because AT command not supported, otherwise nothing seems to be wrong with it.

It's not the sim card, I tried it in my Huawei 3G usb modem and it worked fine.

If I disconnect the Telenor DK connection and take properties for it and properties again then I can choose to register it on a network or set it to automatically. If I register it on Telenor DK then the registration goes fine, same goes for Automatically.

In access connection nothing seem to be wrong with the setup. But here I get an error of failed connection, when I try to connect.

I'm wondering if it has something to do with which protocols the modem can connect too, UMTS, WCDMA, CDMA, HSPA, HSDPA(+) and the ones supplied by my ISP(850, 1900, 2100Mhz). APN is the correct one.

Could someone help me get this thing working, with a troubleshooting from start?

EDIT: You have to love Lenovo(sarcasm), I were installing the latest drivers again to see if that did any difference and it did, but not in a good way - now the modem couldn't connect at all and after reboot the card simply disappeared from windows 7 device manager, and I can't seem to get it back. I have tried uninstalling the drivers - using XP drivers which has confirmed working - tried Vista driver which has been confirmed working - uninstalling Access connections and installing Dell Wireless manager 5.2 (which has been confirmed working), it doesn't even see the card - Installed the modem manager for this card (from Lenovo's site), no card detected. Took out the card and cleaned the connectors, still not working. Took out the card and cleaned the connectors, started windows 7 without the card and got device manger to look for new HW 7 times, then shutdown re-inserted the card and boot to windows - still not working.

Is there anyway or any commands I can use from linux terminal or windows command prompt to see if the card is still alive?

XUbuntu 16.04 64bit who could see the mobile broadband connection in network connections before, can't see it now. Did Lenovo's driver kill my card?

EDIT2: Look like Lenovo's driver did kill my card, it were working and connecting, just not to the internet(most likely because its UMTS only and the net here is HSDPA), untill I installed latest driver from Lenovo, then it came with error when trying to connect and later right out disappeared from the computer. I have tried to get it working in Xunbutu 14.04 32bit and 16.04 64bit and it's gone, none of the methods to find the device, show any result of the Ericsson F3507g modem/3G - So I took it out.

It's not likely Lenovo is going to own up to their driver killing 3G modems, right! As it would be I'm not the only one this happened to, many other people installing the newest driver experience that the modem works then get problems then stop working and last disappear - found this out when looking for solution to why it disappeared.

For me it looks like the latest driver tells the modem to act in a way it were not designed for and then it malfunctions and die. I can't prove it, so it have to stay in theory. #¤%& Lenovo programmers, who never test something before posting it.

But it is a clever way to get people to buy a new modem from Lenovo, because their whitelist makes it impossible to use other manufacturer - unless you void warranty and use a modded bios.

There are a special place in hell for car salesmen, bankers, lawyers, crooks and Lenovo(the others might be saved).

JBJ
Live life to to fullest:) I do!
Thinkpads: T500, R500, X300 - (dead R61(intel), T61(Nvidia))
Other: Toshiba Satellite L40-139(dead)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 6 guests