Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

solved: T500: Ricoh Expresscard SDXC adapter from T420s keeps disconnecting / reconnecting

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
TPFanatic
ThinkPadder
ThinkPadder
Posts: 1027
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

solved: T500: Ricoh Expresscard SDXC adapter from T420s keeps disconnecting / reconnecting

#1 Post by TPFanatic » Sun Nov 05, 2017 1:11 am

I bought the T420s Expresscard to SD adapter to use in my T500 because it's 9 times faster than the onboard reader which is a POS.

But the Expresscard to SD reader keeps disconnecting and reconnecting when I try to use it. I can't get the driver installed and in device manager the device keeps disappearing and reappearing. I of course cannot use the device to copy things.

Using Windows 7.

I haven't tried another OS yet.
Last edited by TPFanatic on Sun Nov 05, 2017 11:32 am, edited 1 time in total.
lenovo T61 T7500, SXGA+, 8GB
lenovo T410s i5 520m, WXGA+, 4GB
lenovo T430 i5 3320m, FHD, 8GB
lenovo T500 P9700, WUXGA, 8GB
lenovo T520 i7 2760QM, FHD, 8GB



Enable 2 finger scroll on any Synaptics touchpads with registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

dr_st
Moderator
Moderator
Posts: 7382
Joined: Sat Oct 29, 2005 6:20 am

Re: T500: Ricoh Expresscard SDXC adapter from T420s keeps disconnecting / reconnecting

#2 Post by dr_st » Sun Nov 05, 2017 2:25 am

1) What's the FRU of that adapter?
2) Do you also experience bad mouse lag when it's plugged in?
3) Try disabling PCI-Express power management in the BIOS, if such an option exists.

It sounds a lot like the interoperability problem between certain Intel chipsets and certain ExpressCard adapters. I reported it here:
viewtopic.php?f=18&t=123727
dr_st wrote:
Tue May 02, 2017 3:36 am
The first surprise, and a rather unpleasant one – from the start, the 04W1701 did not work right in the X220, presenting the same symptoms of horrible mouse lag, falling off the bus and reappearing constantly, as the Renesas uPD720202-based USB 3.0 controllers. The solution, as before, was to disable the PCIe ASPM in the BIOS, so that the root port does not attempt to enable L0s state. This is bad for normal operation, as it drains the battery faster, but for the tests it was fine. This is the first device that is not a uPD720202 adapter where I encountered this problem, so at this point I am more inclined to believe that the L0s interoperability problem lies with the Intel chipset, or the Lenovo BIOS, rather than the endpoint devices. Again, I did not have time to investigate it in depth – maybe in the future.
Current: Thinkpad 25 (20K7), Yoga 14 (20FY), X220 4291-4BG, T410 2537-R46, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, T60 1952-F76, A31p w/ Ultrabay Numpad

TPFanatic
ThinkPadder
ThinkPadder
Posts: 1027
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

solved: Re: T500: Ricoh Expresscard SDXC adapter from T420s keeps disconnecting / reconnecting

#3 Post by TPFanatic » Sun Nov 05, 2017 10:44 am

04W1701

I do get mouse lag.

I'll see if I can find that, thanks!

edit: Found it, it worked. Thanks drst
lenovo T61 T7500, SXGA+, 8GB
lenovo T410s i5 520m, WXGA+, 4GB
lenovo T430 i5 3320m, FHD, 8GB
lenovo T500 P9700, WUXGA, 8GB
lenovo T520 i7 2760QM, FHD, 8GB



Enable 2 finger scroll on any Synaptics touchpads with registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 13 guests