Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Turn off Bluetooth (completely) T520 running Windows 10

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
JayNYC
Freshman Member
Posts: 53
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Turn off Bluetooth (completely) T520 running Windows 10

#1 Post by JayNYC » Tue Jan 09, 2018 10:12 pm

Hi. T520 running Windows 10 Pro. It's a clean install of Win10Pro, does not include any of the Lenovo cruft except the System Interface Foundation driver. How do I fully and completely turn off Bluetooth? I don't see anything in BIOS. In Device Manager I can disable it, but the indicator light remains lit. Thanks for any guidance. (PS. I don't want to turn off WiFi, so the hardware switch doesn't solve the problem as it only turns them both off)

RealBlackStuff
Admin
Admin
Posts: 18999
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Turn off Bluetooth (completely) T520 running Windows 10

#2 Post by RealBlackStuff » Wed Jan 10, 2018 1:55 am

Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

JayNYC
Freshman Member
Posts: 53
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Re: Turn off Bluetooth (completely) T520 running Windows 10

#3 Post by JayNYC » Wed Jan 10, 2018 7:13 am

@RealBlackStuff Tried that, tried switching Bluetooth off, but the indicator light (green LED) is still lit up.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16092
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Turn off Bluetooth (completely) T520 running Windows 10

#4 Post by ajkula66 » Wed Jan 10, 2018 3:52 pm

You *could* try installing Power Manager and Access Connections - no clue on how reliably these will run under W10 - and then use Fn+F5 to selectively turn off the BT.

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T42, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

dr_st
Senior ThinkPadder
Senior ThinkPadder
Posts: 7282
Joined: Sat Oct 29, 2005 6:20 am

Re: Turn off Bluetooth (completely) T520 running Windows 10

#5 Post by dr_st » Tue Jan 16, 2018 3:15 am

Windows 10 has 'Blueooth Settings' menu (just open start menu and start typing). What's the Bluetooth status there?
Current: Thinkpad 25 (20K7), Yoga 14 (20FY), X220 4291-4BG, T410 2537-R46, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, T60 1952-F76, A31p w/ Ultrabay Numpad

JayNYC
Freshman Member
Posts: 53
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Re: Turn off Bluetooth (completely) T520 running Windows 10

#6 Post by JayNYC » Thu Jan 18, 2018 10:43 am

dr_st wrote:
Tue Jan 16, 2018 3:15 am
Windows 10 has 'Blueooth Settings' menu (just open start menu and start typing). What's the Bluetooth status there?
@dr_st even when the Windows 10 Bluetooth setting (switch) is OFF, the green bluetooth LED is still lit.

Was hoping there was a way to fully turn off Bluetooth and the LED itself with some type of simple script or toggle.

hhhd1
Junior Member
Junior Member
Posts: 499
Joined: Mon Nov 17, 2014 7:23 pm
Location: Cairo, Egypt

Re: Turn off Bluetooth (completely) T520 running Windows 10

#7 Post by hhhd1 » Fri Jan 19, 2018 2:16 pm

TPFanControl software can completely turn off bluetooth, right click on the icon in status bar, this is on windows 8.1 though.

not sure if it persists after restart or not.
===

JayNYC
Freshman Member
Posts: 53
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Re: Turn off Bluetooth (completely) T520 running Windows 10

#8 Post by JayNYC » Sat Jan 20, 2018 12:37 pm

hhhd1 wrote:
Fri Jan 19, 2018 2:16 pm
TPFanControl software can completely turn off bluetooth, right click on the icon in status bar, this is on windows 8.1 though.

not sure if it persists after restart or not.
@hhhd1 Well, you are right. TPFanControl does indeed turn off Bluetooth and the LED indicator, even on Windows 10! You are also correct that it does not persist after restart (sleep/resume). I emailed the author and he confirmed there is no way to set Bluetooth off from the .ini file either (he also implied TPFanControl is no longer under development). So right now I have to manually turn off Bluetooth each time. I wish someone knew what the actual machine code was to deactivate Bluetooth and the LED light and could make a script that does this, and could run it inside task scheduler so that upon wake/resume/restart it always turns off. As a non-developer, I'm thinking my only option would be to make an AutoHotKey compiled program that interacts with the TPFanControl GUI, right clicks the icon, left clicks on Bluetooth, etc. but that's pretty inelegant.

RealBlackStuff
Admin
Admin
Posts: 18999
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Turn off Bluetooth (completely) T520 running Windows 10

#9 Post by RealBlackStuff » Sat Jan 20, 2018 3:23 pm

Remove the palmrest, under which you'll find the BT-module.
Remove that, problem solved.

fmcart
Posts: 4
Joined: Wed Mar 14, 2018 9:18 pm
Location: Hull, MA

Re: Turn off Bluetooth (completely) T520 running Windows 10

#10 Post by fmcart » Thu Mar 15, 2018 6:26 pm

My T520's green Bluetooth light was also on and turning it off in the OS had no effect. I finally went to BIOS and poked around. Nothing until I went to Security, Why bother going there? Because I'd been everywhere else.

And that's where I found it, in the last place I thought to look. It was under I/O Port Access.

My green light is now off.

JayNYC
Freshman Member
Posts: 53
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Re: Turn off Bluetooth (completely) T520 running Windows 10

#11 Post by JayNYC » Thu Mar 15, 2018 6:42 pm

fmcart wrote:
Thu Mar 15, 2018 6:26 pm
My T520's green Bluetooth light was also on and turning it off in the OS had no effect. I finally went to BIOS and poked around. Nothing until I went to Security, Why bother going there? Because I'd been everywhere else.

And that's where I found it, in the last place I thought to look. It was under I/O Port Access.

My green light is now off.
@fmcart going to check that out now.

JayNYC
Freshman Member
Posts: 53
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Re: Turn off Bluetooth (completely) T520 running Windows 10

#12 Post by JayNYC » Thu Mar 15, 2018 7:16 pm

@fmcart

THANK YOU


holy cow, I can't believe it was right in the bios all along.

and all the more impressive, you joined this forum just yesterday!

thank you thank you thank thank you!!
https://content.screencast.com/users/ja ... PC-83c.jpg

fmcart
Posts: 4
Joined: Wed Mar 14, 2018 9:18 pm
Location: Hull, MA

Re: Turn off Bluetooth (completely) T520 running Windows 10

#13 Post by fmcart » Mon Mar 19, 2018 9:29 pm

You're welcome. The funny thing is, my T60 didn't have bluetooth and I always wanted it. But when I got the T520 I didn't have a BT device, so I spent quite a while trying to turn off the green BT LED.

The T520 lacks Windows 10 support but perhaps because of that they can be picked up fairly cheap. And they're good for dual-booting - I've got w10 + Linux on this one.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 7 guests