Page 3 of 3

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Mon Aug 06, 2018 3:51 am
by rad4day
Seems like I'm gonna get a LP140QH2-SPB1
found 2 sellers claiming they are selling the exact part.

Getting the other ones seems to be a pain in Europe :/

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Thu Aug 16, 2018 11:48 am
by RMSMajestic
I will resume shortly on Etsy and payment link.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Mon Aug 20, 2018 2:41 pm
by xyzzyx
I am late to the game. Could someone recommend where these _genuine_ displays are available for purchase new in the States? Seems like ebay and amazon only carry fakes :(.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Tue Aug 21, 2018 11:32 am
by RMSMajestic
Also worth mentioning, I have about 40 kits left and since Javi-Jie is no longer in this area, refund will be given instead of replacement if there're lost packets

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Fri Oct 05, 2018 3:14 pm
by RMSMajestic
I' m aware of the difficulties in sourcing panels. I will contact with zhangyongtao (a.k.a LCD fans) to see if there's possibilities for reliable panels.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Oct 21, 2018 12:08 am
by Lvzbel
RMSMajestic wrote:
Fri Oct 05, 2018 3:14 pm
I' m aware of the difficulties in sourcing panels. I will contact with zhangyongtao (a.k.a LCD fans) to see if there's possibilities for reliable panels.
It would be of great help, I already have my kit and trying to find a decent panel

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Oct 21, 2018 9:32 am
by turomini
Lvzbel wrote:
Sun Oct 21, 2018 12:08 am
RMSMajestic wrote:
Fri Oct 05, 2018 3:14 pm
I' m aware of the difficulties in sourcing panels. I will contact with zhangyongtao (a.k.a LCD fans) to see if there's possibilities for reliable panels.
It would be of great help, I already have my kit and trying to find a decent panel
I'm in the same situation.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Oct 28, 2018 11:08 pm
by Pochacco20
I also just purchased a kit and now I'm afraid I won't be able to find a decent panel.
I normally purchase from LaptopScreen.com and I see they're all out of stock of the usual suspects. However, they do currently have a peculiar LP140QH1-SPA2 in stock:
https://www.laptopscreen.com/English/sc ... ash=433175
My concern is that mr.rhtuner clearly stated that "LP140QH1-SPA2 is the GLOSSY VERSION of the LP140QH1", but this listing states the screen is matte. Plus the price is significantly cheaper than the other known quality screens. So I'm afraid this could be a knock-off.
When I receive my kit, if there are no replies regarding my concern, I'll order one of these so-called LP140QH1-SPA2 matte screens (I'll state not to send me a compatible model) and let you guys know how it turns out.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Fri Nov 09, 2018 12:49 pm
by mr.rhtuner
RealBlackStuff wrote:
Thu Mar 08, 2018 10:53 am
That is Registry info.
You need to look up what it says in the EDID-chip on the LCD itself.

Do you have any ideas how I can pull that informaiton? the EDID chip info?

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Wed Nov 14, 2018 3:16 pm
by swymts
Hi, thank you RMSMajestic so much for this mod!!!

I'm seeing vertical white lines across my screen on install...could someone tell me if I received the wrong screen? I was told I bought a B140QAN01.5



https://i.imgur.com/4mibGCO.jpg

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Thu Nov 15, 2018 4:13 pm
by Maxzep
swymts wrote:
Wed Nov 14, 2018 3:16 pm
I'm seeing vertical white lines across my screen on install...could someone tell me if I received the wrong screen? I was told I bought a B140QAN01.5
On your photo VVX14T058J00. Look here and here.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Nov 18, 2018 1:12 pm
by swymts
Thank for you looking, looks like I got a bad deal.

Any recommendations on finding a compatible screen? I was considering this: https://www.aliexpress.com/item/Origina ... 30342.html

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Wed Dec 12, 2018 10:38 pm
by TPFanatic
i literally bought an advertised "Exact B140QAN01.1" from a seller but they sent me a LTN140YL02-H01 instead. It's some sort of Glossy 3K IPS screen? Wtf is this? I thought 2560x1440 was the highest resolution in a 14".

It's a 40 pin EDP screen I wonder what would happen if I plugged it in? :?:

edit: Not going to try.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Fri Dec 14, 2018 2:58 am
by Maxzep
swymts wrote:
Sun Nov 18, 2018 1:12 pm
Any recommendations on finding a compatible screen? I was considering this: https://www.aliexpress.com/item/Origina ... 30342.html
Link at ali shows B140QAN01.5, my advice - be very careful with this one. This panel have bad batch from factory, other buyer described defects here at the end. I also tested some 1.5 panels from local seller all with same defect! Better ask seller about that so it does not turn into a lottery.

TPFanatic wrote:
Wed Dec 12, 2018 10:38 pm
It's a 40 pin EDP screen I wonder what would happen if I plugged it in?

edit: Not going to try.
Better not, pins can be different.

It makes me wonder about 4k kit for panel like LP140UD1 (3840×2160), mostly because lenovo still does not provide 4k screen option for 14" thinkpad. Dunno whether it is possible, ite chip is already heated pretty well.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Thu Dec 27, 2018 10:27 pm
by TPFanatic
That someone was able to put a 14" UHD / 4K 3840x2160 LCD into his T480, because it also uses 4 lane eDP, makes me wonder if those 4 lane 14" 3K and 4K LCDs would work with these machines, since with eDP the pinouts are more standardized, I believe. More information would be needed to know how the QHD kit actually works regarding supported screens. Does it emulate the EDID of the supported screens, that are programmed manually into the adapter board, or would any eDP screen work? I suspect it is the former, because certain screens are confirmed to not work.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Jan 20, 2019 12:16 am
by TPFanatic
I want to share it is eBay user "browngranite" who listed an "Exact" "2560x1440" "AU Optronics" screen that I bought from them, but they sent me a 2880x1600 Samsung and tried to pass it off as "compatible". Since the Negative feedback for eBay sellers thread is closed, figured I'll throw this here, since it is for my QHD project I tried to order from them.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Jan 20, 2019 7:15 am
by RealBlackStuff
From what I have seen over the years, "browngranite" never sells any "real" screens, they are THE knockoff-specialists.
DO NOT BUY ANYTHING FROM THEM.
Apart from that, they are usually way too expensive as well.

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sat Feb 23, 2019 11:27 pm
by RMSMajestic
For those of you who got the last batch of kits, due to the mess of paypal blocking buyer emails, please get the guide here:
https://www80.zippyshare.com/v/quqxchvD/file.html

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Mar 17, 2019 1:00 am
by ji2o0k
Took me some time to getting around to it but I found time this weekend to install the WQHD mod kit and LP140QH1(SP)(A2) screen into my T420s. I mistakenly bought the LP140QH1(SP)(A2) screen not knowing it was glossy but oh well.

I purchased the screen from notebookaid ebay seller and had asked they send me the exact panel - which luckily they did (I think).

As others have mentioned, the cable was tricky as it was hard to flex around the palmrest chasis mounting hole and any bending would cause the cable to pop out of the mod kit. I found this the trickiest part and much harder vs. the FHD mod kit.

Finally got it installed with some finesse but I think the panel I received has some defect as there are a couple of large red blemishes in the middle of the screen when viewed against a black backdrop. You can see my pics below. I'm pretty sure I didn't touch the back of the panel or apply any pressure during the install, I'm pretty careful and previously installed three FHD mod kits and panels with no issues. So I hope it wasn't me and me clumsily wrecking the panel.

Otherwise, once booted up and viewing the screen against colour or images - it is gorgeous. Though the red blemishes and the thought of them will bother me, so I might get a non-glossy screen eventually.

What do others think? Bad panel or did I wreck my panel during the install?


Red blemishes on WQHD panel
Image
Image
Image

Screen with an image on it:
Image

Re: T420s/T430s WQHD - Install/troubleshoot/Picture thread

Posted: Sun Mar 17, 2019 2:26 pm
by ji2o0k
ok, confirmed it is the panel itself.

I actually ordered two panels from notebookaid with my order and I just installed the second panel - no blemishes.

I'll see if notebookaid will offer some form of credit or partial refund - though probably not since it has been a year etc.