Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T-520 Rebuilt, new Bluetooth 4 60y3303, but F5 not working

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
wsalomon
Posts: 44
Joined: Sat Nov 17, 2012 6:24 pm
Location: Boston, ME

T-520 Rebuilt, new Bluetooth 4 60y3303, but F5 not working

#1 Post by wsalomon » Fri Jan 18, 2019 6:03 pm

I'm at the end of a rebuild cycle for two T-520's with Optimus 04W3254 planars. (This follows rebuilding of some T-61's with new stock 44C3933 planars, where I had to solve this Bluetooth problem first which was successful.)

The build is with a clean install of Windows 10 x64 ver. 1809, followed by updating with Windows 10 generic drivers, with those at Lenovo's driver download area. It had been my understanding that in order to get the Lenovo Bluetooth to work, that one had to install *both* the HotKey Integration Driver (latest for this series is ver. 3.89.0100, Lenovo file 8jvu43ww.exe), and for the latest Lenovo/Broadcomm Bluetooth 4 (FRU 60Y3303) Driver (latest for this is ver. 6.5.1.6770, Lenovo file r00bt05w.exe). I did this which worked perfectly with an old HotKey Driver for the T-61, but not in the T-520.

The problem is the F5 key does not toggle the "Radios" On and Off. I assume the black back-grounded Radio pop-up for F5 is similar to the of the T-61, where each "Radio" (meaning an Intel AC-7260 and the Bluetooth 4 is individually turned on and off. As it, with out that, each is on by default, and one can go through the drill oif turning both on/off using the front apron switch, using the Windows 10 tray control for Wireless, and drilling down into "Settings" to turn off the Bluetooth.

In one post for the T-61, there was a suggestion of using the Lenovo Connections tool as a third driver with the other two, but in opening the Setup, there is nothing about Bluetooth mentioned with all the other connection options.

Is this a case where some versions of the HotKey Integration Driver work, and others do not? If so, can someone suggest a working version, and where to find it?

Another thing I found interesting - Windows 10 cannot locate the module on its own. Most hardware with drivers like these have PCI ID's like... PCI\VEN_xxxx&DEV_yyyy (helpful in finding PCI drivers in a DCI driver database. However, the one for the 60Y3303 is USB\VID_0A5C&PID_21E6 (Also interesting is the the Intel AC-2760 has its own Bluetooth (disabled) with an ID of USB\VID_8087&PID_07DC. Some posters have mentioned that keeping the Bluetooth active on the AC-2760 impairs its WiFi speeds, hence the disabling).

BTW, the Bluetooth 4 60Y3303 and Intel AC-2730 WiFi combination works perfectly in the T-61's.

vgiozo
Posts: 17
Joined: Wed Mar 11, 2020 6:32 am
Location: Thessaloniki, Greece

Re: T-520 Rebuilt, new Bluetooth 4 60y3303, but F5 not working

#2 Post by vgiozo » Wed Mar 11, 2020 3:58 pm

So can the 60y3303 BT 4.0 module function in the T520, despite not being included in the Hardware Maintenance Manual's compatible FRUs?

I have a non-BT Wifi module (Intel 6300) and my T520 came without any preinstalled BT daughter-board.

Since my wifi-module includes no BT, the 60y3303 BT 4.0 chip should work without hassle?

Not a big expense at under 4 EUR, anyway but why do unnecessary things?
T520 4243-AF5 (R9-KKBG3), HD+ 1600*900, i5 2520m, 2*8GB DDR3L 1333, Plextor mSATA, 2*500GB HDD (caddy), no eSATA, 4*USB 2,0, no modem

MikalE
ThinkPadder
ThinkPadder
Posts: 1153
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: T-520 Rebuilt, new Bluetooth 4 60y3303, but F5 not working

#3 Post by MikalE » Thu Mar 12, 2020 11:43 am

I upgraded my T520 to BT 4.0, but I don't remember what card FRU it is.

My BIOS has also been upgraded with the whitelist removal.
A31p P-IV 2Ghz 2653-R6U
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7QM 4242-4UU Highly Modified

vgiozo
Posts: 17
Joined: Wed Mar 11, 2020 6:32 am
Location: Thessaloniki, Greece

Re: T-520 Rebuilt, new Bluetooth 4 60y3303, but F5 not working

#4 Post by vgiozo » Thu Mar 12, 2020 7:25 pm

MikalE wrote:
Thu Mar 12, 2020 11:43 am
I upgraded my T520 to BT 4.0, but I don't remember what card FRU it is.

My BIOS has also been upgraded with the whitelist removal.
Since I posted this question I found this think-wiki informational post, which says that the BT daughter cards are not restricted by the BIOS, so one should be able to fit newer ones, if they fit the connector type
http://www.thinkwiki.org/wiki/Bluetooth ... _Card_slot
T520 4243-AF5 (R9-KKBG3), HD+ 1600*900, i5 2520m, 2*8GB DDR3L 1333, Plextor mSATA, 2*500GB HDD (caddy), no eSATA, 4*USB 2,0, no modem

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 22 guests