Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T420s Bluetooth Installation Problems

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
sparta.rising
Senior Member
Senior Member
Posts: 890
Joined: Tue Nov 29, 2005 1:27 pm
Location: Boston, MA

T420s Bluetooth Installation Problems

#1 Post by sparta.rising » Mon Jun 03, 2019 6:59 pm

I have a T420s that came without bluetooth. I'm running Windows 10. I bought a Bluetooth 4.0 daughter card FRU 60Y3303. I installed it under the palmrest. I flashed the modified 1.46 BIOS that removes the whitelist from MyDigitalLife. Bluetooth IO access is enabled in the BIOS. The bluetooth card still doesn't show up in the Device manager. I've seen it suggested in other threads that bluetooth power is default off, and that you need to turn it on in the FN+F5 wireless control window. However, unfortunately, I installed the most recent Lenovo System Interface drivers and Lenovo Vantage, which get rid of the Thinkpad power windows and open the Windows Action Center, so I don't have a way to turn on bluetooth. Any suggestions?
Z61t - C2D 2GHz CPU - 3GB RAM - 320GB HDD - 14.1" WXGA+ - Intel 950 - Travel Bezel

sparta.rising
Senior Member
Senior Member
Posts: 890
Joined: Tue Nov 29, 2005 1:27 pm
Location: Boston, MA

Re: T420s Bluetooth Installation Problems

#2 Post by sparta.rising » Mon Jun 03, 2019 9:58 pm

I was able to use a Windows Restore point to restore back before I updated the Lenovo software which got rid of the Fn+F5 power control. Unfortunately Bluetooth isn't listed.
Z61t - C2D 2GHz CPU - 3GB RAM - 320GB HDD - 14.1" WXGA+ - Intel 950 - Travel Bezel

Screamer
Junior Member
Junior Member
Posts: 461
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: T420s Bluetooth Installation Problems

#3 Post by Screamer » Tue Jun 04, 2019 4:31 am

Could you try powering up Bluetooth via IBM_ECW? There should be a button that allows you to manually power-on Bluetooth in there.

sparta.rising
Senior Member
Senior Member
Posts: 890
Joined: Tue Nov 29, 2005 1:27 pm
Location: Boston, MA

Re: T420s Bluetooth Installation Problems

#4 Post by sparta.rising » Tue Jun 04, 2019 11:51 am

Just tried it. Hitting the Power on Bluetooth button caused the laptop to shutdown/hibernate with a low battery alarm. Removing the battery and hitting the button again did nothing. Maybe I got a bad Bluetooth card.
Z61t - C2D 2GHz CPU - 3GB RAM - 320GB HDD - 14.1" WXGA+ - Intel 950 - Travel Bezel

sparta.rising
Senior Member
Senior Member
Posts: 890
Joined: Tue Nov 29, 2005 1:27 pm
Location: Boston, MA

Re: T420s Bluetooth Installation Problems

#5 Post by sparta.rising » Mon Jun 10, 2019 5:08 pm

Back at it. I returned the new, potential knockoff bluetooth card and bought a tested working pull off card. Still having the same issue.

Went through a Lenovo troubleshooting tutorial and checked the airplane mode settings. No luck.

Any other suggestions?
Z61t - C2D 2GHz CPU - 3GB RAM - 320GB HDD - 14.1" WXGA+ - Intel 950 - Travel Bezel

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20346
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T420s Bluetooth Installation Problems

#6 Post by RealBlackStuff » Tue Jun 11, 2019 11:21 pm

Keep that BT for the moment.
Get an Intel 7260 AC / BT4.0 wifi card like this: https://www.ebay.com/itm/392311923338
On some machines you need to tape/cut pin 51, see viewtopic.php?t=124104
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 16 guests