Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T520 Windows 10 Fresh Install Issues - AC/SOUND

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
cage
Posts: 18
Joined: Thu May 18, 2006 4:37 pm
Location: Canada

T520 Windows 10 Fresh Install Issues - AC/SOUND

#1 Post by cage » Sat Sep 14, 2019 3:24 pm

I just installed Windows 10 Pro on my Thinkpad that is docked in a Thinkpad Dock Series 3 4337.

Upon boot I get a message stating the following:

Docking Station AC Power Problem
AC Power is detached from your docking station. For proper battery charging and docking station operation, connect the AC Adapter to the docking station.

The battery is plugged in and charging.

Audio also does not work from the dock itself. I have the a 3.5mm cable going from the speaker output on the dock to my speakers and it produces no sound.

Sound does work from actual speakers from laptop when not docked and using the headphone out jack on the laptop itself also works.

This setup works fine under Windows 7 Ultimate. Windows 10 Pro seems to not like this dock at all.

Any others experienced similar issues?

Suggestions would be appreciated.
T520 4239-CTO
T420 4180-AP3
T60P 2007-93U
T30 2367-61U
310ED

dr_st
Moderator
Moderator
Posts: 8095
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T520 Windows 10 Fresh Install Issues - AC/SOUND

#2 Post by dr_st » Sun Sep 15, 2019 12:57 am

cage wrote:
Sat Sep 14, 2019 3:24 pm
Docking Station AC Power Problem
AC Power is detached from your docking station. For proper battery charging and docking station operation, connect the AC Adapter to the docking station.
Do you get this message every time? Does the OS detect if you unplug and replug the AC adapter to the dock?

Also, try updating the Power Management driver.
cage wrote:
Sat Sep 14, 2019 3:24 pm
Audio also does not work from the dock itself. I have the a 3.5mm cable going from the speaker output on the dock to my speakers and it produces no sound.
This typically requires an update to the audio driver (I guess it's Realtek). I've experienced similar behavior with Win8.1 and Win10 on these docks before updating the driver.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

cage
Posts: 18
Joined: Thu May 18, 2006 4:37 pm
Location: Canada

Re: T520 Windows 10 Fresh Install Issues - AC/SOUND

#3 Post by cage » Tue Sep 17, 2019 10:43 am

It seems that Windows 10 missed some important drivers. I installed Lenovo Vantage from the windows store and that picked up two missing drivers.

Conexant Audio Software for Windows 10 (32-bit, 64-bit), 8 (32-bit, 64-bit) - 8.32.43.0 11 Oct 2012
This package installs the software (Audio software) to enable the following device. - Conexant 20672 SmartAudio HD

8aax04ww.exe

CRC32: A19F1FA8
MD5: 0B6E8210EE07E727B24B65FFF771302C
SHA-1: AE76CC3FF3615D21DDC9832DDCE47EA7C1BC5EAB
SHA-256: 35D83723E528A2E1CD5CEB0C9B55885069C898D0E3477287C3C07EF0B8FF61C2

Ricoh Media Card Reader Driver for Windows 10 (32-bit, 64-bit), 8 (32-bit, 64-bit) - 2.22.18.01 11 Oct 2012

8axw02ww.exe

CRC32: 00432923
MD5: 48871DCD4B120B0943EBB37457303A67
SHA-1: DA8D0C2411F323C59B6A85A4DB5CEA79F03B8F40
SHA-256: 337A9028F613BFF47B2F4363B7117BAE17A94E20D52F8A3386D615C96B9771A7

The AC power docking problem seems to have fixed itself.

Previously I plugged/unplugged the ac adapter while in the dock and it would continually give this error. I removed the laptop from the dock and used it on battery for around 5 minutes and put it back in the dock and it's not displaying this error anymore. I'm not sure if those 2 drivers made any difference in this regard but that ac docking problem has mysteriously disappeared.

The Lenovo Vantage program from the windows store includes a section for battery wear that you can adjust as the power manager software from Lenovo does not have a Windows 10 version.

As of this point everything seems to be working as it should.
T520 4239-CTO
T420 4180-AP3
T60P 2007-93U
T30 2367-61U
310ED

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 17 guests