Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

[Solved]T520 Left Click Track and Touch buttons not working

T400/T410/T420 and T500/T510/T520 Series
Post Reply
Message
Author
Eugor
Posts: 33
Joined: Sun Jun 02, 2019 8:41 pm
Location: Whitehouse, TX

[Solved]T520 Left Click Track and Touch buttons not working

#1 Post by Eugor » Sat Jan 23, 2021 2:08 pm

I just acquired a T520 with no os loaded.
Used linux on thumbdrive to test out machine.
Left click on track button and touch button do nothing at all. Right click works as it should.
When an external usb mouse is attached, left click did not work either.
I disabled both the trackpad and touchpad in bios, and now an external usb mouse functions as it should.
My question is, where should I look to track down where the problem is ? or is this likely a mainboard circuit issue ?

Thank You
Last edited by Eugor on Sun Jan 24, 2021 8:49 am, edited 1 time in total.

dr_st
Admin
Admin
Posts: 8805
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T520 Left Click Track and Touch buttons not working

#2 Post by dr_st » Sun Jan 24, 2021 2:06 am

If you are lucky, it's just the touchpad that's faulty. Try enabling the trackpoint and leaving the touchpad disabled. If that works, you can replace the touchpad (or just leave it disabled).

If that doesn't work, then it's likely a trackpoint issue, and you need to replace the keyboard (as it's integrated).
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2824
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T520 Left Click Track and Touch buttons not working

#3 Post by axur-delmeria » Sun Jan 24, 2021 2:54 am

The Trackpoint and touchpad share the PS/2 mouse port, so any issue with one affects the other.
If disabling either touchpad or trackpoint in the BIOS doesn't solve it, try disconnecting the touchpad cable. Make sure the charger is disconnected and the battery is removed beforehand.

If the problem disappears, then it's most likely the touchpad. If it doesn't then it's the trackpoint.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

Eugor
Posts: 33
Joined: Sun Jun 02, 2019 8:41 pm
Location: Whitehouse, TX

Re: T520 Left Click Track and Touch buttons not working

#4 Post by Eugor » Sun Jan 24, 2021 8:49 am

dr_st wrote:
Sun Jan 24, 2021 2:06 am
If you are lucky, it's just the touchpad that's faulty. Try enabling the trackpoint and leaving the touchpad disabled. If that works, you can replace the touchpad (or just leave it disabled).

If that doesn't work, then it's likely a trackpoint issue, and you need to replace the keyboard (as it's integrated).
Good call. Thank You. Enabling the trackpoint only worked. I only use the trackpoint or ext mouse anyway. Don't care for the touchpad.
Thanks again.

Eugor
Posts: 33
Joined: Sun Jun 02, 2019 8:41 pm
Location: Whitehouse, TX

Re: T520 Left Click Track and Touch buttons not working

#5 Post by Eugor » Sun Jan 24, 2021 8:51 am

axur-delmeria wrote:
Sun Jan 24, 2021 2:54 am
The Trackpoint and touchpad share the PS/2 mouse port, so any issue with one affects the other.
If disabling either touchpad or trackpoint in the BIOS doesn't solve it, try disconnecting the touchpad cable. Make sure the charger is disconnected and the battery is removed beforehand.

If the problem disappears, then it's most likely the touchpad. If it doesn't then it's the trackpoint.
Thank you. Bad touchpad, and I do not like using that anyway. I will leave it disabled.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/T410/T420 and T500/T510/T520 Series”

Who is online

Users browsing this forum: No registered users and 18 guests