Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T520 Nvidia issue (drivers? PSU?)

T400/T410/T420 and T500/T510/T520 Series
Post Reply
Message
Author
danapad
Posts: 2
Joined: Fri Jul 30, 2021 7:55 pm
Location: Ljubljana, Slovenia

T520 Nvidia issue (drivers? PSU?)

#1 Post by danapad » Fri Jul 30, 2021 8:30 pm

Hi,

I have a problem with using my laptop's graphics card.

Specs: Thinkpad T520, Nvidia graphics card, quad core CPU, 90W PSU

I first installed Windows 10 and tried using the drivers someone suggested in this thread: viewtopic.php?p=858976#p858976. They installed fine, and I was actually able to run Windows while using the Nvidia -- but the moment I turned on the keyboard light on Thinkpad, the system froze. This happened two times in a row, and the third time it just booted to a black screen.

I then installed Manjaro, chose the free drivers (Nouveau https://wiki.archlinux.org/title/Nouveau) since official Nvidia drivers no longer work /w Manjaro, but that too resulted in the system freezing before the login screen appeared.

After poking around these forums, I started to suspect my 90W PSU and quad core CPU are to blame, and that I may need a stronger PSU, especially since turning on the keyboard light on Windows froze the system. Either that, or I'm missing something important with regards to Nvidia drivers.

In any case, I'd appreciate any thoughts or suggestions. Integrated graphics works perfectly fine for what it's worth.

dr_st
Admin
Admin
Posts: 9175
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T520 Nvidia issue (drivers? PSU?)

#2 Post by dr_st » Sat Jul 31, 2021 1:06 am

Welcome to the forum. :) Indeed the recommendation is to use a stronger PSU (at least 135W) for Quad Core CPU + nVidia, although I am not certain an underpowered PSU would lead to these exact symptoms.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad

danapad
Posts: 2
Joined: Fri Jul 30, 2021 7:55 pm
Location: Ljubljana, Slovenia

Re: T520 Nvidia issue (drivers? PSU?)

#3 Post by danapad » Sat Jul 31, 2021 12:16 pm

Well, I'm also wondering what other users who have a T520/T420 are using. I'm happy to install any drivers or even switch operating systems at this point. I'll even use Windows if absolutely forced to ...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/T410/T420 and T500/T510/T520 Series”

Who is online

Users browsing this forum: No registered users and 29 guests