Page 1 of 1

SL500 does not work without the power adapter and detects the battery with the power adapter

Posted: Sat Jan 05, 2019 4:06 pm
by Madodream89
SL500 does not work without the power adapter

Yesterday night I was using my SL500 on battery power and all of a sudden it just powered off. I thought the battery may have discharged without any warning and later plug the chage of battery and I went to sleep.

the next day I woke up and I am shocked to know that I need the power laptop but, the laptop not start. It does not work on battery at all. Even the battery indicator LED does not glow. It just blinks once when the power cord is plugged in and does not glow when the laptop is working (on adapter). Crux of the issue is that my laptop has turned into a desktop and I need to keep it connected to power outlet to use it.

but the battery yes detect with the power adapter on. i try unplug laptop off. not starts without the power adaptor. so form of rebirth this battery so well i buy in ebay

so well had some detalls and sorry for the bad english

lenovo thinkpad battery 41++ panasonic 42t4620

lenovo thinkpad sl500 274643s

manjaro 18.1 65bits +windows 7 32bits

Re: SL500 does not work without the power adapter and detects the battery with the power adapter

Posted: Sat Jan 05, 2019 4:55 pm
by Thinkpad4by3
Battery can be detected but dead. Likely that is the case. It's a 2009 machine so it isn't unreasonable to have a fully flat battery. If getting a new OEM one doesn't fix it...your Motherboard will likely need replacing.