Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Touchpad buttons not working as expected

W500/510/520 and W700/710 series specific matters only
Post Reply
Message
Author
Don6558
Posts: 2
Joined: Wed Nov 21, 2018 12:15 pm
Location: Langley BC, Canada

Touchpad buttons not working as expected

#1 Post by Don6558 » Wed Nov 21, 2018 2:00 pm

It started with right touchpad and touch point right buttons not working.
I suspected a virus so only tried to reinstall the touchpad driver. That did not work so I b/u my data and reformated the hdd. I then reinstalled win 7 and the drivers.
I now had no touchpad.
I researched some more and found the specific Synaptics driver and tried to install. It reported no device found. I opened up the laptop and found the ribbon cable, on the underside of the touchpad, had worked itself disconnected. (I'm a commecial truck driver and the Canadian and American Interstates are horribly rough.)
I reinserted the the ribbon cable and restarted the computer. Now I'm back to where it was before reinstalling windows and drivers.
If all the symtoms were consistant I would try and replace the touchpad but there is more.
I start the computer and my mouse pointer will pull up the Auto Hide Task Bar. Let the computer run a while and I loose this capability. (Now and before the Clean Windows reinstall). I use the windows button to bring up the task bar and use the mouse pointer to select and open an icon and there is now no button response. Same happens with my plugged in usb mouse. The differance between the touchpad and the mouse is that the right mouse button works. Once I press the right mouse button I can move the pointer over an icon and left click either the touchpad or mouse left button and it will activate/open the icon. This is why I suspected a virus and performed clean install.
I opened mouse settings and switched the buttons. I was then able to press the left button on the touchpad and the context menu would open. Pressing the right button on the touchpad did not work. There was no response.
I then restarted my computer in safe mode. Same problems.
I think I may have 2 problems here, the button problem and maybe another driver/service interfereing with the pointing devices.
And that brings me here.
Any ideas would be greatly appreciated.

Screamer
Junior Member
Junior Member
Posts: 269
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: Touchpad buttons not working as expected

#2 Post by Screamer » Fri Nov 23, 2018 4:11 am

Have you tried the touchpad buttons in Linux, via a Linux live CD/USB?

Don6558
Posts: 2
Joined: Wed Nov 21, 2018 12:15 pm
Location: Langley BC, Canada

Re: Touchpad buttons not working as expected

#3 Post by Don6558 » Fri Nov 23, 2018 11:38 am

Great idea, I've never done this before.

(I hate to assume but...) I boot to a linux o/s, eliminating Windows and it's drivers from the problem essentialy isolating it to the hardware?

If my understanding of your suggestion is wrong, please let me know, otherwise I will give it a try in a couple of hours, when I get home.

Screamer
Junior Member
Junior Member
Posts: 269
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: Touchpad buttons not working as expected

#4 Post by Screamer » Fri Nov 23, 2018 12:21 pm

No worries, your assumption is right. I should have explained the purpose of doing that in the first place, my bad.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/510/520 and W7x0 Series”

Who is online

Users browsing this forum: TPFanatic and 6 guests