Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

New owner of w520

W500/W510/W520 and W700/W701 Series
Message
Author
Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#31 Post by Masi_K » Fri May 15, 2020 12:24 pm

I got the clock work by editing linux settings..

But what bugs me still is how on earth my usb bluetooth dongle doesn't connect paired devices when booting to linux and or booting back to windows. If I pair a sound device to windows then boot to linux and pair it there and boot back to windows. Dongle doesn't then connect to the sound device untill I remove it from the paired list and pair it again. And vice versa. What is going on ?
600A->T20->T43->T61->W520 ->T14gen1 AMD

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 23907
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: New owner of w520

#32 Post by RealBlackStuff » Sat May 16, 2020 12:17 am

Cheap/bad BT dongle?
Allow Device Settings to switch BT off to save power?
Lovely day for a Guinness! (The Real Black Stuff)

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#33 Post by Masi_K » Sun May 17, 2020 5:01 am

Yes it is quite cheap. But works like charm after pairing. In win10 or linux. Power off is allowed.
600A->T20->T43->T61->W520 ->T14gen1 AMD

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#34 Post by Masi_K » Sat Jun 06, 2020 10:24 am

Got the bluetooth working. It was again issue with dualboot. Reason to described issue is bt connection encryption key what is every time different when a device is paired. Key is saved to the dongle and in OS. So Linux had own key and windows too. Again against instructions I paired device in windows and then copyed windows key to linux overwriting it's own key. Worked ever since.
600A->T20->T43->T61->W520 ->T14gen1 AMD

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#35 Post by Masi_K » Sat Jan 02, 2021 7:35 am

Yesterday I installed fresh w10 to this machine. All other drivers than ATM and disabled the atm serial port device. Everything is working absolutely fine except battery power state. After install windows said that the battery is fully charged after 4.5hours and it was then 50% done. That can not be possible even when it said the same time after an hour of being plugged in.

Today I used the battery all the way untill machine shut down. That was 3% battery left. After it was cooled down I plugged it in and charging was stopped again to the 57%.

What is going on? Charging was working correctly before fresh install. Battery is 2 months old 9cell OEM one. This machine is now replaced with net T14 and w520 is from now on solely doing car tuning stuff. So working battery is nro one.
600A->T20->T43->T61->W520 ->T14gen1 AMD

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#36 Post by Masi_K » Sat Jan 02, 2021 9:57 am

Fired up a partition magic linux pack. In that there is nice battery monitor that gives a lot of information about battery and chargin system. That too said that the battery is not charged more than 57% and it would take 20hours to charge to 100%. In windows at idle it would take 5hours to drain the battery at idle consumption. Before reinstall windows it gave me like 8hours and 100% charge level.

This is getting weird. CMOS reset, maybe ?

CMOS reset did not change a thing. :(
600A->T20->T43->T61->W520 ->T14gen1 AMD

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 17304
Joined: Sun Feb 25, 2007 11:28 am
Location: Belgrade, Serbia

Re: New owner of w520

#37 Post by ajkula66 » Sat Jan 02, 2021 4:59 pm

Shut the system down and let it charge the battery.

Power back on in let's say 6 hours and let us know what happened.

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

One FlexView to rule them all: A31p

Abused daily: T520, X200s


PMs requesting personal tech support will be ignored.

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#38 Post by Masi_K » Sun Jan 03, 2021 12:50 am

Hi
I installed Vantage software and ran battery calibration from there. It took aprox 12 hours and software did not get to the 3/3 stage but it did the trick. :banana:
Now it is 100% and 6.7hours of idle ahead in Windows.
Booted up in linux again and saw that it is now charged up to 69.9mWh and therefore 100% charged. But designed capacity is 47mWh. So what if for some reason charge unit in the mobo was charging it only to the designed capacity and no more?

Battery is OEM and it is power one. One row more than normal.
600A->T20->T43->T61->W520 ->T14gen1 AMD

atagunov
Senior Member
Senior Member
Posts: 922
Joined: Thu Apr 02, 2020 3:11 pm
Location: London, UK

Re: New owner of w520

#39 Post by atagunov » Mon Jan 04, 2021 7:44 am

Masi_K wrote:
Sun Jan 03, 2021 12:50 am
linux ... saw that it is now charged up to 69.9mWh .. But designed capacity is 47mWh
Is it a 6-cell or 9-cell? I think 6-cell sits flush with the laptop and 9-cell definitely protrudes from the back
X220, 2 *T520

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#40 Post by Masi_K » Mon Jan 04, 2021 9:42 am

9-cell.
600A->T20->T43->T61->W520 ->T14gen1 AMD

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#41 Post by Masi_K » Sat Feb 05, 2022 1:13 am

Looks like I'm started to use Ubuntu more and more with this laptop. Most usage fustration gives the trackpoint. I think I have the better? driver installed. But it stil feels nothing else than very unaccurate joystic than what it is in any windows version. How I can improve it if possible ?

What I have found with linux better vs windows 10 is heat production. With ubuntu w520 runs way cooler. I don't use nvidia gpu at all in either os s.
600A->T20->T43->T61->W520 ->T14gen1 AMD

Masi_K
Freshman Member
Posts: 101
Joined: Sat Aug 16, 2008 2:34 am

Re: New owner of w520

#42 Post by Masi_K » Wed Feb 09, 2022 3:14 pm

Yes. I had the better librdiver installed before. This time I made to the end including all config files and rows of text in them.
I think it is now best as it can be. Have to do some testing to make sure.
600A->T20->T43->T61->W520 ->T14gen1 AMD

rdchinoy
Posts: 20
Joined: Sun Apr 03, 2022 2:00 am
Location: Vijayawada, India

Re: New owner of w520

#43 Post by rdchinoy » Wed Apr 13, 2022 6:49 am

Links are still down.
Interested in the 1.46 with white list removed and advanced features unlocked for W520
Any help appreciated.

Shredder11 wrote:
Sun Dec 22, 2019 8:49 am
I obtained versions 1.45 and 1.46 last year from trusted uploader Serg008 on the MDL forums, and both have WLAN WList check removed + RAM Speed Unlocked.

Lenovo ThinkPad W520_1.45-(8BET65WW)-8buj24us__nWL_RAMunl.rar

https://mega.nz/file/AQYmTbDS#HBTrEB9BV ... i6Ob51SlLM * NEW LINK - PREVIOUS ONE ON MEDIAFIRE EXPIRED


WLAN WList check removed + RAM Speed Unlocked
Lenovo_ThinkPad_W520_1.46-8BET66WW-8buj25us__nWL_RAMunl.rar

https://mega.nz/file/gJZiGA4Z#mHGvc3lQn ... ERHC7x6cfo * NEW LINK - PREVIOUS ONE ON MEDIAFIRE EXPIRED

WLAN WList check removed only
Lenovo_ThinkPad_W520_1.46-%25288BET66WW%2529-8buj25us__nWL.7z

http://www.mediafire.com/file/bd8lralhglw49pl/ LINK DEAD - NEED TO FIND A NEW WORKING SOURCE

Shredder11
Junior Member
Junior Member
Posts: 368
Joined: Sat Jun 30, 2012 6:25 pm
Location: Bradford, West Yorkshire, England

Re: New owner of w520

#44 Post by Shredder11 » Wed Apr 13, 2022 6:55 pm

rdchinoy wrote:
Wed Apr 13, 2022 6:49 am
Links are still down.
Interested in the 1.46 with white list removed and advanced features unlocked for W520
Any help appreciated.
That's odd..... I just checked using my browsers incognito mode, to make sure I was not logged in to my mega.nz account and appear as a random stranger etc. The download worked just fine. I can try dropbox instead if you like, but a bit baffled at why it failed for you.
Z61p x3 (C2D T7600, 3GB, 500GB SSD, BCM70015, Advanced Dock x1, Mini Dock x2)
W520 (C2Q i7-2720QM, 8GB, 60GB SSD)
X61 (C2D T7500, 3GB, 250GB SSD, BCM70015)
X61s (2GB, 120GB SSD)
T43p (P M 760, 2GB, IBM Port Replicator II, 128GB SSD)
G41 (P4 3.46GHz, 2GB, 128GB SSD)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 23907
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: New owner of w520

#45 Post by RealBlackStuff » Thu Apr 14, 2022 1:35 am

@rdchinoy:
Those are working links.
You need to left-click on the link to go there directly.
Or use the double-clik/roller button on a mouse to go there in a new tab.
Or right-click on the link and then select from the Open link... options.
What you did is highlight the link and try to copy that into another tab or browser.
That does NOT work if you have ... in the link.
Lovely day for a Guinness! (The Real Black Stuff)

jfp555
Posts: 1
Joined: Mon May 13, 2024 12:00 pm
Location: **LOCATION ERROR**

Re: New owner of w520

#46 Post by jfp555 » Mon May 13, 2024 1:43 pm

Shredder11 wrote:
Sun Dec 22, 2019 8:49 am
I obtained versions 1.45 and 1.46 last year from trusted uploader Serg008 on the MDL forums, and both have WLAN WList check removed + RAM Speed Unlocked.

Lenovo ThinkPad W520_1.45-(8BET65WW)-8buj24us__nWL_RAMunl.rar

https://mega.nz/file/AQYmTbDS#HBTrEB9BV ... i6Ob51SlLM * NEW LINK - PREVIOUS ONE ON MEDIAFIRE EXPIRED


WLAN WList check removed + RAM Speed Unlocked
Lenovo_ThinkPad_W520_1.46-8BET66WW-8buj25us__nWL_RAMunl.rar

https://mega.nz/file/gJZiGA4Z#mHGvc3lQn ... ERHC7x6cfo * NEW LINK - PREVIOUS ONE ON MEDIAFIRE EXPIRED

WLAN WList check removed only
Lenovo_ThinkPad_W520_1.46-%25288BET66WW%2529-8buj25us__nWL.7z

http://www.mediafire.com/file/bd8lralhglw49pl/ LINK DEAD - NEED TO FIND A NEW WORKING SOURCE

Can't thank you enough for putting up these files. It took a surprisingly long amount of googling and searching online to reach your post. Going back to my W520 as my daily driver and preventing it from becoming e-waste.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/W510/W520 and W700/W701 Series”

Who is online

Users browsing this forum: No registered users and 32 guests