Thinkpad W520 won't turn on [+pics]

W500/510/520 and W700/710 series specific matters only
Message
Author
jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Thinkpad W520 won't turn on [+pics]

#1 Post by jcvjcvjcvjcv » Fri Dec 16, 2016 6:21 pm

Earlier this week, I dropped my W520 from about half a meter, it slipped from my fingers. Well, I picked it up; Thinkpad was fine and there was a dent in the floor :eek: . It hit the floor at the top left corner; some of the black coating is now living with the floor.. The Thinkpad continued to work fine it seemed, so I docked it and continued work. The next day I saw it had it's keyboard misplaced; the bottom left was not under the bezel anymore. Well, that was fixed quickly. The Thinkpad continued to function fine for the balance of the work week.

Then on my way home, I closed it at some point, then reopened half a minute later (sleep on lid close disabled), and everything was frozen; cursor wouldn't move, keyboard did nothing, even brightness wasn't adjustable. Holding the power button for 10s did nothing either. So I pulled the battery and reinserted. All that happened was the fan spinning, no image on screen. One battery pull later, and I get this;

After cycling the battery in and out, and pressing the power button, the ring around the button will start to blink, as if it's in sleep mode, and the ODD gives a half-second sign of life. However, even though the fan doesn't spin up, there is energy consumed and the laptop heats up around the CPU.

I found a similar situation here;
https://forums.lenovo.com/t5/ThinkPad-P ... -p/1610248
That user downgraded to a W530 and, to my knowledge, never solved the problem.

Does this mean I'm stuck with replacing the system board? I'm sort of invested in this platform with multiple docks, brand new 9-cell battery, etc.
I've also re-seated the CPU (yuck, what an overdose of goo on it), pulled RAM, HDD, SSD; no luck. It continues as described above.
It's now sitting with all power unplugged, including BIOS battery.

Does anyone have a cheaper / easier solution than replacing the system board if this doesn't work?
Last edited by jcvjcvjcvjcv on Sun Dec 18, 2016 12:48 pm, edited 1 time in total.
W520
T61

bit_twiddler
Junior Member
Junior Member
Posts: 432
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: Thinkpad W520 won't turn on

#2 Post by bit_twiddler » Fri Dec 16, 2016 11:17 pm

Here is $.02 worth of advice:

Since the keyboard was displaced, you might try reseating the keyboard electrical connector
on the motherboard; since you were getting an image on the lcd, and the cursor was frozen,
that might indicate that the motherboard is O.K., and that the keyboard connector was loosened,
or that the keyboard itself was damaged in some way.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on

#3 Post by jcvjcvjcvjcv » Sat Dec 17, 2016 3:31 am

I did that already too. And apparently it does register the 'on' button, since it starts blinking (and heating up) when you press it once.
I've also had it docked, but it also ignores the dock on/off button. Even though the light on the dock comes on and the dock's network indicator lights start blinking like they do normally.

Only a new keyboard would be a lot cheaper. The Germans (right next door) sell those a lot, since they swap out the QWERTY keyboards on US-imported Thinkpads with their own QWERTZ keyboard. Where I live, QWERTY is the norm. :D

I just wonder; is the T61 keyboard electrical compatible?
W520
T61

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on

#4 Post by jcvjcvjcvjcv » Sat Dec 17, 2016 4:08 pm

Left it a full day without any power (no battery, no BIOS battery, no AC). Reconnected BIOS battery (way to go Lenovo, making the connector stick harder to the header than the header to the board...), and docked it. Result; ODD gives sign of life for half a second, nothing else. Undocked, added battery and keyboard, and got a different kind of blinking, like 95% on, and once every second a very short time off. Removed battery and reinserted, and now it's back to the same state as yesterday. And the heatpipes above the CPU reach 45 degrees Celsius

At the worst time of the year to get anything shipped from far away. Local prices for (new) 04W2028 are €1200, €1000, €900, haha. No way I'm spending that to keep it alive. Seems all the sellers of used 04W2028 are either in the US with ridiculous $140 shipping or in China with "20-39 days" shipping, but a lot cheaper.

I could buy a new P50 for €1K, but acquiring two additional docks and chargers :x. I'd also hate to get stuck with that awful keyboard 6-row keyboard layout.
W520
T61

bit_twiddler
Junior Member
Junior Member
Posts: 432
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: Thinkpad W520 won't turn on

#5 Post by bit_twiddler » Sat Dec 17, 2016 11:44 pm

Perhaps something like this for testing?

http://www.ebay.com/itm/Original-IBM-Le ... 7#shpCntId

They list shipping Germany, if you contact them they should be able to quote you a rate.
When I try it they list shipping to Germany as $13.57. That's got to be a lot cheaper than a P50.

Another option would be to just buy another W520. They're coming off lease, I'd expect that
you could get an FHD unit for under $400 or so.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

mpcook
ThinkPadder
ThinkPadder
Posts: 1076
Joined: Tue May 25, 2004 6:58 pm
Location: Loveland, OH USA
Contact:

Re: Thinkpad W520 won't turn on

#6 Post by mpcook » Sun Dec 18, 2016 9:29 am

jcvjcvjcvjcv wrote:I just wonder; is the T61 keyboard electrical compatible?
The X220, T420, and T420s keyboards all work with the W520. Sorry I don't have any other ideas on diagnosis/repair.
Current: 2 x W520 ET, 3 x X220 i7, T420, X230 i5, T420s, MacbookPro, Dell Venue 11 Pro
Past: IBM5150-8088 500 600E 600X T20 T21 5xT23 X30 3xX31 X32 T40 T42 3xT43 T43p SL510 T60p X60T X60s T61 2xT400 T410si T400s T500-3.06GHz X200 X201 X220i5 X220i7 2xT420s

RealBlackStuff
Admin
Admin
Posts: 18185
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Thinkpad W520 won't turn on

#7 Post by RealBlackStuff » Sun Dec 18, 2016 10:14 am

As do all of the T410/T510/W510 keyboards.

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on

#8 Post by jcvjcvjcvjcv » Sun Dec 18, 2016 11:14 am

I don't see W520's for $400. There is one on the forums here for $300, but that's excluding international shipping and 21% VAT. Locally, Thinkpads are rare in general; it's mostly HP Elitebooks and Dell Precisions. Used FHD ones are all close to €600

From what I gather around the web is that the presence of a keyboard shouldn't matter at all when you can press the 'on' button on the dock. It doesn't respond to that either, except by the half second sound from the ODD and the heating up of the CPU heatpipes to 45 degrees C. It would't make any sense for it to heat up after the power button is pressed if the keyboard is death. But now I regret not having plugged in a USB stick when it froze originally. :cry:

Would be the 3rd System board failure in Thinkpads I own in under 10 years :|


###, do they glue the stupid connectors to the headers !? Just great, I ripped the speaker header off the board... I've disassembled my T61 a few times, and never had such trouble.

What other treasures will I find...?
http://i.imgur.com/hj9fO1X.jpg (401KB; 1840x1228 pixel image)
This is the bottomside of the System board, near the rear USB port. The screw dug itself into that black tape, so it stays there, even when rotating the board.

Admin edit: Please keep inline images to <50KB.
W520
T61

TPFanatic
Senior Member
Senior Member
Posts: 716
Joined: Thu Jul 30, 2015 11:29 pm
Location: Hudson, New Hampshire

Re: Thinkpad W520 won't turn on

#9 Post by TPFanatic » Sun Dec 18, 2016 12:50 pm

I used a W500 keyboard to test a T520. Only things that didn't work were Fn and Windows keys, and thus all associated combos could not be activated. Power button worked. I was apprehensive to use the Caps Lock key because there's no LED for it on the old kb.
Daily driver: lenovo T500 P9700, WUXGA, 8GB
Ultraportable: IBM lenovo X60s
Home theater: lenovo T420

Enable advanced features on older Synaptics touchpads with the registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#10 Post by jcvjcvjcvjcv » Sun Dec 18, 2016 12:56 pm

I ordered a new system board, but clicked 'confirm buy' before I realized the seller doesn't take Paypal. :?

The Thinkpad is still death. Even with pretty much everything removed, including that daughter board where I found that screw, it still gives the same result. It still does the heathing thing.

It makes me wonder. Perhaps I should put it in the oven at 60 degrees C, and see if will turn on after setting there for half an hour...
W520
T61

RealBlackStuff
Admin
Admin
Posts: 18185
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Thinkpad W520 won't turn on [+pics]

#11 Post by RealBlackStuff » Sun Dec 18, 2016 1:57 pm

That screw may have caused a "short" when the laptop fell.
Remove the screw and check for damaged circuitry under where it sat.

bit_twiddler
Junior Member
Junior Member
Posts: 432
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: Thinkpad W520 won't turn on [+pics]

#12 Post by bit_twiddler » Sun Dec 18, 2016 3:06 pm

I concur with RBS - the screw could have nicked a trace or damaged something else while it was moving around.
Also, do you see any little fuses on the motherboard?

BTW, the newer machines are significantly less serviceable (at least the 15.6" ones) than your W520.

I just spent the morning adding some RAM to a Dell m7510, and it was really painful. The keyboard had to
be completely removed (not just popped up), 6 tiny screws held it in place, there was a molding on top of
the (chicklet) keyboard that was held in place by zillions of tiny plastic tabs, there were 4 cables between
the keyboard and the motherboard that had to be dealt with...

I got this over a P50 because that machine looked even worse from a maintainability standpoint.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#13 Post by jcvjcvjcvjcv » Sun Dec 18, 2016 4:24 pm

The only thing that was damaged by the screw (as far as I can see), was the layer of black tape it was stuck in. Underneath is nothing special, the things protected by the tape are on the other side of the PCB. Even without the daughterbord the screw was found on, the system gives the same symptoms. There are no scratch marks anywhere on the board

I've not seen any 'glass' fuses, but there are some solid ones, the few I found were all good (F14 and F24 near DC connector, F8 near keyboard connector, F12 and F22 near BT card, F7 near GPU, F23 near CPU, F13 in between CPU and DC connector, F10 and F11 near the palmrest connector). And I know for a fact that power still flows, since the keyboard can still give it's blinking light, the CPU can heat up, the ODD gives a sign of life and the battery light lights up. I'm not really interested in checking voltages on it live since I'll probably just short out something else by slipping with the measuring tips. I've shorted a big rectifier once on a PSU. It blew up the solder leads around the AC input, fuse was intact, lol.

But half the board is covered with that very sticky black tape. And since they apparently don't even fix the headers to the board, it makes me wonder how many components will stick harder to the tape than to the board.

I've found W520 board schematics here;
http://www.laptopschematics.ro/thinkpad-w520-schematic/
http://www.laptopschematics.ro/wp-conte ... rboard.pdf
107 pages of drawings. And I have no idea on where to start. I'm not even sure if it's for the same board.
The board is also littered with empty places, where the schematics mention "do not stuff".

I've also had no "hard dust" like I've had with other malfunctioning PCB's where small components where blow up or off. No funny smell either.

The area around the GPU looks most nasty; as if the GPU and it's VRAM chips all took a dump on the board they are sitting on, but it's probably just some solder-related residue or something. The same can be seen around the QM67 chip. Wouldn't be the first (or 2nd, 3rd, 4th, 5th) time an nVidia part failed on me though.

The user on the Lenovo forum that had the exact same problems got back to me, he never fixed the problem.

@bit_twidller; that sounds bad. I have to admit I didn't look into fixability of P50 or it's competitors. During the W54x period, I would have bought a Precision M4800 if I had to do it all over again.
W520
T61

bit_twiddler
Junior Member
Junior Member
Posts: 432
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: Thinkpad W520 won't turn on [+pics]

#14 Post by bit_twiddler » Sun Dec 18, 2016 4:50 pm

I'm actually out of my depth at this point, but here are some ideas:

1. Does the CPU fan come on briefly and then stop at boot? It should.
If it doesn't it might mean that the connector to the fan is messed up.

2. Some motherboards have an on-board accelerometer which can
be damaged during handling. It would have to have been damaged
after you removed the motherboard, otherwise what would have
been the point of the roll cage and fancy shock mounting that
Thinkpads are supposed to have?


3. Do you see any signs of deteriorated thermal pads anywhere?
I haven't had to take my W520 apart, but my W510 had these
pathetically deteriorated thermal pads on chips other than the
CPU and GPU, and I had to replace them. You should be able to
see from the HMM whether they are required for your situation.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#15 Post by jcvjcvjcvjcv » Sun Dec 18, 2016 6:07 pm

1. No, the CPU fan doesn't move at all. CN7 (fan header) does have 6 pins though, but my fan has only four in the connector. No idea why any fan would need more than four. When I apply +5V between the red and black wire, it does spin up immediately.

2. If that is the problem, it would be a second failure, because the non-starting with the blinking light was already the case before I disassembled it. The drop to the floor was from less than a meter, and it hit hardest on the rear left corner of the lid. Lenovo states that it can hit 6000G when dropping a bare board 6 inches onto a work bench. But the board wasn't bare, the lid, frame and floor all have a cushion function, so I doubt it hit it there. And if it did; it did work a full week after that. Also; wouldn't it just impact the HDD's operation?

3. Even to my surprise; no. The GPU and CPU don't need thermal pads, they contact the heatsink directly with some thermal paste. Some other parts have these big light gray pads on them, but they all look fine. I can imagine it failing under load when these pads are detoriated, but refusing straight from the start? Then the component under it would have to be 'gone'.
W520
T61

bit_twiddler
Junior Member
Junior Member
Posts: 432
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: Thinkpad W520 won't turn on [+pics]

#16 Post by bit_twiddler » Sun Dec 18, 2016 8:14 pm

I'm assuming it doesn't beep. If the fan is good and it doesn't
spin up during POST, and you aren't getting any beeps, then
it probably is not getting to the POST in the BIOS.

Out of my depth here, it's got to be an electrical problem.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#17 Post by jcvjcvjcvjcv » Mon Dec 19, 2016 7:20 am

Yes, your assumption is right; no beeps whatsoever.

There are a gazilion parts on that system board, not to mention it could just be a defect GPU for all I know. I'll just accept the cost of a new systemboard. If that means I get another four years out of this machine for ~$150, I'm fine with that. This i7-2860QM (I see you have the same :D) is just too nice to replace already.

The guy on Lenovo forums never dropped his laptop btw.

And for completeness sake; I've checked BIOS battery voltage; it's 3.2V, well within the 2.5 - 3.3V range.
W520
T61

RealBlackStuff
Admin
Admin
Posts: 18185
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Thinkpad W520 won't turn on [+pics]

#18 Post by RealBlackStuff » Mon Dec 19, 2016 7:39 am

The drop could maybe have caused the CPU to dislocate.
Remove fan, turn screw that holds CPU to the left, lift up and re-place the CPU, turn screw to right, mount fan, retry.

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#19 Post by jcvjcvjcvjcv » Mon Dec 19, 2016 7:45 am

I already did that. It changed nothing, unfortunately.

Now if eBay finally gets it act together so I can actually pay for items...
W520
T61

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#20 Post by jcvjcvjcvjcv » Mon Dec 19, 2016 1:17 pm

Haha, that took some getting used to today, with the T61. Hitting the wrong F-keys (no big Esc and Del buttons), and that battery, lol. The (degraded from 65Wh to 37 Wh) 7-cell lasted about 80 minutes, not to mention the CPU fan that sounds like a coffee grinder half the time. I guess it needs another oil-refill.

EDIT: I guess the only component that might have cause this is the CPU. But in all those years building computers, I've never had a broken CPU. Mainly broken videocards, motherboards and power supplies.
W520
T61

nitrocaster
Junior Member
Junior Member
Posts: 487
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia

Re: Thinkpad W520 won't turn on [+pics]

#21 Post by nitrocaster » Fri Jan 06, 2017 1:51 pm

I think we could try diagnose the issue.
First of all, you need a schematic with a board view.
The fact that the fan does not spin tells that the embedded controller (EC) fails to perform early initialization. You have to find out what exactly is missing.
As I understand, the board does not turn on, the fan does not spin and the power button does not light up, right?
For those who interested in buying X220/X230 FHD kit: Read this before sending me a PM!
X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#22 Post by jcvjcvjcvjcv » Fri Jan 06, 2017 2:49 pm

The power buttons blinks (breathes), as in sleep mode. One time I got it to flicker, after having it disconnected from all power for some time. What software do you use to open the BRD file?
Correct on the not turning on and the fan not spinning up.
W520
T61

nitrocaster
Junior Member
Junior Member
Posts: 487
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia

Re: Thinkpad W520 won't turn on [+pics]

#23 Post by nitrocaster » Fri Jan 06, 2017 3:07 pm

Does the power button blink all the time when the battery or AC adapter is connected?
For a board view software, see this thread http://forum.thinkpads.com/viewtopic.php?t=121522
For those who interested in buying X220/X230 FHD kit: Read this before sending me a PM!
X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#24 Post by jcvjcvjcvjcv » Fri Jan 06, 2017 3:46 pm

No, it starts after you press the button once. Regardless of that being the TP's power button or the dock power button. And just docking it also gives the sound in the ODD.
Where is that EC anyway on the board?

Under the very sticky black tape I found more fuses; F1, F2, F4, F15, F16, F17, F18, F19, F20; also found F3; all OK.

It's now completely disassembled (except for the display ofc). The CC payment system from eBay seemed to have worked after all; the seller got three payments :roll: was kind enough to only accept one, even though it gave me only errors indicating payment was not successful. But it seems it won't arrive this week, meaning I have to make do with the T61 for another week. At least I upgraded the latter one to 4GB RAM.

Just for the heck of it I should reassemble it. Perhaps it will spring back to life, like my speakerset has done repeatedly...
W520
T61

nitrocaster
Junior Member
Junior Member
Posts: 487
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia

Re: Thinkpad W520 won't turn on [+pics]

#25 Post by nitrocaster » Fri Jan 06, 2017 4:03 pm

jcvjcvjcvjcv wrote:No, it starts after you press the button once.
Now I don't understand. What do you mean by that? Does it boot without image on the screen? Does the power button light up as usual when you turn your machine on?
jcvjcvjcvjcv wrote:Where is that EC anyway on the board?
It's U35, you can find in on the board view.
For those who interested in buying X220/X230 FHD kit: Read this before sending me a PM!
X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#26 Post by jcvjcvjcvjcv » Fri Jan 06, 2017 4:45 pm

No, the power button 'starts' blinking after you press the button.

Starting without battery;
*Insert battery; nothing happens
*Press power button; power button will start to blink (like laptop is in S3), ODD will give short sign of life, CPU will heat up
*The end

I haven't tried it yet, but I assume that if I leave it with that blinking power button, with the battery inserted, it will just burn up the ~90 Wh in the battery in perhaps two days.

It does not boot, there is no HDD activity, there is no image on any display (neither lid nor external) and there is no fan activity whatsoever.

Neither Tebo nor Honhan will open that BRD file :|
W520
T61

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#27 Post by jcvjcvjcvjcv » Fri Jan 06, 2017 5:10 pm

Ahaa, that big fat black square component where the marking seems to have been solved into the black tape's glue;

https://dl.dropboxusercontent.com/u/421 ... SC5464.JPG
W520
T61

nitrocaster
Junior Member
Junior Member
Posts: 487
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia

Re: Thinkpad W520 won't turn on [+pics]

#28 Post by nitrocaster » Fri Jan 06, 2017 6:08 pm

These symptoms remind me the story with bad EEPROM chips: https://forums.lenovo.com/t5/ThinkPad-T ... 241#M95820
When was your machine manufactured?
jcvjcvjcvjcv wrote:Neither Tebo nor Honhan will open that BRD file :|
Aw, I forgot to post a link for it. Just fixed that post.
For those who interested in buying X220/X230 FHD kit: Read this before sending me a PM!
X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#29 Post by jcvjcvjcvjcv » Sat Jan 07, 2017 5:02 pm

I read that too, but I believe mine was build later, March 2012 I believe. But it's a refurb, and I can see that there is another sticker underneat it (on the bottom of the Thinkpad). Inside I found a sticker relating to the systemboard, where it says, after a serial number; 2012/01/18 D, so I assumed it wasn't that problem. And even if it was I doubt Lenovo would replace it for free. If I send it to Lenovo service, they probably ask $1K for it to fix it..

Although they fixed my nVidia-T61 14 months past warranty after nagging them long enough :mrgreen:
W520
T61

jcvjcvjcvjcv
Senior Member
Senior Member
Posts: 726
Joined: Tue Jun 26, 2007 8:42 pm
Location: Amsterdam, The Netherlands

Re: Thinkpad W520 won't turn on [+pics]

#30 Post by jcvjcvjcvjcv » Sat Jan 28, 2017 8:24 am

I got the 'new' board early this week and finally got around to re-assembling the W520.

and...

It's alive!!!! :mrgreen:

With BIOS version 1.16, lol

I guess I'm going to enjoy the BIOS screen for a while before it's onto the Windows re-activation...

EDIT: The 'new' board is a 04W2036, not a 04W2028, which means I just lost AMT I guess. Which is perfect, saves me disabling that stuff
W520
T61

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/510/520 and W7x0 Series”

Who is online

Users browsing this forum: No registered users and 3 guests