Bluetooth issues on W500

W500/510/520 and W700/710 series specific matters only
Post Reply
Message
Author
2ndgencamaro
Posts: 16
Joined: Sat Aug 09, 2014 2:32 pm
Location: Warrington, PA

Bluetooth issues on W500

#1 Post by 2ndgencamaro » Wed Apr 19, 2017 5:11 pm

I downloaded the Bluetooth with Enhanced Data Rate Software II driver from the Lenovo site. It did not install properly and rolled the software back out. Apparently, the rollback itself was not very successful. Afterwards, I had a number of items not working properly. A few drivers were removed from c:\program files\thinkpad\bluetooth software folder. I was able to recover those from another W500 that I own. But I still have two devices in Device Manager that indicate they still do not load properly. The first item is Bluetooth Remote Control device under Human Interface Devices. It shows an error code 39 - driver may be damaged. Driver is ApsHM64.sys. I have the driver and it appears to be intact. I did a comparison to the same driver on my other W500. The second device is Bluetooth Hands-free Audio under section Sound, video, and game controllers. It has the same code 39 error (device driver may be corrupted). That driver is ksthunk.sys and it too appears to be intact based on my other W500.

This W500 is running Win7 64 bit and is a model 4063. It would not upgrade to Win10 because of the dual mode video card. My other W500 is a 4062 and is running Win10.

Any ideas on getting these devices corrected would be appreciated.

Steve

RealBlackStuff
Admin
Admin
Posts: 18206
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Bluetooth issues on W500

#2 Post by RealBlackStuff » Thu Apr 20, 2017 4:55 am

Make sure you have the hotkey drivers installed first, then reboot.
When done, you should be able to use Fn/F5 to start/stop wifi and/or BT.
And you should be able to (re)install missing BT drivers.
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

Thinkpad4by3
ThinkPadder
ThinkPadder
Posts: 1123
Joined: Sun Aug 09, 2015 9:25 am
Location: N. Bellmore, ny

Re: Bluetooth issues on W500

#3 Post by Thinkpad4by3 » Thu Apr 20, 2017 10:12 am

I'm not sure if this is totally relevant but I had an X201 and it has an issue of no WiFi and I tried driver after driver. Left it under my bed for 3 days on the charger and the WiFi worked ever since.

Sent from my E6553 using Tapatalk
Welcome to the jungle, we have FrankenPads
If you want it you're going to bleed, but that is the price to pay
And you're a very rare mobo, very hard to get
You can see the blinky lights, but you won't get them for free.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/510/520 and W7x0 Series”

Who is online

Users browsing this forum: No registered users and 4 guests