Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

W520 won’t boot with discrete graphics

W500/W510/W520 and W700/W701 series specific matters only
Post Reply
Message
Author
u666sa
Posts: 48
Joined: Tue Mar 12, 2013 11:40 am
Location: Sochi, Russia

W520 won’t boot with discrete graphics

#1 Post by u666sa » Fri Nov 29, 2019 9:00 am

W520 4270-CTO
Works fine when in BIOS NVidia optimus is enabled. In fact playing world of tanks at ~115 fps. PUBG lags at 20 fps unplayable.

If I go to BIOS and select discrete graphics and disable os detection of optimus. Then I have problems. Even with fresh windows install (7) it hangs after installing drivers and gets hot.

I remember facing this problem awhile back. I just enabled optimus and continue using notebook without trouble. Now I went to install win10 and fedora 30 and I’m facing this problem again.

What gives? Google shows me this is a common issue.

Does this mean I have a bad gpu? Or what??

chugu
Posts: 1
Joined: Tue Sep 01, 2020 7:22 am
Location: Nizhny Novgorod, russia

Re: W520 won’t boot with discrete graphics

#2 Post by chugu » Mon Sep 21, 2020 6:08 am

I have w520. it works in win7 with no issue. I tried to upgrade to win10, got a freeze at first boot after install. So i guess uprade path is not working, try clean install (need to somehow take care of license for win10 being taken care of). so your gpu is fine.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/W510/W520 and W700/W701 Series”

Who is online

Users browsing this forum: No registered users and 25 guests