Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

black screen 2 sec after Thinkpad logo

W500/W510/W520 and W700/W701 series specific matters only
Post Reply
Message
Author
winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

black screen 2 sec after Thinkpad logo

#1 Post by winkoe » Sun Jul 05, 2020 4:22 am

Greetings to you,

Thinkpad W700ds. Installed systems are Debian and Kali Linux. At startup the expected Thinkpad entry screen appears for ca 2 sec. Blindly I can select either system. On Kali the secondary screen had been activated and there the (verbose) boot sequece is beeing displayed. I can log in and thereafter the secondary screen shows my Kali background color. Meanwhile the main screen remains black.

I go to sleep mode via Fn + F4. After wakeup via Fn the main screen wakes up for about two sec, and the goes black again. When I SSH from a separate machine and try with "xrandr" I get the message "Can't open display".

How should I proceed?
Thanks and watch your health.

Vin Koehler

dr_st
Moderator
Moderator
Posts: 8663
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: black screen 2 sec after Thinkpad logo

#2 Post by dr_st » Sun Jul 05, 2020 5:40 am

Welcome to the forum, Vin.

It sounds suspiciously like the lid sensor/magnet/switch (whatever there is on a W700ds) is stuck, making the laptop think that the lid is closed. Therefore, it turns the display off.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

Re: black screen 2 sec after Thinkpad logo

#3 Post by winkoe » Sun Jul 05, 2020 6:33 am

Can't really be the reason, because the lid had not been closed for many sleep/wake cycles beforehand.

Vin

dr_st
Moderator
Moderator
Posts: 8663
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: black screen 2 sec after Thinkpad logo

#4 Post by dr_st » Sun Jul 05, 2020 8:04 am

Not suggesting that the lid has been closed, just that due to some malfunction the laptop thinks it's closed. I've seen similar symptoms due to this effect on other laptops. Unfortunately, I can't help you more than that, since I'm not familiar with the W700 series to know how this mechanism works there.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

Re: black screen 2 sec after Thinkpad logo

#5 Post by winkoe » Mon Jul 06, 2020 2:31 am

Ok. But following an alternative tack I ask myself if the batterie's low charge could be the culprit. Although the machine is continuously on external supply there had been a low battery warning before. Could the said black screen be the result of a worn out battery?

Before buying a new battery I should like to verify my suspicion. How can I?

Vin

dr_st
Moderator
Moderator
Posts: 8663
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: black screen 2 sec after Thinkpad logo

#6 Post by dr_st » Mon Jul 06, 2020 3:05 am

winkoe wrote:
Mon Jul 06, 2020 2:31 am
Although the machine is continuously on external supply there had been a low battery warning before. Could the said black screen be the result of a worn out battery?
I have not heard of a single documented case where the symptoms you describe were caused by a battery issue.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

Re: black screen 2 sec after Thinkpad logo

#7 Post by winkoe » Mon Jul 06, 2020 4:15 am

Dear dr_st,

following your initial hint I closed and opened the lid a few times and, Lo and behold! ... it's working again.

Thanks for your valuable and patient help.

Vin

dr_st
Moderator
Moderator
Posts: 8663
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: black screen 2 sec after Thinkpad logo

#8 Post by dr_st » Mon Jul 06, 2020 5:29 am

Happy I could help. :D Hope the problem does not come back! If it does, it means that some part in the lid (or the chassis) is malfunctioning, but generally it should not be too troublesome to replace.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

Re: black screen 2 sec after Thinkpad logo

#9 Post by winkoe » Thu Jul 09, 2020 6:49 am

And there we are: The misbehavior is back again. I have dismantled the palm rest, cleaned, checked connetors. All to no avail.

By logging in via SSH I receive 'dmesg' allright but really have no clue what to look for. And 'xrandr' still reports 'Can't open Display'.

Before swapping hrdware I should really wish to have some kind of verification. And still I think that there should be some kind of message to be found on the terminal. Any suggestion?

Vin

winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

blank screen 2 secs after Thinkpad logo

#10 Post by winkoe » Tue Jul 14, 2020 11:43 am

Greetings to you,

Thinkpad W700ds. Installed systems are Debian and Kali Linux. At startup the expected Thinkpad entry screen appears for ca 2 sec. Blindly I can select either system. On Kali the secondary screen had been activated and there the (verbose) boot sequece is beeing displayed. I can log in and thereafter the secondary screen shows my Kali background color. Meanwhile the main screen remains black.

I go to sleep mode via Fn + F4. After wakeup via Fn the main screen wakes up for about two sec, and the goes black again.

With Debian the secondare screen had not been activated. However I can SSH from a separate machine and work on the terminal. From 'dmesg' I get no clue.

How should I proceed?
Thanks and watch your health.

winkoe

winkoe
Posts: 10
Joined: Sat Nov 12, 2016 11:24 am
Location: Aschaffenburg, Bavaria

Re: blank screen 2 secs after Thinkpad logo

#11 Post by winkoe » Sun Jul 19, 2020 2:56 am

As a matter of fact there are two harddisks installed. After the bios-POST I'm free to select either for booting. One of them contains Debian, the other one hosts Kali and other Linuxes that I wanted to try out. All that worked fine for years.

But lately the screen goes blank even before I can select a drive. But booting continues into the default OS. Once there as indicated by the indicator LEDs, I can connect via SSH from a separate machine.

Removing any of the harddisks does'nt make the fault go away.

I was hoping that there might be some kind of message to be found about what goes wrong during POST. There are no beeps.

winkoe

dr_st
Moderator
Moderator
Posts: 8663
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: black screen 2 sec after Thinkpad logo

#12 Post by dr_st » Sun Jul 19, 2020 5:30 am

Winkoe,

I've merged your new topic with the exact same topic you've opened 2 weeks ago. This is not a Linux issue, and looks very much like a hardware issue, like I described. You may disagree with my analysis, and in fact, it is possible my assumption is wrong, but please do not double-post, ignoring previous discussions. This will likely get everyone confused and won't help you in solving the problem.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

unixed
Sophomore Member
Posts: 125
Joined: Fri Sep 04, 2015 7:41 pm
Location: Oxford, UK

Re: black screen 2 sec after Thinkpad logo

#13 Post by unixed » Sun Jul 19, 2020 12:39 pm

winkoe wrote:
Thu Jul 09, 2020 6:49 am
And 'xrandr' still reports 'Can't open Display'.
Use "ssh -X" instead of just "ssh". Read the ssh man page. xrandr is telling you that $DISPLAY is not set.
However then just typing xrandr will give you the details for the machine you are using to ssh into the W700ds.
Try using
xrandr -d :0.0 -q
instead (you don't need ssh -X in this case).

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/W510/W520 and W700/W701 Series”

Who is online

Users browsing this forum: No registered users and 11 guests