Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Issue with Thinkpad A30p & Thinkpad Dock II(2877)

R, A, G and Z series specific matters only. NOT for AMD-Ryzen.
Post Reply
Posts: 38
Joined: Sun May 14, 2006 2:29 pm
Location: Winchester, VA

Issue with Thinkpad A30p & Thinkpad Dock II(2877)

#1 Post by larrystotler » Wed Sep 21, 2016 1:02 pm

I have a Thinkpad A30p that I'm having some issues with the docking station. I actually have 2 of the docks. When I use my R52 on either, everything works fine. A DVD or hard drive in the Ultrabay is detected and works, the passthroughs work and the PCMCIA slots work.

However, when my A30p is attached, not only does it not see the ultrabay or the PCMCIA slots, it also doesn't see the onboard PCMCIA slots. I have a TPLink AR9XX minipci wireless card in it, and it made no difference when it was removed. If I have the A30p boot off the dock, the PCMCIA is detected. If I dock the laptop after booting it, some of the dock is seen, but not the ultrabay.

All testing done under Linux(various kernel versions old & new)

I had the A30p and the R52 docked side by side last night and even after loading all kernel modules to match I still can't get the dock to work.

Now, I have a weird setup on the A30p with a 320GB IDE as the main drive and a 250GB IDE in the ultrabay. There are 2 different linux versions, one on each drive. I have tried with the onboard 320GB set to master and slave(have to set it to slave to use 3 hard drives - onboard and ultrabay IDE & SATA trays).

I used to have this same setup working just fine with 3 drives and then a DVD in the dock's ultrabay. Now I can't get it to see the dock's ultrabay at all.

I know the docks work because the R52 works fine on either. The R52 BIOS shows the Dock's ultrabay drive as non bootable where the A30ps BIOS doesn't show anyhting(which is how I think it always was).

I've tried using the BIOS setup defaults with no change. I have BIOS v1.18 on the A30p(1.19 is available but the update doesn't have anything useful in it.

I do have an A31p(in parts). If I can get that together I will try it to see what happens.

Anyway, I'm at a total loss. Any suggestions?

Posts: 38
Joined: Sun May 14, 2006 2:29 pm
Location: Winchester, VA

Re: Issue with Thinkpad A30p & Thinkpad Dock II(2877)

#2 Post by larrystotler » Thu Aug 31, 2017 2:37 pm

Update(almost a year later.....)

I found another A30p bottom case with a motherboard that I thought had a password but it didn't. When I hook it to the dock, everything works just fine. The unit booted up with an LCD connected to the VGA of the dock and everything on the laptop and the dock worked as expected. When I put the other A30p on the dock, I had the same issues. The dock is not seen(the LCD is missing as well).

So, I'm going to assume that the motherboard is defective in some way. Will be transferring the screen and stuff over to the other unit to make it a working system.

Kinda weird though. I wonder what the issue is.......

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad R, A, G and Z Series”

Who is online

Users browsing this forum: No registered users and 6 guests