Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

R61 Video issues - is this the NvidiaBug failure?

R, A, G and Z series specific matters only. NOT for AMD-Ryzen.
Post Reply
Message
Author
mid_mob
Posts: 3
Joined: Fri Jan 13, 2017 6:02 pm
Location: Hope, Canada

R61 Video issues - is this the NvidiaBug failure?

#1 Post by mid_mob » Tue May 01, 2018 8:09 pm

When it starts, this machine does not exhibit any beep codes, but there is no display on the internal LCD. The backlight does turn on turned on but the screen remains glowing black.

Display switching via Fn+F7 still works and I can get display output on external monitor but the picture is garbled with green and purple. Using DisplayPort and VGA output give same result on external monitor as shown in linked images here: https://imgur.com/a/6mcKg63

Does anyone have any experience with this?

Are these images typical of the Nvidia chip failure that was common in the Quadro NVS 140m? Or is this some other problem?

I'm trying to decide if it's worth buying an Intel Graphics motherboard to replace the existing motherboard.

TPFanatic
Senior Member
Senior Member
Posts: 931
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: R61 Video issues - is this the NvidiaBug failure?

#2 Post by TPFanatic » Tue May 01, 2018 8:30 pm

Such graphical errors are symptomatic of GPU malfunction. If you have an Nvidia GPU, then yeah that's what gone bad. May or may not be the typical failure, those tend to just die then and there and not boot.
lenovo T61 T7500, SXGA+, 8GB
lenovo T430 i5 3320m, HD+, 8GB
lenovo T500 P9700, WUXGA, 8GB
lenovo X201 i5 520m, WXGA, 4GB
lenovo T520 i7 2760QM, FHD, 8GB



Enable advanced features on older Synaptics touchpads with the registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

mid_mob
Posts: 3
Joined: Fri Jan 13, 2017 6:02 pm
Location: Hope, Canada

Re: R61 Video issues - is this the NvidiaBug failure?

#3 Post by mid_mob » Tue May 01, 2018 10:33 pm

Yes, this machine has the NVIDIA Quadro NVS 140M graphics.

Is it possible that this is a symptom of any other problem with the machine? If I install another motherboard with integrated Intel graphics is there a chance I will still have the same graphics problems?

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1738
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: R61 Video issues - is this the NvidiaBug failure?

#4 Post by axur-delmeria » Tue May 01, 2018 11:13 pm

If not the GPU itself, the video RAM chips are failing.
But since both are soldered onto the system board, the easiest fix is board replacement.
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60/s Frankenpad Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E, X61 T7500
:cry:

mid_mob
Posts: 3
Joined: Fri Jan 13, 2017 6:02 pm
Location: Hope, Canada

Re: R61 Video issues - is this the NvidiaBug failure?

#5 Post by mid_mob » Wed May 02, 2018 4:50 am

Thank you TPFanatic and axur-delmeria for your responses.

Now I have to decide if it's worth buying and installing new system board for 11 year old laptop :)

I wonder how much weaker the Intel Integrated Graphics feel when browsing the web or watching Youtube?

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1738
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: R61 Video issues - is this the NvidiaBug failure?

#6 Post by axur-delmeria » Wed May 02, 2018 7:08 am

YouTube shouldn't be an issue, unless you're watching 1080p video and your processor is either single core or below 2.0 GHz.

NVS 140M supports video decode acceleration, but whether the browser can make use of it is another matter entirely.
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60/s Frankenpad Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E, X61 T7500
:cry:

SKA
Freshman Member
Posts: 60
Joined: Fri Dec 16, 2011 9:50 pm
Location: Bangkok, Thailand

Re: R61 Video issues - is this the NvidiaBug failure?

#7 Post by SKA » Tue May 22, 2018 9:40 am

Sorry for OT !

Can a R61 15.4 inch take a 15.4 inch T61P board (Intel/Nvidia) + T9300 /T9500 CPU +8GB DDR2 RAM +wifi card etc ?

In other words can all components of T61P work in a R61 incuding WSXGA+/WUXGA screens ?

Thanks for guidance

Ska
Last edited by SKA on Wed May 23, 2018 3:46 pm, edited 1 time in total.

Screamer
Posts: 35
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: R61 Video issues - is this the NvidiaBug failure?

#8 Post by Screamer » Tue May 22, 2018 12:31 pm

Yes, they can. The only issue will be the T61p's SD card slot sitting deeper in the chassis. You should have made a separate topic about this though, it is a little off-topic.

EDIT: I must been sleepy while writing this post, eugh. Apologies, but there are a few more things that you should know before placing in a 15.4" T61(p) motherboard into an R61. Other than the SD card slot's positioning, the IEEE1394 firewire port is also positioned differently in the 15.4" T61(p) in comparison to the 15.4" R61. Which means the IEEE1394 firewire port is not going to be available, since it is positioned at the front of the T61(p), compared to the R61's left-facing firewire port.

If your R61 does have a S-Video out port located underneath the right hinge, you should be able to transfer the daughterboard that contains the S-Video + 2 USB ports to the T61(p) motherboard easily. In conclusion, this means that you will be not able to access the IEEE1394 firewire port without burrowing a hole at the front of your R61's base. The SD card slot and the S-Video out port should be usable, that is all as far as I can remember.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad R, A, G and Z Series”

Who is online

Users browsing this forum: No registered users and 7 guests