Unrecognized devices in Device Manager of X1 Carbon Gen1 running Win7

Windows 7 on ThinkPads
Post Reply
Message
Author
dandreye
Sophomore Member
Posts: 162
Joined: Tue Feb 07, 2012 11:48 am
Location: London, UK

Unrecognized devices in Device Manager of X1 Carbon Gen1 running Win7

#1 Post by dandreye » Sun Jan 08, 2017 9:10 am

Hi All,

A couple of months ago I noticed the following 2 unrecognized devices in my Device Manager that have never been there before:
https://s28.postimg.org/jzloe1klp/Unknown.png

The former one ("Bluetooth Peripheral Device") has the following Hardware IDs:
BTHENUM\{0000180f-0000-1000-8000-00805f9b34fb}_VID&0002045e_PID&0916
BTHENUM\{0000180f-0000-1000-8000-00805f9b34fb}_LOCALMFG&000f

The latter one has no Hardware IDs section at all.

The only HW change I can think of dates back to August or September, when I started using my new Microsoft Bluetooth Mouse 3600. The mouse uses LE/SMART, which is part of BT v4.0, and despite statements here and there that it's not supported prior to W8.x works perfectly well under W7 somehow.

Has anyone ever come across Windows 7 driver(s) that'd help recognize these 2 devices? (installing a dummy driver would be undesirable)


Many thanks in advance!
X1G1 3460-1F4, 2x X61s 7667-34G, X61s 7667-Y24, X61s 7667-WQ8, X61s 7666-AA5, X60s 1702-W96, T43 2669-YJ6, T42 2373-Q91

RealBlackStuff
Admin
Admin
Posts: 18215
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Unrecognized devices in Device Manager of X1 Carbon Gen1 running Win7

#2 Post by RealBlackStuff » Sun Jan 08, 2017 9:24 am

What's it say in Device Mgr under Bluetooth..., Mice... and Human...
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

dandreye
Sophomore Member
Posts: 162
Joined: Tue Feb 07, 2012 11:48 am
Location: London, UK

Re: Unrecognized devices in Device Manager of X1 Carbon Gen1 running Win7

#3 Post by dandreye » Sun Jan 08, 2017 10:15 am

RealBlackStuff wrote:What's it say in Device Mgr under Bluetooth..., Mice... and Human...
Here we go:
https://s27.postimg.org/h1u2jriyr/BT_Mice_Human.png
X1G1 3460-1F4, 2x X61s 7667-34G, X61s 7667-Y24, X61s 7667-WQ8, X61s 7666-AA5, X60s 1702-W96, T43 2669-YJ6, T42 2373-Q91

RealBlackStuff
Admin
Admin
Posts: 18215
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Unrecognized devices in Device Manager of X1 Carbon Gen1 running Win7

#4 Post by RealBlackStuff » Sun Jan 08, 2017 11:05 am

In my X1C1 (without such a BT-mouse) I have:
same BT Radios as you
only BT Remote Control under HID
2 entries under Network Adapters:
- BT Device (Personal Area Network)
- BT Device (RFCOMM Protocol TDI)

No BTHENUM entries or matching VID or PID entries anywhere.
Do those unknown IDs stop anything from working?
If not, UNinstall both and see what happens at the next boot or DM-refresh.

dandreye
Sophomore Member
Posts: 162
Joined: Tue Feb 07, 2012 11:48 am
Location: London, UK

Re: Unrecognized devices in Device Manager of X1 Carbon Gen1 running Win7

#5 Post by dandreye » Sun Jan 08, 2017 1:29 pm

RealBlackStuff wrote: 2 entries under Network Adapters:
- BT Device (Personal Area Network)
- BT Device (RFCOMM Protocol TDI)
Yeah I have these too there.
RealBlackStuff wrote: No BTHENUM entries or matching VID or PID entries anywhere.
Do those unknown IDs stop anything from working?
Nope, nothing wrong at all with any functionality to complain about... just that imperfection in DM.
RealBlackStuff wrote: If not, UNinstall both and see what happens at the next boot or DM-refresh.
Just tried. The former of the 2 in Other Devices has returned (I didn't reboot it though - just re-scanned for HW changes). The other one hasn't yet. Just tried turning on my mouse - got "installing" message followed by "failed" but the 2nd unknown device hasn't turned up as yet.

Update: these tell me no W7 driver exists for this mouse:
https://answers.microsoft.com/en-us/win ... 9707306893
https://answers.microsoft.com/en-us/win ... db2144e148
X1G1 3460-1F4, 2x X61s 7667-34G, X61s 7667-Y24, X61s 7667-WQ8, X61s 7666-AA5, X60s 1702-W96, T43 2669-YJ6, T42 2373-Q91

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 7”

Who is online

Users browsing this forum: No registered users and 1 guest