Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Windows 7 SP1 install error 0x800F0A12

Windows 7 on ThinkPads
Post Reply
Message
Author
ashleys
Junior Member
Junior Member
Posts: 311
Joined: Mon Oct 11, 2004 9:25 am
Location: England

Windows 7 SP1 install error 0x800F0A12

#1 Post by ashleys » Fri Feb 25, 2011 4:24 am

Word of warning regarding the above error.

I've now installed SP1 on both my T60 and T30. SP1 installed flawlessly in 30 minutes on the T60 but the above error was encountered on the T30.
Both machines had retail Windows 7 Professional installed and were fully patched prior to the availability of SP1. The only difference was the presence, or otherwise, of the 100Mb System partition.
When I installed Windows 7 on the T60 I decided, during the Windows 7 setup, to remove the 100Mb System partition. Therefore, my system, boot and active partition were one and the same, namely C:
On the T30 I had left setup to create the 100Mb system partition, as recommended by Microsoft.

It was the T30 system with the separate 100Mb system partition that had the error.
The workaround was to mount the system partition prior to starting the SP1 install.

Everything looks fine post upgrade so will probably upgrade my desktop next week.

ThinkPadophile
Freshman Member
Posts: 100
Joined: Tue Feb 24, 2009 11:03 am
Location: Huntsville, AL

Re: Windows 7 SP1 install error 0x800F0A12

#2 Post by ThinkPadophile » Sun Feb 27, 2011 6:27 pm

My first attempt to install SP1 returned the same error code, and I also found that mounting the service partition solved the problem.
T60p UXGA Flexview T7200 3 GB RAM 128GB Samsung SSD Windows 7 Ultimate 64-bit

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 7”

Who is online

Users browsing this forum: No registered users and 3 guests