Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

WWAN on x131e

X100e/X120e/X130e etc. series specific matters only.
Post Reply
Message
Author
dynaflux
Posts: 7
Joined: Fri Feb 15, 2008 9:49 am
Location: Stockholm, Sweden

WWAN on x131e

#1 Post by dynaflux » Wed Jul 15, 2020 6:03 am

I have been using Thinkpads 1998 and have owned like 15 T-series. However I needed something lighter and bought a x131e and I use it for commuting. I upgraded to 8GB RAM and a SSD so it works pretty smooth. I also added a Ericsson H5321 gw WWAN card - but can't get it working in Windows 10. There is something wrong connecting to my operator and I'm sure it isn't a hardware issue as I'm also running Linux Mint where everything works fine. I get a connection, first "Checking account balance" and then "Disconnected".

I have tried pretty much everything:

- Updated BIOS
- Reseted BIOS
- Different settings in BIOS
- Reinstalled Windows 10 (more than once)
- New SIM-card
- Firmware update of the WWAN card
- Installed all appropriate drivers
- Added new APN manually
- Talked to the operator (who said I should restart the computer and take the SIM card out and wipe it of and then sent me a new SIM).

Any ideas? Should I opt for a new WWAN card - if so, which one?

As I said: everything works perfect in Linux and the SIM card works in my Samsung tablet.

Screamer
Senior Member
Senior Member
Posts: 509
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: WWAN on x131e

#2 Post by Screamer » Sun Jul 19, 2020 5:00 am

Does the Ericsson H5321gw have any settings that you could change in the device manager? It seems to be a configuration problem, but I could be wrong.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1xxe Series”

Who is online

Users browsing this forum: No registered users and 9 guests