Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Worried about temperature X121e Linux

X100e/X120e/X130e etc. series specific matters only.
Post Reply
Message
Author
Dead1nside
Senior Member
Senior Member
Posts: 780
Joined: Mon Jul 24, 2006 8:32 pm
Location: Reading, UK
Contact:

Worried about temperature X121e Linux

#1 Post by Dead1nside » Sat Dec 03, 2011 2:21 pm

I was just wondering what sort of temperature range X121e owners Thinkpads get to, especially running Linux? It seems like my i3 model is always between 55-65 at idle. At load just now, playing a game it was reported to be at 72 degrees celsius, which is very uncomfortable.

Does anybody know if thinkpad-acpi's fan control works properly on these X1xx models? I did a "cat /proc/acpi/ibm/fan"
and it reported the following:

status: enabled
speed: 566
level: auto

It doesn't seem like 600RPM is a lot at all, especially with all that heat.

Many thanks in advance, it's a great laptop/netbook otherwise. Idle temperatures on Windows 7 don't seem nearly as bad, so I'm wondering whether this is a Linux problem, and whether there is a solution.
T41p 2373-GHG / 1.5Ghz 'Banias' / NMB Keyboard
T61 14.1'' 7661-CTO / Vista Business / WXGA / T7300 / 2GB RAM / 80GB HDD / X3100 / 3945ABG / NMB KB /
T400 14.1'' 2768-CTO / Vista Business / WXGA / P8400 / 4GB RAM / 200GB 7200RPM / HD 3470 / 5300AGN / WWAN / NMB KB

fero14041
Posts: 1
Joined: Thu Mar 22, 2012 10:10 am
Location: Paris, France

Re: Worried about temperature X121e Linux

#2 Post by fero14041 » Thu Mar 22, 2012 10:32 am

Hello,

Same Thinkpad here, with same problem on Linux. It seems that some other guys reported the problem and exposed solutions through the web. A quick search gives some usefull links, among others: telling that some "magic" (at least for me ;-) ) options could be passed to the kernel to reduce temperatures.
Running Debian testing in my X121e, as recommanded in these articles, I put options that GRUB passes to the kernel, in /etc/default/grub file:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1"
then regenerate GRUB files with update-grub and reboot.
Now, my laptop is around 10°C lower than before! :D

Hope it helps...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1xxe Series”

Who is online

Users browsing this forum: No registered users and 1 guest