X120e internal speakers problem

X100e/X120e/X130e etc. series specific matters only.
Post Reply
Message
Author
Humanoid
Posts: 10
Joined: Tue Aug 09, 2011 8:04 am
Location: Bangkok, Thailand

X120e internal speakers problem

#1 Post by Humanoid » Mon Dec 09, 2013 4:07 am

It started about 5 months ago. While watching videos, loud sounds in videos such as glass breaking would cause the speakers to switch off. Plugging in earphones still works, but the speakers won't output any more sound, as if they were switched off by some kind of protection circuit. This only happened with really loud sounds, usually sounds of breaking glass. The only way I was able to get the speakers working again is to reboot the computer.

After 2-3 months, I noticed this switching off behaviour became more and more sensitive. The sound causing the speakers to switch off didn't have to be that loud anymore, and it could be any sound. It just got more and more sensitive. Now for the last month, it's so sensitive that it even turns off within a few minutes of rebooting, without even having to play a sound at all.

I'm stuck using earphones all the time now, because if I'm lucky, the most I can get is about one minute of sound from the speakers before they switch off again.

It's clearly some kind of hardware problem, since I haven't changed the firmware or anything else. The warranty's already expired, and it looks like something that would be very difficult to fix myself. But maybe I can just order some replacement part or something? If anybody has some idea of what I can do, please let me know. Thanks!

ibidem
Posts: 6
Joined: Sun Oct 06, 2013 5:53 pm
Location: Redding, California

Re: X120e internal speakers problem

#2 Post by ibidem » Thu Dec 12, 2013 2:09 am

Check the part number in the X100e/X120e Hardware Maintenance Manual.
That provides a full parts list and also directions for replacing every component.

I'm not aware whether this could be a software bug, but you might try updating the BIOS and drivers first...

Humanoid
Posts: 10
Joined: Tue Aug 09, 2011 8:04 am
Location: Bangkok, Thailand

Re: X120e internal speakers problem

#3 Post by Humanoid » Thu Dec 19, 2013 6:32 am

I've taken a look at the hardware maintenance manual. The speaker assembly is replaceable, but that doesn't look like it contains the DAC. Pc speaker sound (those beeps), still work just fine. The digital sound circuit that contains the DAC looks like it's directly on the motherboard and not replaceable.

When will lenovo make a new X120e with a more powerful cpu and usb3? Those new X100 series models are all so much bigger and heavier than the X120e, and they won't even accept a 9.5mm HD! It looks like the X120e is the last of its kind. I'm not downgrading, and there's no upgrade option! :(

ibidem
Posts: 6
Joined: Sun Oct 06, 2013 5:53 pm
Location: Redding, California

Re: X120e internal speakers problem

#4 Post by ibidem » Fri Dec 20, 2013 4:44 pm

Humanoid wrote:I've taken a look at the hardware maintenance manual. The speaker assembly is replaceable, but that doesn't look like it contains the DAC. Pc speaker sound (those beeps), still work just fine. The digital sound circuit that contains the DAC looks like it's directly on the motherboard and not replaceable.

When will lenovo make a new X120e with a more powerful cpu and usb3? Those new X100 series models are all so much bigger and heavier than the X120e, and they won't even accept a 9.5mm HD! It looks like the X120e is the last of its kind. I'm not downgrading, and there's no upgrade option! :(
A pity.
I've got the X100e, which is very close except for using an older, hotter, CPU and GPU.
But I wish is had a taller screen, and loath the touchpad....

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1xxe Series”

Who is online

Users browsing this forum: No registered users and 1 guest