Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X120e Intermittent Camera

X100e/X120e/X130e etc. series specific matters only.
Post Reply
Message
Author
Scorpion8
Posts: 46
Joined: Fri Apr 17, 2020 9:21 pm
Location: Juneau, AK

X120e Intermittent Camera

#1 Post by Scorpion8 » Fri Apr 17, 2020 9:38 pm

Hello all. Joined this forum as I just obtained two X120e's on the cheap, and love them. One runs Zorin OS15 Core, and the other has a Windows 10 32-bit install. Both were upgraded to 8GB RAM and run just fine on those sticks. Also replaced the old mechanical HDDs with SSD's. Now here's my issue ... the model running Win10 has an intermittent integrated camera. By "intermittent", I mean it works with some software and not with others. If I call up Windows own camera app, I can stare at my own video all day long. But if I try to use Skype, it says "no camera device found" even if the camera app is (or is not) running at the same time. I haven't been able to get it to work within Skype at all.

p.s. - The BIOS says it (the camera) is enabled, as I found the previous owner had said he had no Wifi but the internal Wifi FRU was disabled in BIOS. Weird. Works now just fine. But not the camera....

Thoughts? A search on "X120e and camera" doesn't give me anywhere to go. Thanks.

ETA: It's actually WIn 64, I was thrown off by the Win 32 directory on the HDD when I cloned it to the new SSD.
2@ X120e's for fun, T430s/X220i/T420 running Win10.
Pain heals, chicks dig scars, glory .... lasts forever.

Scorpion8
Posts: 46
Joined: Fri Apr 17, 2020 9:21 pm
Location: Juneau, AK

Re: X120e Intermittent Camera

#2 Post by Scorpion8 » Sun Apr 19, 2020 3:07 pm

Well, I think I have it solved. I ran Windows update and it found a new driver for the camera. Still not sure why the old driver worked with "some" software, but what=the=hey, it seems to work now with both. Will follow up in a few days.

ETA: Okay, that worked yesterday, but doesn't seem to work today. Still the camera app works in video, and quickly. The Skype app doesn't seem to do video even when the camera app IS doing video.
2@ X120e's for fun, T430s/X220i/T420 running Win10.
Pain heals, chicks dig scars, glory .... lasts forever.

Scorpion8
Posts: 46
Joined: Fri Apr 17, 2020 9:21 pm
Location: Juneau, AK

Re: X120e Intermittent Camera

#3 Post by Scorpion8 » Sun Apr 26, 2020 8:25 pm

Well a little more info. If I boot up this X120e and let it work through all of it's startup machinations, and then do nothing else but start (e.g.) Skype to use the integrated camera..... it works fine. If I start any other app, regardless if it uses the camera or not ... it may not may not work when I start Skype. Maybe 30:70 on if it starts.

Bugs me...
2@ X120e's for fun, T430s/X220i/T420 running Win10.
Pain heals, chicks dig scars, glory .... lasts forever.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1xxe Series”

Who is online

Users browsing this forum: No registered users and 5 guests