Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

ThinkPad 755C - Audio

Older ThinkPads.. from the 600, the 7xx, the iSeries, 300, 500, the Transnote and, of course, the 701
Post Reply
Message
Author
theterminator93
Senior Member
Senior Member
Posts: 938
Joined: Fri Oct 11, 2013 7:45 pm
Location: North Ridgeville, Ohio, United States

ThinkPad 755C - Audio

#1 Post by theterminator93 » Fri Sep 18, 2015 11:44 am

Recently acquired quite a steal of a deal on a 755C on feebay; nearly mint condition and a handful of accessories all in a high-end IBM carry case.

I installed a copy of Windows 95 on it and am in the process of getting the various hardware components set up. Once that has me stumped is the sound card. Windows 95 doesn't recognize it if I do a hardware scan and I can't seem to locate drivers for it online.

Anyone have some tips so I can get sound working?
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·LED UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19435
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: ThinkPad 755C - Audio

#2 Post by RealBlackStuff » Sat Sep 19, 2015 7:27 am

Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

theterminator93
Senior Member
Senior Member
Posts: 938
Joined: Fri Oct 11, 2013 7:45 pm
Location: North Ridgeville, Ohio, United States

Re: ThinkPad 755C - Audio

#3 Post by theterminator93 » Sat Sep 19, 2015 10:15 am

Thanks for the link RBS.

I had, in fact, run across that article a couple days ago. The links to the downloads of the utility diskettes were dead but I was able to track them down on an enthusiast's FTP server. I did install them but they do not appear to have drivers, per-se, but rather a set of utilities to set options of the hardware.

I continued digging just now and was able to locate an version of the IBM PC driver matrix page referenced as containing drivers for these legacy systems on archive.org (http://web.archive.org/web/200202120002 ... E|9545|7BE); from there I was able to find the required driver file .exe name I was looking for (aftps140.exe) on another enthusiast's server (http://john.ccac.rwth-aachen.de:8000/ft ... s/mobiles/).

Now I have sound.
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·LED UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

goldeneagle
Freshman Member
Posts: 107
Joined: Sat May 31, 2014 8:06 pm
Location: Bandera, TX

Re: ThinkPad 755C - Audio

#4 Post by goldeneagle » Mon Nov 02, 2015 6:04 pm

Out of curiosity, are you using the hard drive your 755C came with, or another one? I've been working on my 755C the last few days. Glad you got your audio working - looked around and somewhere it mentioned devices in config.sys, which I believe included Windows 95. My current problem is getting a CF card over 512MB to work in my machine so I can install 95 (and NT and etc).
Historic ThinkPads owned:
300, 360C, 360CE (x2), 360CSE, 510CS, 560, 560E, 701C, 701CS, 730TE, 750, 750C, 755C (x3), 755CE, 755CX (SVGA), 755CDV, 760ED, 770
Newer ThinkPads owned:
T520, W520 (x2), X220 Tablet (x4), and some T61/X61T laying around somewhere

theterminator93
Senior Member
Senior Member
Posts: 938
Joined: Fri Oct 11, 2013 7:45 pm
Location: North Ridgeville, Ohio, United States

Re: ThinkPad 755C - Audio

#5 Post by theterminator93 » Mon Nov 02, 2015 7:25 pm

It's the original 360 MB (IIRC) disk. I acquired it with a factory 3.1 install and wiped it for 95 after taking an image of the original install.
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·LED UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

goldeneagle
Freshman Member
Posts: 107
Joined: Sat May 31, 2014 8:06 pm
Location: Bandera, TX

Re: ThinkPad 755C - Audio

#6 Post by goldeneagle » Tue Nov 03, 2015 10:05 am

theterminator93 wrote:It's the original 360 MB (IIRC) disk. I acquired it with a factory 3.1 install and wiped it for 95 after taking an image of the original install.
I don't suppose you would be able to allow me to download the image of the factory install? Do you know if it came with the demo program as well? I actually have a semi-original install for the 360CE and both original installs for the 701 series. Still trying to find these for the 755's.
Historic ThinkPads owned:
300, 360C, 360CE (x2), 360CSE, 510CS, 560, 560E, 701C, 701CS, 730TE, 750, 750C, 755C (x3), 755CE, 755CX (SVGA), 755CDV, 760ED, 770
Newer ThinkPads owned:
T520, W520 (x2), X220 Tablet (x4), and some T61/X61T laying around somewhere

theterminator93
Senior Member
Senior Member
Posts: 938
Joined: Fri Oct 11, 2013 7:45 pm
Location: North Ridgeville, Ohio, United States

Re: ThinkPad 755C - Audio

#7 Post by theterminator93 » Tue Nov 03, 2015 11:27 am

I'll put it up on my web server this afternoon and PM you a link. I can't recall what "stuff" was on it (I know it had MS Office), but it did have a few ThinkPad related items in a separate program group in Program Manager. I'm not sure how intact the original install is since the computer came to me from the original owners - a utility company in New England - and things were obviously added to it.
Daily: T25 | W520 i7-2860QM·Quadro 2000m·IPS FHD | T420 i7-2640M·NVS 4200m·IPS FHD | X220 i7-2640M | T601F T9900·NVS 140M·LED UXGA
Wife's: T61p T9500·2010 FX570m·WUXGA | X220T i7-2640M
Others: T61p·61·43·42p|X41T·24·23·22|G41|A31p·22m|i1200|TransNote|380D|365XD|701C|755C

goldeneagle
Freshman Member
Posts: 107
Joined: Sat May 31, 2014 8:06 pm
Location: Bandera, TX

Re: ThinkPad 755C - Audio

#8 Post by goldeneagle » Tue Nov 03, 2015 12:42 pm

Thank you. If you're also interested, I have preloads of the 701C/CS (both DX2 and DX4). I actually pasted a dropbox link in another thread several months back. I don't remember where my 360CE came from, but it had the same situation - other stuff was added to it.
Historic ThinkPads owned:
300, 360C, 360CE (x2), 360CSE, 510CS, 560, 560E, 701C, 701CS, 730TE, 750, 750C, 755C (x3), 755CE, 755CX (SVGA), 755CDV, 760ED, 770
Newer ThinkPads owned:
T520, W520 (x2), X220 Tablet (x4), and some T61/X61T laying around somewhere

mimarsinan
Posts: 17
Joined: Fri Jan 19, 2018 1:29 pm
Location: Ankara, TURKEY

Re: ThinkPad 755C - Audio

#9 Post by mimarsinan » Tue Feb 13, 2018 1:23 pm

I recently got my hands on a 755C.

Any chance you might PM me the link for its drive image as well?

Also, the system has two memory modules, but neither seem to work - they're found under the floppy.

I tried inserting an 8 MB module from my 701C and it didn't work - is that to be expected?

mimarsinan
Posts: 17
Joined: Fri Jan 19, 2018 1:29 pm
Location: Ankara, TURKEY

Re: ThinkPad 755C - Audio

#10 Post by mimarsinan » Tue Feb 13, 2018 7:40 pm

I've also got a question about the hard drive.

Getting it out of the caddy was quite a challenge, the plastic had almost fused in over time.

After that, I connected it to the same IDE to USB adapter I used in connecting my 701C hard drives, so I can transfer large files over.

Unfortunately, while the drive spun up, the drive never showed up in the Disk Manager. I also had an uncanny feeling that of the two sides available in my USB adapter to connect the IDE HDD, I was using a different one for this 755C HDD, compared to the 701C HDD's. The pins would not fit on the other side where I thought I had connected the other IDE drives.

When I inserted the drive back into the 755C, I had quite a scare. It wouldn't boot. I ran a drive test through the BIOS which went fine, but then the PC wouldn't even boot from a floppy. I kept getting error 201 in the BIOS!

Disappointed that I had ruined a fine antique, I let the machine sit for a couple days. Then imagine my surprise today when it worked fine!

All of the HDD data had been lost, but I have been able to install PC-DOS 6.3, then Windows 3.1, and its audio/video/utility/pc card drivers successfully.

I love the keyboard and the display on the device for sure! This thing runs circles around the 701C, which from what I understand is due to the CPU L2 cache.

Any thoughts on what might have gone wrong with the USB adapter though? Is it dying or something? Could I really have connected it to the wrong side of the USB adapter?

I would love to image the 755C with its factory setup too, so I'd love to get this figured out at some point.

mimarsinan
Posts: 17
Joined: Fri Jan 19, 2018 1:29 pm
Location: Ankara, TURKEY

Re: ThinkPad 755C - Audio

#11 Post by mimarsinan » Tue Feb 13, 2018 8:02 pm

BTW here's the instructions I used (pretty much as-is, apart from substituting my USB adapter to transfer the ZIP file) for imaging my 701C:

www.os2museum.com/wp/thinkpad-701-resto ... -cf-media/

The boot floppy contains a DOS EXE which contains some `magic sauce` that makes the extracted, regular PKZIP format archive contents receive OS/2 extended attributes - so its a true dual-boot image.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad Legacy Hardware”

Who is online

Users browsing this forum: No registered users and 9 guests