Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Win98 installation on the 600

Older ThinkPads.. from the 600, the 7xx, the iSeries, 300, 500, the Transnote and, of course, the 701
Post Reply
Message
Author
andersswe92
Posts: 5
Joined: Tue Mar 13, 2018 3:27 pm
Location: Uppsala, Sweden

Win98 installation on the 600

#1 Post by andersswe92 » Wed Mar 21, 2018 11:43 am

Hi,

This will be my first topic on this site, and i am sorry for my english not being the best.
So i have a Thinkpad 600 that i bought a couple of years ago and recently found just laying around. It started right up and it had some old version of ubuntu installed.
But i wanted to reinstall win98se that it had when i first got it, so i got the bootdisk on cd and ran fdisk and did the format and everything. But then when i try to install win98 from cd all i get is a blinking cursor after i chose "Boot from CD".
Then i tried to put the bootdisk back in and got the same blinking cursor, it never goes further.
To test the cd-drive i ran a older version of puppy linux and it booted up and works fine. I also used gparted in linux to format the hdd to fat32 again, but i still only get the blinking cursor from win98 and bootdisk cd.
Does anyone know what the problem could be?
I can add that the win98 cd works fine as i could install it on a virtual machine on my main pc.

Thanks for taking your time.

fultontech
Sophomore Member
Posts: 170
Joined: Fri Jan 02, 2015 10:38 am
Location: Henderson, NV USA
Contact:

Re: Win98 installation on the 600

#2 Post by fultontech » Wed Mar 21, 2018 12:29 pm

Did you redo the master boot record, before partitioning the drive?

fdisk /mbr
IBM P75
IBM ThinkPad 700, 720C, 750Cs, 360C, 360P, 360CE, 360PE, 730TE, PC110, 365CSD, 365ED, 701Cs, 820, 600X, 770X, 240, T30
IBM RS/6000 43P 150
Lenovo ThinkPad X41T, X61T, X200T, X201T, X220T, X230T
Lenovo ThinkCenter M92p Tiny, M900 Tiny

andersswe92
Posts: 5
Joined: Tue Mar 13, 2018 3:27 pm
Location: Uppsala, Sweden

Re: Win98 installation on the 600

#3 Post by andersswe92 » Wed Mar 21, 2018 1:50 pm

Oh, that could be the problem. Haven't used fdisk in a while.
Do u know if i can do it thru gparted in linux, since it wont start the bootdisk?
Or did i make the hdd unusable?

Edit: I found an article on how to do it, so i will try that. Thanks

evening_hunger
Junior Member
Junior Member
Posts: 264
Joined: Thu Nov 26, 2015 2:55 pm
Location: Normandy, France

Re: Win98 installation on the 600

#4 Post by evening_hunger » Wed Mar 21, 2018 5:49 pm

The gparted guys seem to have - a bit longish - explanation here.
I don't have any Windows machine/disk handy, but I guess I'd use gparted and try to rebuild parition table, perhaps would add the boot flag to first of them and so on. (Haven't checked that enlightened wisdom with the link above, but I foresense it's way more coplicated the way they see it:)).
Good luck!
x320/i7-2620M/8GB/256gb.ssd/FHD13.3''IPS/debian_testing (main driver)
x230/i5/8GB/500gb.hdd+256gb.m2ssd/IPS/debian_stable+win7 (better half)

andersswe92
Posts: 5
Joined: Tue Mar 13, 2018 3:27 pm
Location: Uppsala, Sweden

Re: Win98 installation on the 600

#5 Post by andersswe92 » Thu Mar 22, 2018 9:44 am

I am about to give up now. How could it be that when i had ubuntu on the hdd i could start the win98 boot disk and run fdisk.
But whatever i try to do now my boot disk wont even start, only get a blinking cursor. The boot disk works in another computer so it is working.
I tried other live linux cd:s and every one works fine, but non of the different windows cd:s i tried will get pass the blinking cursor.

fultontech
Sophomore Member
Posts: 170
Joined: Fri Jan 02, 2015 10:38 am
Location: Henderson, NV USA
Contact:

Re: Win98 installation on the 600

#6 Post by fultontech » Thu Mar 22, 2018 9:51 am

Take a deep breath and step through the process.

1) (optional) go into bios and make notes of the current settings on paper, then reset to defaults.

2) boot from Win98 floppy, fdisk /mbr and reboot

3) boot from Win98 floppy, fdisk whole drive and reboot

4) boot from Win98 floppy, format c: /s and reboot

does it still blink?
IBM P75
IBM ThinkPad 700, 720C, 750Cs, 360C, 360P, 360CE, 360PE, 730TE, PC110, 365CSD, 365ED, 701Cs, 820, 600X, 770X, 240, T30
IBM RS/6000 43P 150
Lenovo ThinkPad X41T, X61T, X200T, X201T, X220T, X230T
Lenovo ThinkCenter M92p Tiny, M900 Tiny

andersswe92
Posts: 5
Joined: Tue Mar 13, 2018 3:27 pm
Location: Uppsala, Sweden

Re: Win98 installation on the 600

#7 Post by andersswe92 » Thu Mar 22, 2018 2:38 pm

Thanks again,
I managed to get the bootdisk to start and ran fdisk just like you said, but i still get the blinking cursor from the win98 cd.
But what i did find was that after about one hour with the blinking, i rebooted and by accident hit start from hdd and got to a command line with "A:/>".
When i ran "dir" i had a couple of files like fdisk. Then i changed to "C:/>" and i actually had some files there as well, no .exe files just some strange things.
Could it bee that the installation cd was in the middle of copying files to the hdd when i see the blinking?
I figured i might try and leave the blinking on for a couple of hours tomorrow, it's getting a bit late here.

FryPpy
Senior Member
Senior Member
Posts: 501
Joined: Thu Dec 06, 2012 3:29 pm
Location: Moscow, Russia

Re: Win98 installation on the 600

#8 Post by FryPpy » Thu Mar 22, 2018 4:02 pm

andersswe92 wrote:
Thu Mar 22, 2018 2:38 pm
But what i did find was that after about one hour with the blinking, i rebooted and by accident hit start from hdd and got to a command line with "A:/>".
Some hints from oldschool:
These times when normal boot from CD haven't worked we used method "install from HDD".
If you can partition and format your HDD (C: drive) - you can see it as a clean storage with some system files like command.com, io.sys, msdos.sys. If there are no command.com and sys files on C: you can use sys.com from boot disk.
From this point you can boot from HDD in DOS.
Try to find dos CD driver and copy it to HDD and add it to autoexec.bat and config.sys. Or use driver from this site (Drivers link on top)
* After this step you can use CD drive in DOS. Make folder like Win98Inst on C: drive and copy all files from CD to this folder.
* Start installation procces by running setup.exe (someting like C:\Win98Inst\setup.exe).
You can ommit steps (*) and run setup directly from CD (ex. D:\WIN98\SETUP.EXE).

andersswe92
Posts: 5
Joined: Tue Mar 13, 2018 3:27 pm
Location: Uppsala, Sweden

Re: Win98 installation on the 600

#9 Post by andersswe92 » Fri Mar 23, 2018 7:23 am

So it seemed like the windows 98se was not going to work for some reason after redoing everything two more times.
Therefore i figured i could try to install windows 2000 just to see what happened, and it worked right away!
Sure it took almost two hour but that's not to bad, and at least now i have a working Thinkpad 600 with Windows 2000.
Thanks a lot to all for the help! Now i just have to find my old copy of SimCity 2000.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad Legacy Hardware”

Who is online

Users browsing this forum: No registered users and 8 guests