Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X-1 Carbon Gen 8 odd internet reconnect issue

X1/X1-Carbon (X1Cx)/X1-Extreme (X1Ex) series and later, specific matters only
Post Reply
Message
Author
dave_n_s
Posts: 3
Joined: Sat Aug 01, 2020 10:22 am
Location: Boulder, Colorado

X-1 Carbon Gen 8 odd internet reconnect issue

#1 Post by dave_n_s » Sat Aug 01, 2020 10:35 am

New here, but Thinkpad user / owner / DIY maintainer continuously since around '95 except for one error - bought XPS 9550, nice computer, unreliable hardware, now back in the fold this week when the Dell mobo failed.

Issue is that around 90% of the time when it is in sleep mode, manually or automatically, it reconnects to wifi but states the SSID it is connected to has no internet service, despite all other devices having connectivity on that SSID.

Solution is connect to the other frequency on the same router, which is shown as having connectivity, at which point the original one shows internet available again..... frustrating.

Router is Linksys EA7500.

OS is Windows 10 Home

SSIDs in question are Office and Office 5GHz

dave_n_s
Posts: 3
Joined: Sat Aug 01, 2020 10:22 am
Location: Boulder, Colorado

Re: X-1 Carbon Gen 8 odd internet reconnect issue

#2 Post by dave_n_s » Sat Aug 01, 2020 12:22 pm

and one more fact.... disconnecting and reconnecting to the same SSID results in it reestablishing an internet connection

BillMorrow
*Senior* Admin
*Senior* Admin
Posts: 7406
Joined: Tue Apr 13, 2004 9:40 pm
Location: San Francisco -> Florida -> Georgia
Contact:

Re: X-1 Carbon Gen 8 odd internet reconnect issue

#3 Post by BillMorrow » Sun Aug 02, 2020 3:01 am

have 2 X-1 extremes, gen 2's.. 1 older 1 carbon gen 2 (wife uses that one) and an X1 carbon gen 3.. all these have been ironclad reliable thus far..
on and off wifi via sleep and power down, etc. and never any issue reconnecting with the routers..
i got rid of my linksys stuff years ago 'cuz they were failing with regularity..
use two netgear nighthawk.. 7000 and 8000.. both 100% reliable..

you might try a different access point and router..
Bill Morrow, kept by parrots :parrot: & cockatoos
Sysop - forum.thinkpads.com

*
She was not what you would call refined,
She was not what you would call unrefined,
She was the type of person who kept a parrot.
~~~Mark Twain~~~

dave_n_s
Posts: 3
Joined: Sat Aug 01, 2020 10:22 am
Location: Boulder, Colorado

Re: X-1 Carbon Gen 8 odd internet reconnect issue

#4 Post by dave_n_s » Tue Aug 04, 2020 9:31 am

For those who may be experiencing a similar issue, it appears to be a driver issue, with a correction posted hours after I updated all drivers on receipt of the machine (date of correct driver 7/28/20)

And for those who haven't needed to call Lenovo tech support before, when you get through to the IBM contracted team in the US all is well - they are officially the Hardware warranty team - however until then the support was hopeless - the tech support chat team said they couldn't help and sent me to the extra charge software support team.

I quite understand why Lenovo would not sign up to support software, even that sold with the machines, but at low level the OS, drivers and hardware are so integrated that they should be offering a triage service to confirm hardware and driver correct functionality, including interfacing to the OS they sold.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1 / X1-Carbon / X1-Extreme and later Series”

Who is online

Users browsing this forum: No registered users and 7 guests