Mouse scrolling issue

X1/X1-Carbon series specific matters only
Post Reply
Message
Author
cfds
Freshman Member
Posts: 110
Joined: Fri Nov 09, 2012 11:29 am
Location: Les Vosges, France

Mouse scrolling issue

#1 Post by cfds » Tue Mar 07, 2017 4:35 am

Since long time I have been confronted with the following issue;
The scrolling pre-setting is getting "reset" to a much lower value when I use the touch pad over the Logitech mouse.
All works fine when only using the external mouse but when using the build in touch pad at some point I loose the pre-setting and the scrolling revert to a much lower value...it is than a matter of going into the settings and reconfirm the value. I did notice the same behavior on the T420 and X220...so it seems a conflict between the Logitech software/driver and the Lenovo software drivers.
Am I the only one? It is annoying me...
X1C-1, i5 3427U 1.8GHz, 8GB, Samsung mSATA 240GB SSD, Win 7 Pro 64bit
X1C-1, i7 3667U 2.0GHz, 8GB, Sandisk mSATA 240GB SSD, Win 10 Pro 64bit
X220, i5 2520M 2.5GHz, 6GB, Crutial mSATA 120GB SSD & Samsung 256GB SSD
T420, i5 2520M 2.5GHz, 8GB, mSATA 256GB SSD + 500GB HDD

w0qj
Senior Member
Senior Member
Posts: 694
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: Mouse scrolling issue

#2 Post by w0qj » Thu Mar 09, 2017 2:13 am

Hi cfds,

Did you try manually disabling your TrackPad from the BIOS in your X1C-1 ?
Perhaps you can then use your external Logitech touchpad via USB cable!

We would suspect many users on this forum use the TrackPoint instead.
Actually we disable the TrackPad via BIOS for all our computers.
(We have a mini-fleet of 100% Lenovo Thinkpad computers).
Daily Driver: X1 Carbon 4th Gen (X1C4): i7-6600U 2.6GHz; 16GB DDR3 1866 MHz; 1TB PCIe-NVMe SSD; 14" WQHD 2560x1440; LTE EM7455 Mobile Broadband; Win7 Pro 64bit
Current Thinkpads: X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

dr_st
Senior ThinkPadder
Senior ThinkPadder
Posts: 6898
Joined: Sat Oct 29, 2005 6:20 am

Re: Mouse scrolling issue

#3 Post by dr_st » Thu Mar 09, 2017 2:41 am

You know, I have exactly the same behavior on my T410, when going between docked (with a Logitech MX518) and undocked. It's been going on for so long, that I don't remember if it only started when I got the MX518 or whether it affected the previous mouse (a simple Lenovo scroll mouse) as well.

Note the following:
1) I don't have any Logitech mouse software installed
2) I don't use the touchpad and it's disabled in the BIOS; trackpoint scrolling seems to affect it as well
Current: X220 4291-4BG, T410 2537-R46, T60 1952-F76, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, A31p w/ Ultrabay Numpad
Past: Z61t 9440-A23, T60 2623-D3U, X32 2884-M5U

cfds
Freshman Member
Posts: 110
Joined: Fri Nov 09, 2012 11:29 am
Location: Les Vosges, France

Re: Mouse scrolling issue

#4 Post by cfds » Thu Mar 09, 2017 2:48 pm

I don't want to deactivate the track-pad in the bios as I use it from time to time...
The external mouse I use is using a wireless USB receiver.

In my case the scrolling on both the thouch-pad and Logitec mouse is affected but it happens not always...I cannot put my finger on it when or what cause it except that is usually occurs after I have been using the thouch-pad.

I found this on another forum...
"for this all to work nicely you do have to make sure that the BIOS setting for the trackpoint is set to "automatic," not "On" -- that's the only way to enable the "dynamic" sensing of the presence of an external PS/2 mouse..." dunno if this could be a possibility for our problem.

Have to figure out how to get into the bios on this machine...
X1C-1, i5 3427U 1.8GHz, 8GB, Samsung mSATA 240GB SSD, Win 7 Pro 64bit
X1C-1, i7 3667U 2.0GHz, 8GB, Sandisk mSATA 240GB SSD, Win 10 Pro 64bit
X220, i5 2520M 2.5GHz, 6GB, Crutial mSATA 120GB SSD & Samsung 256GB SSD
T420, i5 2520M 2.5GHz, 8GB, mSATA 256GB SSD + 500GB HDD

RealBlackStuff
Admin
Admin
Posts: 18204
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Mouse scrolling issue

#5 Post by RealBlackStuff » Thu Mar 09, 2017 3:55 pm

Every REAL ThinkPad (incl. the X1/X1C) only needs F1 at boot time...
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1/X1-Carbon”

Who is online

Users browsing this forum: No registered users and 2 guests