Page 1 of 1

mSATA SSD inWWAN slot

Posted: Wed Aug 30, 2017 3:21 am
by cfds
Would it be possible to insert a small mSATA SSD in the WWAN slot on a X1C 1st gen like on the X220 and T420?
Like this I could migrate my operating system to the SSD in the WWAN slot and keep the second SSD as storage...

Thanks for your reply,

Yves

Re: mSATA SSD inWWAN slot

Posted: Wed Aug 30, 2017 6:42 am
by RealBlackStuff
There are half-size mSATA SSDs from 16 to 256 GB.
And looking at the schematics for the WWAN slot (CN11) it has all the SATA lines, but
I'd say: probably not.

PS: you can try to put in a full-size mSATA to check. Push it down as far as you can, that should be enough.
Make sure to cover up the bottom of that card to avoid shorts against the chassis.

PS2: just tried to put in 2 different mSATA drives (Intel and Samsung, both 'full' size)
Both give the 2101 error on HDD2 (Mini-SATA).
So I guess the WWAN slot is mSATA-possible, but may need a different mSATA drive.

Re: mSATA SSD inWWAN slot

Posted: Wed Aug 30, 2017 8:24 am
by cfds
Thanks RBS, lets see if I can find a mini mSATA SSD for a descent price!

Re: mSATA SSD inWWAN slot

Posted: Wed Aug 30, 2017 8:31 am
by RealBlackStuff
WAIT, see my edited post above!

I just compared the pin-out from the WWAN port (CN11) from the X1C1 with that of the X230 (also CN11).
Both are identical.
In my X230 I have a (full-size) mSATA (Sandisk X300) in the WWAN slot, with bootable W7 installed.
My main drive has a 500GB 7200rpm HD for storage.

So mSATA works in X230 but not (yet) in X1C1.
I tried a few different settings in X1C1 BIOS, but the error 2101 kept showing.

See this for references: https://forums.lenovo.com/t5/ThinkPad-X ... -p/2036501

Some more info: http://www.tomshardware.com/answers/id- ... aptop.html

Someone else chime in?

Re: mSATA SSD inWWAN slot

Posted: Wed Aug 30, 2017 12:00 pm
by cfds
Ok, I hold my horses...!
Have to say that the mini mSATA's are more expensive compared to the full-size mSATA's...
RealBlackStuff wrote:
Wed Aug 30, 2017 8:31 am
WAIT, see my edited post above!

I just compared the pin-out from the WWAN port (CN11) from the X1C1 with that of the X230 (also CN11).
Both are identical.
In my X230 I have a (full-size) mSATA (Sandisk X300) in the WWAN slot, with bootable W7 installed.
My main drive has a 500GB 7200rpm HD for storage.

So mSATA works in X230 but not (yet) in X1C1.
I tried a few different settings in X1C1 BIOS, but the error 2101 kept showing.

See this for references: https://forums.lenovo.com/t5/ThinkPad-X ... -p/2036501

Some more info: http://www.tomshardware.com/answers/id- ... aptop.html

Someone else chime in?

Re: mSATA SSD inWWAN slot

Posted: Wed Aug 30, 2017 12:24 pm
by RealBlackStuff
Found another thing to try: https://forums.lenovo.com/t5/ThinkPad-T ... d-p/871187
Maybe install the cache software mentioned therein?

Good picture with mSATA vs PCIe pinout:
http://www.ecs.com.tw/ECSwebsite/images ... %20pin.bmp

Another idea: cover pin 20 on the mSATA card:
https://superuser.com/questions/688904/ ... s-and-ssds
Superuser wrote:it seems that in a Lenovo T420, pin 20 on the "mPCIe slot for WLAN cards" causes the card to turn its radio on, while pin 20 in the "mPCIe slot for WWAN cards" causes the card to turn its radio off. Are we having fun yet?
But if you take a tiny sliver of scotch tape and cover pin 20 on the Wifi card and then insert it into the WWAN slot, it works just fine.

Re: mSATA SSD inWWAN slot

Posted: Thu Aug 31, 2017 9:21 am
by cfds
As I don't have a spare mSATA or even a mini mSATA SSD I will wait until some body can confirm 100% if it fits...
One X1C runs under Win 7, the other I will keep with Win 10 as for now...maybe it works under Win 10 without issue's?
As for the reference to cover pin20 on the mSATA, I have a T420 and have an mSATA in the WWAN slot and never ran into this problem. Did the same on my X220, no issue's there either. Its good to know though!
If somebody has a link to a cheap mini mSATA SSD...I am happy with a 128GIG SSD :D