Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Changed Gen one LCD panel and now no boot. Ideas?

X1/X1-Carbon (X1Cx)/X1-Extreme (X1Ex) series and later, specific matters only
Post Reply
Message
Author
dwilsonfl
Senior Member
Senior Member
Posts: 648
Joined: Thu Feb 16, 2006 1:29 am
Location: Valparaiso, FL
Contact:

Changed Gen one LCD panel and now no boot. Ideas?

#1 Post by dwilsonfl » Tue Feb 11, 2020 3:27 pm

Finally found the right panel for my Gen 1 3443-CTO and put it in just a few minutes ago. Connector snugged up, got the wires back in the guides and snapped the bezel back on expecting that glorious boot screen. But instead it did nothing. No beeps either. I'm changing it up right now, as I'm sure the battery was run down during the two weeks I've been waiting. But man I was really hoping to get back to using it.

Any tricks to this that I missed? It looked simple. Foolish me.

Can anyone help?

David
Vocavit autem servirent

dwilsonfl
Senior Member
Senior Member
Posts: 648
Joined: Thu Feb 16, 2006 1:29 am
Location: Valparaiso, FL
Contact:

Re: Changed Gen one LCD panel and now no boot. Ideas?

#2 Post by dwilsonfl » Tue Feb 11, 2020 7:22 pm

Aha! Reset button for the win! Just took some forum searching. Sorry for wasting your time.

David
Vocavit autem servirent

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1 / X1-Carbon / X1-Extreme and later Series”

Who is online

Users browsing this forum: No registered users and 7 guests