Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

X1/X1-Carbon (X1Cx)/X1-Extreme (X1Ex) series and later, specific matters only
Post Reply
Message
Author
simi2222
Posts: 3
Joined: Sat Jun 06, 2020 9:05 am
Location: Domažlice, CZ

Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

#1 Post by simi2222 » Sat Jun 06, 2020 9:10 am

Hi everyone,

i just installed 4g modem Sierra on my Thinkpad and it is not showing anywhere. I have modem from Thinkpad T450s, it worked fine there.

But now I don't see it in device manager, or anywhere. I have downloaded right drivers from lenovo and nothing happend. I have also enabled WAN modul in BIOS.

Could anybody please help.

Thanks.

w0qj
ThinkPadder
ThinkPadder
Posts: 1135
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

#2 Post by w0qj » Thu Jun 11, 2020 9:50 am

Just to be clear, your X1 Carbon (20A8) is the 2nd Generation.
http://pcsupport.lenovo.com/hk/en/solut ... arbon-help

I'm not sure what Mobile Broadband (WWAN) card is OEM for X1 Carbon 2nd Generation.
Can anyone help chip in on this point?

***Did you simply move the Mobile Broadband (WWAN) card from your T450s into your X1 Carbon 2nd Generation?
This may not work, as ThinkPads do have a WWAN whitelist that allows only the expected hardware to be recognized.
Perhaps this is the problem?

- - - - - - - - - - -
Anyways, we have X1C3 (X1 Carbon 3rd Generation) which is a (20BS) series, also came pre-installed with WWAN from ThinkPad/Lenovo.

1. This was how we got ours working: go to [Device_Manager]>>[Network_Adapters] and look for [Ericsson_N5321_gw] assuming that it's an OEM WWAN as supplied by ThinkPad/Lenovo.

Right-click [Ericsson_N5321_gw]>>[Update_Driver] to see if it helps.

2. Alternatively, you can install/run [Lenovo_Vantage] and update the driver for [Ericsson_N5321_gw] via ThinkPad/Lenovo for X1C3.

3. ***If you *do*not* see [Ericsson_N5321_gw] in your [Device_Manager],
there might be something wrong with the X1C3 hardware.

4. Just curious, did your X1C2 (X1 Carbon 2nd Gen) came preinstalled with OEM Windows 7 (along with all ThinkPad-specific drivers),
or are you trying to run some sort of Windows 10 on X1C2?
Daily Driver: (X1E3) X1 Extreme 3rd Gen | mobile broadband (WWAN)
Current Thinkpads: X1E3 | X1E1 | X1C4 | X1C3 | X250 | X230
Retired Thinkpads: T410 | T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

simi2222
Posts: 3
Joined: Sat Jun 06, 2020 9:05 am
Location: Domažlice, CZ

Re: Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

#3 Post by simi2222 » Thu Jun 11, 2020 10:58 am

Thank you for your response!

I have checked it before installation.

This is support list for my machine:

https://websvaj.cz/wp-content/uploads/2020/06/x1.png

w0qj
ThinkPadder
ThinkPadder
Posts: 1135
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

#4 Post by w0qj » Thu Jun 11, 2020 12:08 pm

1. What OS are you using? Windows 8 that came preinstalled with ThinkPad drivers?
Or are you using a plain vanilla Windows 8 (with no ThinkPad drivers)?
Or are you using an upgrade version of Windows 10?

(Presume that you did not get the Windows 7 downgrade rights for your X1C2).

2. Did you try unplugging your Mobile Broadband (WWAN) card, then reinserting it,
to ensure that it's securely connected to the WWAN socket on the motherboard?

3a. Try updating to the latest version of BIOS/UEFI.
3b. Boot into BIOS/UEFI (press [F1] upon bootup, goto [Security],
and ensure that [Wireless_WAN] is [Enabled].

4. Did you try installing Lenovo_Vantage for your X1C2 (X1 Carbon 2nd Generation),
then run Lenovo Vantage and scan for hardware drivers, especially for your newly inserted Sierra EM7345.

Hopefully your Windows can "see" your Sierra EM7345 card by then! Good luck!
Daily Driver: (X1E3) X1 Extreme 3rd Gen | mobile broadband (WWAN)
Current Thinkpads: X1E3 | X1E1 | X1C4 | X1C3 | X250 | X230
Retired Thinkpads: T410 | T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

simi2222
Posts: 3
Joined: Sat Jun 06, 2020 9:05 am
Location: Domažlice, CZ

Re: Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

#5 Post by simi2222 » Thu Jun 11, 2020 12:19 pm

I am using clean windows 10, I have also tried to reinstall it after wwan installation.

I have tried to re-plug and reconnect wwan twice, but no effect.

I have enabled wwan in bios, but did not updated it. Will try now. Maybe this is the point because Device manager is not showing it anyway.

Thank you very much.

w0qj
ThinkPadder
ThinkPadder
Posts: 1135
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: Sierra EM7345 not working on Thinkpad X1 carbon (20A8)

#6 Post by w0qj » Fri Jun 12, 2020 2:29 am

Unfortunately it sounds like you have a defective Mobile Broadband card (WWAN) on your hands,
since Windows cannot "see" it...
Daily Driver: (X1E3) X1 Extreme 3rd Gen | mobile broadband (WWAN)
Current Thinkpads: X1E3 | X1E1 | X1C4 | X1C3 | X250 | X230
Retired Thinkpads: T410 | T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X1 / X1-Carbon / X1-Extreme and later Series”

Who is online

Users browsing this forum: No registered users and 5 guests