Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Second-generation Carbon no-boot after firmware update

X1 / X1-Carbon (X1C) / X1-Extreme (X1E) Series/Generations
Post Reply
Sophomore Member
Posts: 127
Joined: Fri May 01, 2015 8:50 pm
Location: The United States of America

Second-generation Carbon no-boot after firmware update

#1 Post by SurrealMustard » Wed Aug 02, 2023 6:30 pm

I'm dealing with a second-generation X1 Carbon, (20A8) fresh off the eBay boat. Loaded up Windows, installed Lenovo System Update, and let it (and Windows) begin the process of installing drivers and patches. After reaching the home stretch, I opted to install the newest version of the motherboard firmware. This went well, or so I thought. After successfully staging, the machine rebooted, finished flashing, and then restarted once more... to nothingness. It now powers on, blinks the shift key light as it normally would, lights up the touch buttons, but I get nothing on screen at all whatsoever. If I leave it for a minute or two, it eventually shuts off on its own. Otherwise, it only requires a brief press of the power button to accomplish this.

I've tried holding down the power button for a really long time, pressing/holding the normal reset button, and even the motherboard battery reset button. No change. I also tried pulling the SSD to see if perhaps it was halting the post process, but the condition persisted. In my research, there have been a handful of reports of this, but no solid solutions. Has anyone here seen that before? If so, is there some kind of secret backdoor key combo or a way to reinstall the motherboard firmware off of a flash drive when the computer is in this state? I've installed motherboard firmware quite a few times in my life, but never once had it end this way. I was expecting the ThinkPad X1 to be less of a sissy than this :P .

Senior ThinkPadder
Senior ThinkPadder
Posts: 3787
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: Second-generation Carbon no-boot after firmware update

#2 Post by axur-delmeria » Thu Aug 03, 2023 11:53 am

Problems like this generally require a hardware SPI flasher like the CH341A, a SOIC8 clip, and another computer. That said, I've never done any sort of hardware flashing so I can't be of much help in that regard.
Planned Purchase: T480s i5-8350 FHD Touch
Impulse Buy: Thinkpad not named for safety reasons :lol:

Old Faithful: X220 4291-C91 i7-2620M

Admin Emeritus
Admin Emeritus
Posts: 23771
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: Second-generation Carbon no-boot after firmware update

#3 Post by RealBlackStuff » Thu Aug 03, 2023 12:13 pm

$hafted by Micro$haft, so what's new?
If/when you go for CH341A, get a black one with 3.3V option built-in.
Lovely day for a Guinness! (The Real Black Stuff)
Lenovo: X240, X250, T440p, T480, M900 Tiny.

PS: the old Boardroom website is still available on the Wayback Machine

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad X1 / X1-Carbon / X1-Extreme and later Series”

Who is online

Users browsing this forum: No registered users and 2 guests