Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T420 Windows 8.1 HotKeys problem

Windows 8 on ThinkPads
Post Reply
Message
Author
Classic600X
Posts: 22
Joined: Wed Apr 25, 2012 6:17 am
Location: London, United Kingdom

T420 Windows 8.1 HotKeys problem

#1 Post by Classic600X » Sun May 18, 2014 4:21 pm

Hi all,

I have just installed Windows 8.1 Pro (x64) on my T420. However, I cannot get the HotKey features to work properly.

I have tried installing the latest package as is and also in Win7 compatibility mode. I also tried installing an older version (3.80.0000) that I have been using without issue on my Windows 8.1 X220.

I remember having this problem on the X220 and I worked around it by installing the older package mentioned above and it works fine.

Any advice here would be appreciated.

Thank you.

asp
Posts: 12
Joined: Sun May 02, 2010 2:51 pm
Location: London, UK

Re: T420 Windows 8.1 HotKeys problem

#2 Post by asp » Wed Jul 09, 2014 10:52 am

I also have the same issue. Volume, mute and microphone mute hotkeys work, but others don't.
I'd be interested to know if you found a solution, especially in getting the WiFi/Bluetooth toggle hotkey to work.

gfoster
Posts: 1
Joined: Wed Jan 14, 2015 4:15 pm
Location: Ottawa, ON

Re: T420 Windows 8.1 HotKeys problem

#3 Post by gfoster » Wed Jan 14, 2015 4:18 pm

Same issue here on a T420 with Windows 8.1.

Also noticing that the integrated webcam isn't working. I also don't appear to have control over wireless functions via Fn-F5, nor the ability to disable the touchpad with Fn-F8.

tomjrc
Sophomore Member
Posts: 132
Joined: Tue May 19, 2009 10:31 pm
Location: Abbotsford B.C. Canada

Re: T420 Windows 8.1 HotKeys problem

#4 Post by tomjrc » Wed Jan 14, 2015 5:43 pm

My post on Nov.13/14 was met with some options but nothing has helped me Same problem

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16116
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T420 Windows 8.1 HotKeys problem

#5 Post by ajkula66 » Wed Jan 14, 2015 8:10 pm

In order for any of these to function properly, you need Power Manager which is not officially supported on W8.x

My understanding is that even with PM installed, certain Fn combinations will not result in OSD in a W8 environment.

Webcam needs an utility from the ThinkVantage pool, forgot the name of it at the moment, will report back once I remember...
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T42, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

rkawakami
Admin
Admin
Posts: 10135
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: T420 Windows 8.1 HotKeys problem

#6 Post by rkawakami » Wed Jan 14, 2015 8:15 pm

I think that's the Communications Utility.
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16116
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T420 Windows 8.1 HotKeys problem

#7 Post by ajkula66 » Wed Jan 14, 2015 8:32 pm

rkawakami wrote:I think that's the Communications Utility.
And you, sir, are correct.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T42, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

Norway Pad
ThinkPadder
ThinkPadder
Posts: 1161
Joined: Mon Jul 13, 2009 2:50 pm
Location: Meridian, ID & Oyer, Norway
Contact:

Re: T420 Windows 8.1 HotKeys problem

#8 Post by Norway Pad » Thu Jan 15, 2015 1:06 am

I have had similar issues with Hotkeys and OSD the last times I have done clean installs on newer Thinkpads. I don't think it's related to neither 8.1 nor the T420 specifically, as I had this problem with Win7 on T410 and T400 machines as well. In order to make Hotkeys/OSD work, I have installed Hotkeys Features V3.81, an older version, found here: http://support.lenovo.com/us/en/product ... s/DS014985 Uninstall your current one, and reinstall this one. That has fixed it for me every time.

With this version of Hotkeys installed, all OSD displays work on a T420 with Win10, including the ancient Presentation Director, WebCam options, UltraNav options, and the WiFi/Bluetooth options. The only thing that doesn't work is Fn+F3, as the now incompatible Power Manager isn't installed. I did manage to install and make Power Manager work in Win8 in compatibility mode, but that's a different subject.
Bjorn
THINKPAD collector. Only missing a proper RetroThinkpad.

pemati
Posts: 2
Joined: Fri Oct 09, 2015 2:13 am
Location: Somewhere in Finland on a wireless connection

Re: T420 Windows 8.1 HotKeys problem

#9 Post by pemati » Fri Oct 09, 2015 2:18 am

For me it still doesn't work with the version Norway Pad suggested in Windows 10. If I install it normally the buttons work but no Lenovo OSD (windows OSD still works). And, if I kill the OSD processes and start the i386 versions from HOTKEY install folder, the Audio OSD works, but not the screen brightness OSD.

Yet another reason to stick with Windows 7 for my T420 until either windows or lenovo has fixed this.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 8”

Who is online

Users browsing this forum: No registered users and 2 guests