T450s screen glitching

T430 - T470 and T530 - T570 series specific matters only
Post Reply
Message
Author
retrosaurus
Posts: 6
Joined: Tue Aug 08, 2017 8:51 am
Location: New York, NY

T450s screen glitching

#1 Post by retrosaurus » Tue Aug 08, 2017 8:59 am

I was gaming on my T450s and suddenly these artifacts appeared on the screen. I tried to power off and restart, update drivers and BIOS... nothing seems to work. The artifacts are not static, they actually jump around on the screen when I move the mouse or the type on the keyboard. I tried finding a solution but I haven't seen anyone else have this issue.

http://imgur.com/a/ONJrv

I ran some diagnostics on it (one through the BIOS and also through the Lenovo Companion tool) and there doesn't seem to be any kind of hardware issues. I can actually use the computer normally (open up applications, use the keyboard & mouse). I did try the VGA and mini display port to test out the picture on an external monitor but that did not work.

I had a few ideas of what could be potentially the suspect:
  • GPU got fried
    LCD screen clonked out
Any idea of what could be wrong? I was thinking of taking my chances and buying a replacement screen to start troubleshooting. Really sad especially since I got it new two years ago.

Specs:

Code: Select all

• Intel Core i5-5200U Processor (3MB Cache, up to 2.70GHz)
• Intel HD Graphics 5500
• Windows 10
• 14.0" FHD (1920 x 1080) with WWAN
• 720p HD Camera
• Security Chip Enabled
• 4 GB DDR3L - SDRAM 1600MHz Base soldered + 8 GB stick that I bought separately
• 500GB Hard Disk Drive, 7200rpm, 2.5"
• 16GB M.2 Solid State Drive Single
• 3rd M.2 SSD slot
• ThinkPad Battery 3 cell Li-Polymer (23.2Whr) Front
• ThinkPad Battery 3 cell Li-Polymer (23.2Whr) Rear
• Intel 7265 AC/B/G/N Dual Band Wireless + Bluetooth Version 4.0
Last edited by retrosaurus on Wed Aug 09, 2017 3:25 pm, edited 1 time in total.

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1427
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T450s screen glitching

#2 Post by axur-delmeria » Tue Aug 08, 2017 9:42 am

retrosaurus wrote:
Tue Aug 08, 2017 8:59 am
I did try the VGA and mini display port to test out the picture on an external monitor but that did not work.
Just to clarify:

1. Was there any video output from the VGA and/or Displayport?
2. If yes, did it exhibit the same issue as the internal display?
3. If no, did you set up the external display as the primary (inside BIOS setup)? Or tried the Windows + P key combination to switch video outputs (while in Windows)?

Another question: does your T450s have Intel graphics, or nVidia?
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

retrosaurus
Posts: 6
Joined: Tue Aug 08, 2017 8:51 am
Location: New York, NY

Re: T450s screen glitching

#3 Post by retrosaurus » Wed Aug 09, 2017 10:22 am

axur-delmeria wrote:
Tue Aug 08, 2017 9:42 am
1. Was there any video output from the VGA and/or Displayport?
2. If yes, did it exhibit the same issue as the internal display?
3. If no, did you set up the external display as the primary (inside BIOS setup)? Or tried the Windows + P key combination to switch video outputs (while in Window
1. There was no video output from both the VGA or mini displayport. I heard the windows notification sound (that it recognized another monitor) but no actual picture on the external monitor.

3. I connected the external display while in Windows (used the Fn key that would duplicate or extend the display). Do you suggest I try to set up the external display as primary through BIOS?

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1427
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T450s screen glitching

#4 Post by axur-delmeria » Wed Aug 09, 2017 1:01 pm

retrosaurus wrote:
Wed Aug 09, 2017 10:22 am
3. I connected the external display while in Windows (used the Fn key that would duplicate or extend the display). Do you suggest I try to set up the external display as primary through BIOS?
Not yet.

I'm not very familiar with the different T450s configurations. Does yours have Intel Graphics only, or nVidia? If it's the latter, is it Optimus or not?

If it's the former, then the issue may be with system RAM.

If it's the latter, then it's either the GPU itself or its video RAM. You might be able to disable the GPU in BIOS and stick with Intel graphics only.
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

retrosaurus
Posts: 6
Joined: Tue Aug 08, 2017 8:51 am
Location: New York, NY

Re: T450s screen glitching

#5 Post by retrosaurus » Wed Aug 09, 2017 3:23 pm

axur-delmeria wrote:
Wed Aug 09, 2017 1:01 pm
I'm not very familiar with the different T450s configurations. Does yours have Intel Graphics only, or nVidia? If it's the latter, is it Optimus or not?
ah, sorry I missed your question the first time. It's the Intel Graphics. My specs are below:

• Intel Core i5-5200U Processor (3MB Cache, up to 2.70GHz)
• Intel HD Graphics 5500
• Windows 10
• 14.0" FHD (1920 x 1080) with WWAN
• 720p HD Camera
• Security Chip Enabled
• 4 GB DDR3L - SDRAM 1600MHz Base soldered + 8 GB stick that I bought separately
• 500GB Hard Disk Drive, 7200rpm, 2.5"
• 16GB M.2 Solid State Drive Single
• 3rd M.2 SSD slot
• ThinkPad Battery 3 cell Li-Polymer (23.2Whr) Front
• ThinkPad Battery 3 cell Li-Polymer (23.2Whr) Rear
• Intel 7265 AC/B/G/N Dual Band Wireless + Bluetooth Version 4.0

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1427
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T450s screen glitching

#6 Post by axur-delmeria » Thu Aug 10, 2017 12:23 am

Since your T450s has Intel Graphics (uses system RAM), try removing the 8GB RAM and check if the problem goes away.
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

retrosaurus
Posts: 6
Joined: Tue Aug 08, 2017 8:51 am
Location: New York, NY

Re: T450s screen glitching

#7 Post by retrosaurus » Sat Aug 12, 2017 9:18 am

axur-delmeria wrote:
Thu Aug 10, 2017 12:23 am
Since your T450s has Intel Graphics (uses system RAM), try removing the 8GB RAM and check if the problem goes away.
I tried removing the 8gb RAM and didn't fix it. I'm worried it's the soldered 4gb RAM that's the issue but that's almost impossible to replace unless I grab a new mobo.

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1427
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T450s screen glitching

#8 Post by axur-delmeria » Sun Aug 13, 2017 4:03 am

I'm a bit worried about changing the BIOS setting of the primary display to External. If you don't get any video output on both the external monitor and the internal display, I don't know how to set the primary display back to Internal. :o
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

retrosaurus
Posts: 6
Joined: Tue Aug 08, 2017 8:51 am
Location: New York, NY

Re: T450s screen glitching

#9 Post by retrosaurus » Tue Aug 15, 2017 1:01 pm

Any possibility that it's the screen? I could try to get a replacement screen to test, but that's not a cheap test ($55+ cost)

RealBlackStuff
Admin
Admin
Posts: 18068
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: T450s screen glitching

#10 Post by RealBlackStuff » Tue Aug 15, 2017 1:31 pm

If still under warranty, call them up.
That looks to me like a bad GPU, which is part of the CPU.
Problem with the TXXXs models is, they have a soldered CPU.

retrosaurus
Posts: 6
Joined: Tue Aug 08, 2017 8:51 am
Location: New York, NY

Re: T450s screen glitching

#11 Post by retrosaurus » Tue Aug 15, 2017 6:19 pm

Yeah the one year warranty expired already. Any chance of renewing the warranty and getting it fixed?

RealBlackStuff
Admin
Admin
Posts: 18068
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: T450s screen glitching

#12 Post by RealBlackStuff » Wed Aug 16, 2017 2:07 am

AFAIK after expiration warranty renewal is not possible.
Look for a replacement mobo.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 5 guests