Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

ThinkPad T530 with Nvidia GPU: High CPU Usage

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
kwanbis
Posts: 7
Joined: Sat Nov 25, 2006 2:08 pm
Location: Argentina

ThinkPad T530 with Nvidia GPU: High CPU Usage

#1 Post by kwanbis » Mon Jun 22, 2020 4:51 am

Hi, I have been a user (and fan) of ThinkPads since the 755CD I used in like 25 years ago, and luckily I have been used only ThinkPads at work since that time, and I have had also ThinkPads as my personal machines.

My last ThinkPad was a T520 that I bought new and used non-stop 7x24 for 10 years. This year I decided to buy a T530 to replace it, as they are very similar in format, and the T540 has a horrible touchpad.

I got it like 4 months ago, installed Window 10, and if I recall correctly it worked very well. But then I decided to try Ubuntu on it, but it was constantly in high CPU mode. I thought it was something related to Linux, so I re-installed Windows 10.

But the problem still persists. It is mainly in Chrome, but I have also tried Chromium and it is the same problem. I even tried Firefox, but to be honest I don't see any decrease. It is not all the time, ti is at times. Some times, if I open task manager, it goes down after a while.

Before the Win>Linux switch, I used to have probably like 30 tabs open and nothing happened, now I have 11 tabs open and it is at 78% CPU. I have tried googling, tried lenovo drivers, manufacturer drivers, and windows 10 drivers. Same result.

The main problem is when I use JavaScript heavy pages like google docs/slides/sheets, or video (youtube).

This T530 has the Nvidia Optimus, I tried to enable the Intel GPU, the Nvidia GPU, and both, same problem. I tried to disable the Nvidia one within the BIOS, then the Intel one, same problem. I tried this because I have another T530 that does NOT have the Nvidia CPU and it works much better.

By the way, my T530 has 16GB of RAM, so memory shouldn't be a problem. Also, notice that I have re-installed Windows 2 times, build 1909 and 2004 (1909 seems to work better), and still the same issue. I also re-installed chrome/chromium.

Any ideas? Anyone with this issue? Thanks!

Image

Code: Select all

CPU-Z version			1.92.2.x64

Processors Information
-------------------------------------------------------------------------

	Number of cores		2 (max 2)
	Number of threads	4 (max 4)
	Manufacturer		GenuineIntel
	Name			Intel Core i5 3230M
	Codename		Ivy Bridge
	Specification		Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
	Package (platform ID)	Socket 988B rPGA (0x4)
	CPUID			6.A.9
	Extended CPUID		6.3A
	Core Stepping		E1/L1
	Technology		22 nm
	TDP Limit		35.0 Watts
	Tjmax			105.0 °C
	Core Speed		1198.0 MHz
	Multiplier x Bus Speed	12.0 x 99.8 MHz
	Base frequency (cores)	99.8 MHz
	Base frequency (ext.)	99.8 MHz
	Stock frequency		2600 MHz
	Instructions sets	MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, EM64T, VT-x, AES, AVX
	Microcode Revision	0x21
	L1 Data cache		2 x 32 KBytes, 8-way set associative, 64-byte line size
	L1 Instruction cache	2 x 32 KBytes, 8-way set associative, 64-byte line size
	L2 cache		2 x 256 KBytes, 8-way set associative, 64-byte line size
	L3 cache		3 MBytes, 12-way set associative, 64-byte line size
	Max CPUID level		0000000Dh
	Max CPUID ext. level	80000008h
	Cache descriptor	Level 1, D, 32 KB, 2 thread(s)
	Cache descriptor	Level 1, I, 32 KB, 2 thread(s)
	Cache descriptor	Level 2, U, 256 KB, 2 thread(s)
	Cache descriptor	Level 3, U, 3 MB, 16 thread(s)
	FID/VID Control		yes


	Turbo Mode		supported, enabled
	Max non-turbo ratio	26x
	Max turbo ratio		32x
	Max efficiency ratio	12x
	Min Power		24 Watts
	O/C bins		none
	Ratio 1 core		32x
	Ratio 2 cores		30x
	Ratio 3 cores		30x
	Ratio 4 cores		30x
	TDP Level		35.0 W @ 26x

	Temperature 0		52 degC (125 degF) (Package)
	Temperature 1		52 degC (125 degF) (Core #0)
	Temperature 2		52 degC (125 degF) (Core #1)
	Voltage 0		0.84 Volts (VID)
	Power 00		10.61 W (Package)
	Power 01		6.98 W (IA Cores)
	Power 02		0.03 W (GT)
	Power 03		3.60 W (Uncore)
	Clock Speed 0		1198.00 MHz (Core #0)
	Clock Speed 1		1198.00 MHz (Core #1)
	Core 0 max ratio	32.0 (effective 32.0)
	Core 1 max ratio	32.0 (effective 32.0)

BIOS
-------------------------------------------------------------------------

UEFI				Yes
BIOS Vendor			Phoenix Technologies, LTD
BIOS MSG			äa¨túâíëá´€ë2äËÿ.öàÿÀtyëPäa¨túäa¨uúâòÛtKëëXÃPQ¹
BIOS Date			09/09/19
Mainboard Model			äa¨túâíëá´€ë2äËÿ.öàÿÀtyëPäa¨túäa¨uúâòÛtKëëXÃPQ¹

Mainboard Model		24297ZG (0x000001A9 - 0x00438987)

Chipset
-------------------------------------------------------------------------

Northbridge			Intel Ivy Bridge rev. 09
Southbridge			Intel QM77 rev. 04
Graphic Interface		PCI-Express
PCI-E Link Width		x16
PCI-E Max Link Width		x16
Memory Type			DDR3
Memory Size			16 GBytes
Channels			Dual
Memory Frequency		665.6 MHz (1:5)
CAS# latency (CL)		9.0
RAS# to CAS# delay (tRCD)	9
RAS# Precharge (tRP)		9
Cycle Time (tRAS)		24
Command Rate (CR)		1T
Host Bridge			0x0154


Memory SPD
-------------------------------------------------------------------------

DIMM #				1
	SMBus address		0x50
	Memory type		DDR3
	Module format		SO-DIMM
	Module Manufacturer(ID)	Patriot Memory (7F7F7F7F7F020000000000)
	Size			8192 MBytes
	Max bandwidth		PC3-10700 (667 MHz)
	Part number		PSD38G13332S
	Number of banks		8
	Nominal Voltage		1.50 Volts
	EPP			no
	XMP			no
	AMP			no

DIMM #				2
	SMBus address		0x51
	Memory type		DDR3
	Module format		SO-DIMM
	Module Manufacturer(ID)	Patriot Memory (7F7F7F7F7F020000000000)
	Size			8192 MBytes
	Max bandwidth		PC3-10700 (667 MHz)
	Part number		PSD38G13332S
	Number of banks		8
	Nominal Voltage		1.50 Volts
	EPP			no
	XMP			no
	AMP			no

Thinkpad4by3
Senior ThinkPadder
Senior ThinkPadder
Posts: 2667
Joined: Sun Aug 09, 2015 9:25 am
Location: N. Bellmore, ny

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#2 Post by Thinkpad4by3 » Mon Jun 22, 2020 8:15 am

I5-3230M is not the fastest thing, although should be capable of it. Why is your CPU running at only 1.2GHz though? It might be pegged because it's not going full speed.
Thinkpad4by3's Law of the Universe.

The efficiency of two screens equally sized with equal numbers if pixels are equal. The time spent by a 4:3 user complaining about 16:9 is proportional to the inefficiency working with a 16:9 display, therefore the amount of useful work extracted is equal.

kwanbis
Posts: 7
Joined: Sat Nov 25, 2006 2:08 pm
Location: Argentina

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#3 Post by kwanbis » Mon Jun 22, 2020 8:58 am

Thinkpad4by3 wrote:
Mon Jun 22, 2020 8:15 am
I5-3230M is not the fastest thing, although should be capable of it. Why is your CPU running at only 1.2GHz though? It might be pegged because it's not going full speed.
Thanks for replying.

The T520 I had was perfectly capable of running Chrome. I don't believe the T530 cannot handle it. Also because it used to work before the re-install, and because my wife's computer works just fine. I understand it might be slow to run something like blender. But this is just chrome.

Where do you see my laptop running at 1.2? Thanks again!

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1528
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#4 Post by kfzhu1229 » Mon Jun 22, 2020 9:52 am

For your usage a quad core i7 is a must. If you still have that T520 lying around you can use that CPU in a T530 but not the other way around (thanks to intel).
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 128gb WSXGA+ Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

kwanbis
Posts: 7
Joined: Sat Nov 25, 2006 2:08 pm
Location: Argentina

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#5 Post by kwanbis » Mon Jun 22, 2020 10:14 am

kfzhu1229 wrote:
Mon Jun 22, 2020 9:52 am
For your usage a quad core i7 is a must. If you still have that T520 lying around you can use that CPU in a T530 but not the other way around (thanks to intel).
Why would that be the case? My wife's T530 works perfectly. Do you think the T520 CPU is better than the T530 one? I don't think so. Both are i5. It is no longer turning on so I cannot verify what exact CPU. And like I said, previous to the switch Win > Linux (and back), it worked perfectly.

Thinkpad4by3
Senior ThinkPadder
Senior ThinkPadder
Posts: 2667
Joined: Sun Aug 09, 2015 9:25 am
Location: N. Bellmore, ny

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#6 Post by Thinkpad4by3 » Mon Jun 22, 2020 11:53 pm

kwanbis wrote:
Mon Jun 22, 2020 8:58 am
Where do you see my laptop running at 1.2? Thanks again!
Look about 12 lines down under your CPU-Z info.

"Core Speed 1198.0 MHz"
Thinkpad4by3's Law of the Universe.

The efficiency of two screens equally sized with equal numbers if pixels are equal. The time spent by a 4:3 user complaining about 16:9 is proportional to the inefficiency working with a 16:9 display, therefore the amount of useful work extracted is equal.

kwanbis
Posts: 7
Joined: Sat Nov 25, 2006 2:08 pm
Location: Argentina

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#7 Post by kwanbis » Tue Jun 23, 2020 3:25 am

Thinkpad4by3 wrote:
Mon Jun 22, 2020 11:53 pm
kwanbis wrote:
Mon Jun 22, 2020 8:58 am
Where do you see my laptop running at 1.2? Thanks again!
Look about 12 lines down under your CPU-Z info.

"Core Speed 1198.0 MHz"
Thanks, I understand that CPUs underclock when not in full use, but that is really weird as at the time the CPU was at 89%. Good catch.

kwanbis
Posts: 7
Joined: Sat Nov 25, 2006 2:08 pm
Location: Argentina

Re: ThinkPad T530 with Nvidia GPU: High CPU Usage

#8 Post by kwanbis » Mon Jun 29, 2020 3:30 am

After more checking and more testing, I realized that it was Lastpass' extension on chrome that was causing all of the trouble.

https://news.ycombinator.com/item?id=21172569

I uninstalled it instantly and all seems to be fine now.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: No registered users and 11 guests