Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

No working USB ports on ThinkPad Pro Docking station when connected to T480

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
jskang
Posts: 33
Joined: Thu Feb 21, 2008 3:07 pm
Location: Maple Grove, MN

No working USB ports on ThinkPad Pro Docking station when connected to T480

#1 Post by jskang » Mon Nov 19, 2018 12:46 pm

I'm hoping others might have encountered this and can share their experience in hopefully fixing this problem.

Background: I have a new T480 (20L5) and new ThinkPad Pro docking station (40AH0135US). I believe the connector between the laptop and the dock is now Thunderbird and no longer a proprietary connector.

When the T480 is connected to the docking station, the Ethernet, 2x Display Port, and power ports on the docking station all work. None of the five USB ports (3x USB 3.x and 2x USB 2.0) or the 3.5mm headset jack work. I have run the firmware update utility for the docking station and confirmed it's running the latest firmware.

I have tried two brand new pro docks and have had the same experience with both. After speaking with my account rep at Connection.com (formerly PC Connection), I was asked to contact the Lenovo ThinkPad support group for further assistance. They shipped out a replacement and it also behaves the same way.

I did some brief searching here and didn't turn up any previous posts reporting similar. I have done some searching on Google and found a topic on the Lenovo user forums where someone reported similar problems with no resolution. One person suggested that they did not see the problem with the Ultra dock. If I can't get these docks to work reliably, I need to return them to Connection.com.

I'm hoping someone here has run into this and found a solution.

Thanks in advance!

alexcasillas
Posts: 1
Joined: Thu Jan 24, 2019 1:44 pm
Location: tlajomulco de zuñiga, Mexico

Re: No working USB ports on ThinkPad Pro Docking station when connected to T480

#2 Post by alexcasillas » Thu Jan 24, 2019 1:47 pm

This is exactly the same problem with my T480 and my pro dock... usb are not working in the dockstation ... lenovo support sent me links to drivers but not working at all ... did you get a solution for this other than a replacement ? thanks

jskang
Posts: 33
Joined: Thu Feb 21, 2008 3:07 pm
Location: Maple Grove, MN

Re: No working USB ports on ThinkPad Pro Docking station when connected to T480

#3 Post by jskang » Thu Jan 24, 2019 4:10 pm

alexcasillas wrote:
Thu Jan 24, 2019 1:47 pm
This is exactly the same problem with my T480 and my pro dock... usb are not working in the dockstation ... lenovo support sent me links to drivers but not working at all ... did you get a solution for this other than a replacement ? thanks
I did. After confirming with Lenovo customer support that I had installed all related updates, etc., they sent a Lenovo field rep out to replace the mainboard in my T480.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 7 guests