Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T470 (type HD20, HE20): Intel HD 520 Graphics not working in Windows 7 Pro 64-bit

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
emasks
Posts: 3
Joined: Sun Jan 06, 2019 9:37 am
Location: Fargo, ND

T470 (type HD20, HE20): Intel HD 520 Graphics not working in Windows 7 Pro 64-bit

#1 Post by emasks » Sun Jan 06, 2019 9:38 am

The computer came with Windows 10 when I got it a while ago, and recently I've decided to put Windows 7 on it instead. This process has been fraught with peril: I had to mount an ISO and manually add USB 3.0 drivers - and use Rufus to create a UEFI bootable stick - just to be able to install Windows 7 in the absence of an optical drive; I had to manually install Ethernet and Wifi drivers; etc. I've fielded those problems on my own, but I'm stuck on getting Windows to use or even recognize my Intel HD 520 integrated graphics: it shows up as "Standard VGA Graphics Adapter" in the Device Manager, and even in the Intel Driver & Support Assistant - https://i.imgur.com/4AGEmjd.png

Trying to run DirectX games such as League of Legends gives me this error - https://i.imgur.com/v2tPy5t.png

And so a fix must be found!

In effort to fix this trouble, I went to the Lenovo website. Unfortunately, the T470 doesn't have a Windows 7 graphics driver listed; so, I went to Intel. They do list two possible downloads:
+ 15.45.23.4860 (for 6th Gen Only) https://downloadcenter.intel.com/downlo ... -15-45-?pr...
+ 15.40.14.4352 (for 6th Gen) https://downloadcenter.intel.com/downlo ... -40-6th-Ge...

I've tried both of those download links. Each successfully runs the installer, which reads and extracts files, then I am presented with this error - https://i.imgur.com/XJy16zY.png

Windows then gives me a notification that the driver may not have installed correctly, and prompts me to try again with recommended settings. Again the installer reads and extracts files, then gives me this slightly different error - https://i.imgur.com/M41cd24.png

I know people successfully run Windows 7 on T470s, but I have hit a snag I do not know how to overcome. Assistance is appreciated! It's worth noting that these issues did not occur when running Windows 10.

dr_st
Moderator
Moderator
Posts: 8099
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T470 (type HD20, HE20): Intel HD 520 Graphics not working in Windows 7 Pro 64-bit

#2 Post by dr_st » Sun Jan 06, 2019 9:51 am

Welcome to the forum. :D

Can you manually install the driver (via the INF file) after unpacking all files from the installer? You may need to let the installer 'hang there' while browsing to the temporary folder where it unpacked the files.

If that does not work, you may succeed by hacking the INF to tell it that it supports Win7 (and not just Win10). This trick has been tested with relative success going the other way (getting drivers for old Intel GPUs to run on Win10).
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

emasks
Posts: 3
Joined: Sun Jan 06, 2019 9:37 am
Location: Fargo, ND

Re: T470 (type HD20, HE20): Intel HD 520 Graphics not working in Windows 7 Pro 64-bit

#3 Post by emasks » Sun Jan 06, 2019 9:55 am

dr_st wrote:
Sun Jan 06, 2019 9:51 am
Welcome to the forum. :D

Can you manually install the driver (via the INF file) after unpacking all files from the installer? You may need to let the installer 'hang there' while browsing to the temporary folder where it unpacked the files.

If that does not work, you may succeed by hacking the INF to tell it that it supports Win7 (and not just Win10). This trick has been tested with relative success going the other way (getting drivers for old Intel GPUs to run on Win10).
I have run the .EXE and I have unpacked the .ZIP and tried running that .EXE; I have not tried messing with the INF. Can you provide guidance?

emasks
Posts: 3
Joined: Sun Jan 06, 2019 9:37 am
Location: Fargo, ND

Re: T470 (type HD20, HE20): Intel HD 520 Graphics not working in Windows 7 Pro 64-bit

#4 Post by emasks » Sun Jan 06, 2019 10:44 am

Solution was found in this thread on Tom's Hardware: http://www.tomshardware.com/forum/id-34 ... -lake.html

Literally as simple as copying the code from the Windows 10 section of the driver INF to the Windows 7 section.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 22 guests