Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T430s indicator LEDs not working

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
matthew28845
Posts: 7
Joined: Wed Feb 13, 2019 11:10 pm
Location: Minneapolis, MN
Contact:

T430s indicator LEDs not working

#1 Post by matthew28845 » Tue Apr 02, 2019 11:18 pm

A few weeks ago, I noticed that the indicator LEDs on the screen bezel of my T430s were not working - all 4 of them were always off. Would it be worth it to seek out a new LED board, or is it more likely the issue is elsewhere, like a blown fuse or a bad cable?
lenovo ThinkPad T430s, lenovo ThinkPad T500, IBM ThinkPad A21m

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2344
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T430s indicator LEDs not working

#2 Post by axur-delmeria » Wed Apr 03, 2019 12:16 am

Bad cable is a more common failure compared to the LED board.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 8 guests