Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T440p + i7-4600M - video artifacts

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
ndandanov
Posts: 4
Joined: Tue Dec 30, 2014 10:22 am
Location: Sofia, Bulgaria

T440p + i7-4600M - video artifacts

#1 Post by ndandanov » Tue Jun 04, 2019 2:39 am

Hello,

I recently got a T440p (integrated graphics only) with an Intel Core i7-4600M and have some questions related to it.

1. First, the device would not boot properly - if no RAM was installed, it would beep 3-3-1. After installing RAM, it would pretend to start properly, but nothing is displayed neither on the screen nor on an external monitor connected with VGA. The green power LED is solid and during startup the backlit keyboard flashes once as if it was a normal startup. This is when using an external USB drive with SystemRescueCd only and no internal SATA drive. The lights on the thumb drive are solid so there seems to be no read/write activity. I tried to remove the external battery and the CMOS one, but this has lead to no positive effects. I also tried with another CPU and changing the RAM slot and stick but to no avail. Any clue what could have gone wrong with this motherboard? Corrupted BIOS? Some component/trace damage?
2. Based on the above, I replaced the motherboard. The system would now boot properly, however there are video artifacts when working with higher resolution. Here you can see a video displaying the artifacts when booting Windows 7: https://youtu.be/4JqViOmJoxk

I decided that having an integrated GPU, the issue must lie within the CPU so I swapped it with a tested i5-4300M and the artifacts were gone: https://youtu.be/Kkxv-j1fNJQ

In both cases I did *not* re-apply fresh thermal paste, however the problem should not be related to high temperatures as during startup, the 4300M got up to ~60 degrees Celsius. Currently Arctic Silver MX-4 was applied before the swap, however it is not electrically conductive so this should not pose any issue. Here is a photo of the i7-4600M: https://i.imgur.com/8Xsyodt.jpg

The BIOS version is quite old, but I doubt it that it could be the reason: https://i.imgur.com/uwI6B5t.jpg

3. Is there any way to read the accelerometer values from Linux or Windows? I dropped the new motherboard from a few centimeters on a hard bench and would like to see whether the accelerometer works properly. I read that tp_smapi does not work properly on newer ThinkPads, however there may be some other means to directly access the current values.

Thanks in advance!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 29 guests