Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Weird T430 1080P Flickering Issue (Fixed once VGA plugged in)

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
MadMax_INT
Posts: 4
Joined: Mon Mar 11, 2019 4:10 pm
Location: Sint-Niklaas, Belgium

Weird T430 1080P Flickering Issue (Fixed once VGA plugged in)

#1 Post by MadMax_INT » Mon Jul 08, 2019 6:36 am

I've been having this long standing battle with this 1080p kit of mine. I already tried a different screen and instead of going black, it simply starts flickering really heavily.
HOWEVER, once I plug in a VGA cable there are no issues anymore at all! Why is this, and how can I fix it? This is my last try before returning the controller board.

T430 has been tested thoroughly, even going as far as plugging the whole controller/ display assembly into another T430 followed by a T420 replicates the issue. The controller board is the latest revision, cables are all correctly attached and I have also tried using the controller board outside of the laptop on top of an anti-statis mat to cancel out any interference. This happens on any version of linux and windows.

wujstefan
ThinkPadder
ThinkPadder
Posts: 1131
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: Weird T430 1080P Flickering Issue (Fixed once VGA plugged in)

#2 Post by wujstefan » Mon Jul 08, 2019 7:25 am

This is most likely your FHD kit. This is a hit-or-miss (with the latter being far more common) with non-s models.
Too many thinkpads not enough time!
(stable under reduction)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 8 guests