Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T460s, camera and windows 1903

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
norricorp2
Posts: 3
Joined: Sat Aug 17, 2019 3:41 am
Location: reading, uk

T460s, camera and windows 1903

#1 Post by norricorp2 » Sat Aug 17, 2019 4:00 am

Several months ago I upgraded to the 1809 windows update from 1803. This stopped the integrated camera working. I contacted Lenovo support and was told to roll back, which I did. And the camera started working.
This week I upgraded to 1903. And once again the camera has stopped. And there have been no new drivers from Lenovo so I have no idea if this is a common problem..
Having googled the problem, there is not a lot of specific stuff. But I have noticed a few things, so perhaps someone on this forum can help.

In device manager, my camera is under Cameras -> Integrated Cameras, yet various posts from MS and Lenovo have it as Imaging Devices.

In Lenovo Vantage, my camera is always "camera is in use, Another app is using the camera" - by what? I have set privacy in windows so that only skype, vantage and camera can use the camera. And they are not running (except vantage).Using sysinternals to find which process is using the device (physical device object name) shows no matching items.

When the camera is used, I get an initial few seconds and then it freezes. I really do not want to roll back the update.

Have others had this problem? Is it a windows problem? Or a Lenovo problem?

Regards,
John

sktn77a
Senior ThinkPadder
Senior ThinkPadder
Posts: 2005
Joined: Thu Apr 29, 2004 9:44 am
Location: Chapel Hill, NC

Re: T460s, camera and windows 1903

#2 Post by sktn77a » Sat Aug 17, 2019 6:59 pm

Well, I have a T460 (not a T460s) with 1903 and have not had that problem. Mine was a clean install from the Microsoft download page, not an upgrade.
Keith
(Formerly 600E, T40, T41, 2xT42, 2xT61p, T420
Currently 4xT430, 2xT460, H520S, Ideapad K1)

norricorp2
Posts: 3
Joined: Sat Aug 17, 2019 3:41 am
Location: reading, uk

Re: T460s, camera and windows 1903

#3 Post by norricorp2 » Mon Aug 19, 2019 1:19 am

I think the T460s and T460 are quite different machines. But I don't think this is a common problem in that I have not seen much on google re feature upgrade / camera on a T460s. Though there is a quite a bit about feature upgrades and cameras on Lenovo's generally.
I think the camera driver may come from MS rather than Lenovo. Which may explain why Lenovo never produce driver upgrades for cameras.
Hopefully I am not the only person to have this problem …..

norricorp2
Posts: 3
Joined: Sat Aug 17, 2019 3:41 am
Location: reading, uk

Re: T460s, camera and windows 1903

#4 Post by norricorp2 » Mon Aug 19, 2019 2:22 am

And just rolled back to 1803. Camera works, vantage shows camera without telling me that another app is using the device.
In my previous post I said that MS provided the driver but it is actually Realtek. And with windows 1803 still using the latest driver.
So I seem to be in the position where the thinkpad 460s is stuck at 1803 if I want camera functionality.
I am loathe to do a fresh install of windows because then I then I can't go back and I am not sure why anyone would not use the upgrade facility - it is supposed to work. And on the whole it does. But for me, for the last two feature upgrades, it has broken the camera.

kpevav
Freshman Member
Posts: 59
Joined: Sun Oct 02, 2011 6:17 am
Location: Columbia, SC

Re: T460s, camera and windows 1903

#5 Post by kpevav » Sun Sep 01, 2019 11:31 am

I have a T460s running Windows Pro 1903 and the camera is working. I hope your issue has been solved by now.

jdhurst
Admin
Admin
Posts: 5865
Joined: Thu Apr 29, 2004 6:49 am
Location: Toronto, Canada

Re: T460s, camera and windows 1903

#6 Post by jdhurst » Sun Sep 01, 2019 11:58 am

I see in Reliability History on my ThinkPad X1:

Installation Successful: Windows successfully installed the following update: 9WZDNCRFJBBG-MICROSOFT.WINDOWSCAMERA

In Device Manager, Camera has moved to its own section (away from the Imaging Section).

While I can see this is not your machine, see if Windows has a driver for your machine - if not now, possibly in the near future

kpevav
Freshman Member
Posts: 59
Joined: Sun Oct 02, 2011 6:17 am
Location: Columbia, SC

Re: T460s, camera and windows 1903

#7 Post by kpevav » Sun Sep 01, 2019 12:13 pm

I see the Camera section in Device Manager on my T460s as well in 1903. It is working as intended.

I hope the OP got his working in 1903.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 16 guests