Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T530 WiFi adapter stops auto-connecting

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
JPOESQ
**SENIOR** Member
**SENIOR** Member
Posts: 180
Joined: Sun May 16, 2004 2:26 pm
Location: San Francisco, CA
Contact:

T530 WiFi adapter stops auto-connecting

#1 Post by JPOESQ » Fri Nov 01, 2019 8:44 pm

I have a T530 running Windows 10. Every couple of days I boot the computer and the WiFi is disconnected. I run the network troubleshooter, it resets the adapter, and WiFi auto-connects again. A few days later rinse and repeat.

Everything was fine until a Windows update. I can’t recall which one.

All of the drivers are correct, the adapter is not set to go into standby and I have checked for any Windows errors. There’s no reason that it should work for a few days and then need to be reset (or connect manually).

I’m open to suggestions. Thanks.
John P. O'Banion, JD, PE, BSEE
Registered Patent Attorney
http://www.intellectual.com

600, X220, T530, X1 Carbon 5th Signature Edition

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20392
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T530 WiFi adapter stops auto-connecting

#2 Post by RealBlackStuff » Sat Nov 02, 2019 2:17 am

One thing that helped me in a similar situation:
remove the antennas and the wifi card.
Clean the gold contacts on both sides with an eraser, until they shine.
Remove the eraser leftovers with a brush and reinsert the card 2 or 3 times (to clean its contacts).
Reattach the antennas and turn them a little back and forth a few times (to clean their contacts).
Should be a lot better now.

And as usual, blame Micro$haft and its W10 abomination.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

JPOESQ
**SENIOR** Member
**SENIOR** Member
Posts: 180
Joined: Sun May 16, 2004 2:26 pm
Location: San Francisco, CA
Contact:

Re: T530 WiFi adapter stops auto-connecting

#3 Post by JPOESQ » Sat Nov 02, 2019 9:55 am

Good suggestion. I was focusing on a software issue.
John P. O'Banion, JD, PE, BSEE
Registered Patent Attorney
http://www.intellectual.com

600, X220, T530, X1 Carbon 5th Signature Edition

sktn77a
Senior ThinkPadder
Senior ThinkPadder
Posts: 2006
Joined: Thu Apr 29, 2004 9:44 am
Location: Chapel Hill, NC

Re: T530 WiFi adapter stops auto-connecting

#4 Post by sktn77a » Tue Nov 19, 2019 9:27 pm

Well, sounds pretty much like a software issue. Do you have Lenovo Vantage installed on your computer? If so, use the System Update app to make sure you have the latest Lenovo driver and not an older Microsoft driver.
Keith
(Formerly 600E, T40, T41, 2xT42, 2xT61p, T420
Currently 4xT430, 2xT460, H520S, Ideapad K1)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430/T530 and later Series”

Who is online

Users browsing this forum: No registered users and 42 guests