Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T450s Power Bridge not working

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
boberto19
Posts: 11
Joined: Sun Nov 03, 2019 1:33 am
Location: Las Vegas, NV

T450s Power Bridge not working

#1 Post by boberto19 » Sat Nov 30, 2019 5:01 pm

Whenever I try to hot-swap the removable battery, and I pull out the removable battery, it momentarily loses power and the computer reboots (on internal power/ "battery 1") before I slip in the new battery, which entirely defeats the purpose of having a battery bridge.

Anyone have a clue how to fix this? I'm running win10.

Brian10161
Junior Member
Junior Member
Posts: 308
Joined: Mon Jan 25, 2010 5:53 pm
Location: Canada

Re: T450s Power Bridge not working

#2 Post by Brian10161 » Tue Dec 24, 2019 11:47 pm

I don't know if you ever got this resolved, but did you install the power manager driver? I'm running 8.1 on mine and this method of swapping batteries seems to work well for me. I did use the Lenovo System Update and installed all the recommended drivers for it however.
Thinkpad T450s - Everyday ( i5-5300u, 8gb, 240gb ssd, 1600x900 )
Thinkpad T430s - Home ( i5-3320m, 8gb, 500gb ssd, 1600x900 )
Thinkpad T410s - Work ( i5-520m, 4gb, 120gb ssd, 1440x800 )

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: No registered users and 34 guests