Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Issue installing Linux Mint after Windows 7 (solved)

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
wrybread
Freshman Member
Posts: 122
Joined: Wed May 30, 2007 12:01 am
Location: San Francsico, CA

Issue installing Linux Mint after Windows 7 (solved)

#1 Post by wrybread » Thu Jan 02, 2020 10:01 pm

I'm trying to install Linux Mint on my T530 that already has Win7 installed.

When installing Linux Mint though, it's not finding the Win7 partition:

Image

Any tips to make it see the Win7 partition?

In bios I have "UEFI/Legacy Boot" set to "Both". Then "UEFI/Legacy Boot Priority" is set to "Legacy First", and "CSM Support" is set to "yes".

If I set it to "Legacy Only" Windows won't boot, it goes to the Boot Menu, and selecting "Windows Boot Manager" does nothing.

Any tips?

According to this guide I should disable "secure boot" and "fast boot" in bios. I found secure boot and it was already disabled, but don't see an option for fast boot:

https://www.tecmint.com/install-linux-m ... uefi-mode/

Is it important for the Mint installer to see the Windows partition? It's been awhile since I installed it, but I'm pretty sure in the past it was seeing the Windows partition.

Using latest Mint (19.3).

I have the drive imaged so can take my chances by clicking through the dialog, but wondering if anyone has any words of wisdom.

Edit: I found this tutorial for converting GPT partition table (UEFI bios) to MBR (legacy bios):

https://www.youtube.com/watch?v=OP7NikNiCuk

It uses EaseUS Partition Manager, but it's $60 and the free and trial versions won't do it.
Last edited by wrybread on Fri Jan 03, 2020 12:43 am, edited 1 time in total.

wrybread
Freshman Member
Posts: 122
Joined: Wed May 30, 2007 12:01 am
Location: San Francsico, CA

Re: Issue installing Linux Mint after Windows 7 (dual boot)

#2 Post by wrybread » Thu Jan 02, 2020 11:54 pm

Aha, solved it. I set "UEFI/Legacy" to "UEFI" and the Mint installer was able to find the Windows partition.

That's because Windows was installed in UEFI mode. I guess all OS's have to be in the same mode, either UEFI or Legacy.

And because I had it set to "both" with "legacy first" Mint was booting into Legacy mode, and therefore not finding the Windows partition.

Working great now.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: refujee and 35 guests