Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T440p touchpad/keyboard help. It just keeps getting worse.

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

T440p touchpad/keyboard help. It just keeps getting worse.

#1 Post by kyle2000yt » Mon Jan 20, 2020 11:19 pm

So a few days ago I did the touchpad mod on my T440p. Installed a Synatics Touchpad, and got the drivers working. But today, the keyboard and touchpad stopped working for no reason at all. First, the keyboard's touchpad and backlight stopped working (the keys still worked). On my touchpad, only the mouse worked; none of the physical buttons did. I did some more messing with the ribbon cable when the entire thing just stopped working (I just want to stay I was messing with the ribbon cables while the system was on). The mouse and keys on the touchpad did not work at all. So I shut the system down, and it got worse!


I got a 1-3-3-1/3-3-1 beep code (for some reason, sometimes I hear a short beep and pause before the first 3 beeps). Looking at Lenovo's HMM, it doesn't mention a beep code like that. But looking online people have the same issue, mostly with the X240. After doing the touchpad swap they get this beep code. When I unplug the cable, everything works and the system boots. But when the cable is connected, I get a beep code. Some people said to reseat the RAM, and I did that. But it still gave me the beep code.

As a test, I unplugged the ribbon cable from the touchpad and plugged in my keyboard. It did not give me a beep code and booted just fine


Did I mess up the motherboard? I really, really do not want to go through with a full teardown to replace the motherboard if that's the problem. My other thoughts is that it's the touchpad or cable. Since I still have my old touchpad, I plugged it in with a different ribbon cable, and the SAME BEEP CODE! This has to be my motherboard right? My motherboard is screwed now, right? :cry:

If I possibly blew a fuse, I do see a fuse named "F15" by the touchpad cable connector. Maybe it blew, but I can't tell. It didn't explode or anything, nor did I hear any pops.

Here is some more information about the keyboard. The green light near the FN key is always on, and I can't turn it off. The backlight doesn't come on (Fn + SpaceBar) and the trackpoint doesn't work. I can only type. Keep in mind I was doing this tests with the keyboard physically removed. What connector supplies the power for the backlight power?

Update 1: I looked at the touchpad cable again, and I found out a few pins on the cable were actually damaged. But when I tried with a different cable I got the same thing.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21283
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#2 Post by RealBlackStuff » Tue Jan 21, 2020 1:32 am

Sounds like either a faulty touchpad or a faulty touchpad cable.
Does your machine have a fingerprint reader?
If so, that FPR is on the same cable as the touchpad and could also have become mis/disconnected.
Check the touchpad cable that it is not torn and that it is straight and properly inserted/connected inside the touchpad.
F15 is indeed the touchpad fuse. Check it for continuity with a multimeter.

Remove charger and battery, hold down the power button for ~20 seconds.
Connect charger, press power and then F1 immediately to boot into BIOS.
If OK, power off, insert battery, boot into BIOS again.
If still beeping, power off, swap RAM modules, make sure they are low-voltage ones (DDR3L, 3.5V).
Try booting again.

You can turn the green Fn LED on/off by pressing Fn/Esc together.
Does your spacebar have a 'light' symbol on it? If not, you don't have a backlit KB.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#3 Post by kyle2000yt » Tue Jan 21, 2020 9:45 am

RealBlackStuff wrote:
Tue Jan 21, 2020 1:32 am
Sounds like either a faulty touchpad or a faulty touchpad cable.
Does your machine have a fingerprint reader?
If so, that FPR is on the same cable as the touchpad and could also have become mis/disconnected.
Check the touchpad cable that it is not torn and that it is straight and properly inserted/connected inside the touchpad.
F15 is indeed the touchpad fuse. Check it for continuity with a multimeter.

Remove charger and battery, hold down the power button for ~20 seconds.
Connect charger, press power and then F1 immediately to boot into BIOS.
If OK, power off, insert battery, boot into BIOS again.
If still beeping, power off, swap RAM modules, make sure they are low-voltage ones (DDR3L, 3.5V).
Try booting again.

You can turn the green Fn LED on/off by pressing Fn/Esc together.
Does your spacebar have a 'light' symbol on it? If not, you don't have a backlit KB.
Yes, I can verify the fingerprint reader works. Does this mean the touchpad fuse isn't blown? I checked, and it appears I bent a few of the pins on the touchpad cable, but it's near the motherboard. But I tried a different ribbon cable I had laying around with my old ClunkPad, and I still got the beep code. I'm going to try ordering a new ribbon cable, but condiring it still beeps with a different ribbon, it suggests something is wrong with the motherboard, unless both of these cables are damaged. sebileis suggested those pins possibly shorted the motherboard.


Like I said, the keyboard is also acting weird. While typing works fine, the backlight or trackpoint nipple doesn't work, Yes, I have the backlit LiteOn keyboard with the logo symbol on the spacebar. Good news is that Fn+Esc turns the keyboard light on the Escape key off, which is good.

I disconnected the power and battery and held it for 20 seconds, it still gave the beeps. I tried reseating the RAM. How can I check if it's low voltage RAM? The machine works fine with the RAM installed, as long as the touchpad cable isn't installed. One of the RAM sticks say DDR3 1600 SODIMM 1.35v

Is there a fuse for the keyboard? Or is that F15. I would guess the keyboard fuse is blown if the backlight isn't working correctly. What ribbon cable on the keyboard provides the power for the backlight?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21283
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#4 Post by RealBlackStuff » Tue Jan 21, 2020 10:33 am

How can you bend contacts on a flat cable?
Did you screw up the motherboard and/or touchpad connector?
Put a link here to a picture of that 'bad' cable.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#5 Post by kyle2000yt » Tue Jan 21, 2020 11:07 am

RealBlackStuff wrote:
Tue Jan 21, 2020 10:33 am
How can you bend contacts on a flat cable?
Did you screw up the motherboard and/or touchpad connector?
Put a link here to a picture of that 'bad' cable.
https://imgur.com/a/Mem9e1N

The actual connector looks fine.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21283
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#6 Post by RealBlackStuff » Tue Jan 21, 2020 11:59 am

Don't know how you did that, probably forced it in while the cable clamp was already down.
You could try to cut off the damaged part (in a straight line) and also make those 2 square "side-placeholder" cuts a bit deeper, the exact width of the cut-off.
Then put the cable in, clamp it down and use a piece of electrician's tape to hold it in place.
Or get a new cable.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#7 Post by kyle2000yt » Tue Jan 21, 2020 1:40 pm

RealBlackStuff wrote:
Tue Jan 21, 2020 11:59 am
Don't know how you did that, probably forced it in while the cable clamp was already down.
You could try to cut off the damaged part (in a straight line) and also make those 2 square "side-placeholder" cuts a bit deeper, the exact width of the cut-off.
Then put the cable in, clamp it down and use a piece of electrician's tape to hold it in place.
Or get a new cable.
Yes, you're most likely about how I broke the cable. For some reason the T440p's ribbon cable sort of goes in at an angle. It's strange. I thought maybe the pins that control the right/left click buttons weren't making good contact.

I'm just going to buy a new cable. If that doesn't work I'm going to look at the fuse. Hopefully it's just the cable. But since the backlight and trackpoint isn't working, that's strange. Does the fuse for the touchpad also control the backlight and trackpoint?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21283
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#8 Post by RealBlackStuff » Wed Jan 22, 2020 12:31 am

KB-backlight fuse = F24
F13 and F23 are connected with the touchpad TrackPoint, don't know which function.
All three are 1A/32V_ERBRD1R00X fuses.
No idea about any trackpoint fuse, if there even is one.

Look at your KB-cable, if you morxed that in, the same way as the touchpad cable, you're SOL and also need a new KB.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#9 Post by kyle2000yt » Wed Jan 22, 2020 10:48 am

RealBlackStuff wrote:
Wed Jan 22, 2020 12:31 am
KB-backlight fuse = F24
F13 and F23 are connected with the touchpad trackpoint, don't know which function.
All three are 1A/32V_ERBRD1R00X fuses.
No idea about any trackpoint fuse, if there even is one.

Look at your KB-cable, if you morxed that in, the same way as the touchpad cable, you're SOL and also need a new KB.
No, it doesn't look like I damaged the cables for the keyboard. I have a new keyboard coming in the mail I ordered a few weeks ago, just to test. Where is F24 located on the mobo?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21283
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#10 Post by RealBlackStuff » Wed Jan 22, 2020 11:40 am

For F24 follow pin 8 from the KB-connector, fuse is marked with an H.
You need to do the search yourself.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#11 Post by kyle2000yt » Wed Jan 22, 2020 12:38 pm

RealBlackStuff wrote:
Wed Jan 22, 2020 11:40 am
For F24 follow pin 8 from the KB-connector, fuse is marked with an H.
You need to do the search yourself.
Some sort of bad news, I hear a faint sort of "sizzling"/"cracking" sound coming from the mobo. It's very quiet and I dunno what it is, but it seems like something is wrong the motherboard. Hopefully it's just a blown fuse. I don't think a fuse on the keyboard is blown, since the backlight/trackpoint wasn't working, before the touchpad completely stopped working. It doesn't look like I damaged the touchpad connector on the mobo, at least not physically.

kyle2000yt
Posts: 33
Joined: Mon Jul 08, 2019 11:59 am
Location: Macomb, Michigan, USA

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#12 Post by kyle2000yt » Wed Jan 22, 2020 1:48 pm

Some good news! I got the backlight to work at one point. it turns on during the POST I believe. I suspect the clamp that holds the touchpad ribbon cable is not holding the cable tight enough and it doesn't make good enough contact anymore. The trackpoint doesn't work still, but I believe that's related to the touchpad itself.

Yeah, it's 100% the stupid clamp that's holding it down. When I hold the ribbon cable down myself with my spudger, it lights up perfectly. Electric tape to the rescue? Should I remove the clamp?

Look at this: https://imgur.com/a/6ur5lW8

You might to zoom in, but one of the pins looks wrong on the far right. I'm not too concerned about it since I can use electric tape (quite annoying, but it seems like this is my only option unless I replace the mobo) . But I'm wondering if that pin is making any contact at all. Is it even used? I'm worried it might be the pin for ground maybe, but I doubt that.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21283
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#13 Post by RealBlackStuff » Thu Jan 23, 2020 3:28 am

Needed to make some corrections about fuse-allocations.
RealBlackStuff wrote:
Wed Jan 22, 2020 12:31 am
KB-backlight fuse = F24
F13 and F23 are connected with the touchpad TrackPoint, don't know which function.
All three are 1A/32V_ERBRD1R00X fuses.
No idea about any trackpoint fuse, if there even is one.
The TrackPoint connector is marked JTP1 on the mobo.
The ClunkPad (officially ClickPad) connector is marked JCP1 on the mobo.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

pakastinhki
Posts: 3
Joined: Wed Oct 26, 2016 7:41 am
Location: Helsinki, Finland

Re: T440p touchpad/keyboard help. It just keeps getting worse.

#14 Post by pakastinhki » Tue Jan 28, 2020 8:19 am

Have you routed the cable from the right place? On the pictures it looks like you haven't routed it from that tiny gap between mobo and chassi but from upperside. That would mess up the cable when you push the frame down. Also would explain why both cables and touchpads are now not working.

The routing is somewhat annoying cause you have to put the frame in place underneath the screen at an angle and you might need a few tries for that.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: No registered users and 18 guests