Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T490 is very sluggish

T430 and later, plus T530 and later series specific matters only
Post Reply
Message
Author
hyde
Junior Member
Junior Member
Posts: 356
Joined: Fri Jul 08, 2011 8:12 pm
Location: New York, NY

T490 is very sluggish

#1 Post by hyde » Mon Aug 17, 2020 5:46 pm

Hi everyone,
I recently received my new T490 and coming from T450s I find it to be very sluggish, it's very hard to pinpoint but it's like dragging a heavy boulder. It's strong, but held back.
Simple operations take much longer than it should. I upgraded ram immediately from 8GB to 24GB, and storage CrystalDiskMark is in 2000s and 3000s.
Only thing I can think of is the graphics performance and maybe processor throttling?

I thought it was Windows settings after I used OOSU10, but I reverted back to defaults that I saved before changing.
Sometimes it takes a very long time to even open an excel file. What can I check/test? Any suggestions? It's 10210U, and it's almost always plugged in. Could it be overheating issue?

8/18/2011 - X220, i5-2540M, 12.5" IPS, FP, Cam, BT, Intel 6205 Wifi, 8GB, U2312HM
1/15/2012 - S405 (Wife's), AMD A6-4455M, 14", 4GB
7/02/2015 - T450s i5-5300U, 14" FHD IPS, FP, Cam, 12GB
7/1/2020 - T490 i5-10210U, 24GB, 14" FHD TS IPS, 512GB NVMe,

MikalE
ThinkPadder
ThinkPadder
Posts: 1314
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: T490 is very sluggish

#2 Post by MikalE » Mon Aug 17, 2020 7:04 pm

If that happens with any of my systems I go to the Task Manager and Services and see what's running or sucking up all of my processor resources.
A31p P-IV 2Ghz, 2MB, 2653-R6U
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7QM 4242-4UU Highly Modified

hyde
Junior Member
Junior Member
Posts: 356
Joined: Fri Jul 08, 2011 8:12 pm
Location: New York, NY

Re: T490 is very sluggish

#3 Post by hyde » Wed Aug 19, 2020 10:35 am

Thanks, that's the thing, I don't really see anything eating up resources, yet, when I try to run Excel, it goes super high and despite disabling Windows Defender, I see "antimalware service executable"
I think it's defender choking things up? How do I completely eliminate this?
Are there any settings in BIOS to disable in regards to Processing power or graphics/ram usage?

8/18/2011 - X220, i5-2540M, 12.5" IPS, FP, Cam, BT, Intel 6205 Wifi, 8GB, U2312HM
1/15/2012 - S405 (Wife's), AMD A6-4455M, 14", 4GB
7/02/2015 - T450s i5-5300U, 14" FHD IPS, FP, Cam, 12GB
7/1/2020 - T490 i5-10210U, 24GB, 14" FHD TS IPS, 512GB NVMe,

atagunov
Junior Member
Junior Member
Posts: 445
Joined: Thu Apr 02, 2020 3:11 pm
Location: London, UK

Re: T490 is very sluggish

#4 Post by atagunov » Wed Aug 19, 2020 11:28 am

Hi, I'm not an expert at all let alone in Win 10, but wasn't the piece of software that offered lots of info on your system called CPU-Z? I've never run it :) but it should at least tell you what frequency your CPU/RAM is running at etc. Which processor exactly did you have on T450? How does the overall CPU score compare between old and new? What are the single threaded scores for both?

P.S. I'm not sure if it will mess the system up on the old SSD but I suppose you could move that from old to new, boot and see what happens? Yes windows will probably get upset it's on new hardware but it should run at least somehow?
X220, 2 *T520

nikki605
Senior Member
Senior Member
Posts: 622
Joined: Fri Dec 08, 2006 2:39 pm
Location: Tampa, FL
Contact:

Re: T490 is very sluggish

#5 Post by nikki605 » Wed Aug 19, 2020 12:21 pm

My T490 is not sluggish at all. I have Norton Security installed so I do not use Windows Defender. The summary specs are in my signature below plus an external link to much more detailed specs if you want to compare.

I have CPU-Z installed but their results output text file is very long, too long to post here.

Here's my CrystalDiskMark results:

------------------------------------------------------------------------------
CrystalDiskMark 7.0.0 x64 (C) 2007-2019 hiyohiyo
Crystal Dew World: https://crystalmark.info/
------------------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

[Read]
Sequential 1MiB (Q= 8, T= 1): 3307.341 MB/s [ 3154.1 IOPS] < 2533.89 us>
Sequential 1MiB (Q= 1, T= 1): 1259.403 MB/s [ 1201.1 IOPS] < 830.09 us>
Random 4KiB (Q= 32, T=16): 1477.220 MB/s [ 360649.4 IOPS] < 1415.87 us>
Random 4KiB (Q= 1, T= 1): 51.530 MB/s [ 12580.6 IOPS] < 79.35 us>

[Write]
Sequential 1MiB (Q= 8, T= 1): 2101.087 MB/s [ 2003.8 IOPS] < 3981.30 us>
Sequential 1MiB (Q= 1, T= 1): 1476.479 MB/s [ 1408.1 IOPS] < 707.73 us>
Random 4KiB (Q= 32, T=16): 1094.441 MB/s [ 267197.5 IOPS] < 1897.15 us>
Random 4KiB (Q= 1, T= 1): 156.462 MB/s [ 38198.7 IOPS] < 25.96 us>

Profile: Default
Test: 1 GiB (x5) [Interval: 5 sec] <DefaultAffinity=DISABLED>
Date: 2020/08/19 9:55:04
OS: Windows 10 Professional [10.0 Build 18363] (x64)
Gary A.

lenovo: T490 (20N20028US) | i7-8565U | 16GB | 512GB SSD | FHD LED | WiFi 9560 | Bluetooth | Webcam | Win10 Pro x64 | Full System Specs
lenovo: T410 (2516-CTO) | i7-620M | 8GB | 320GB 7200rpm | WXGA+ | WiFi 6300 | Bluetooth | Webcam | DVD-RW | 9 Cell | Win7 Pro x64 | Full System Specs

atagunov
Junior Member
Junior Member
Posts: 445
Joined: Thu Apr 02, 2020 3:11 pm
Location: London, UK

Re: T490 is very sluggish

#6 Post by atagunov » Wed Aug 19, 2020 1:42 pm

BTW OP actually has the processors in his signature and his T490 is way ahead of his T450s in CPU score:

T450s/i5-5300U/2,732
T490/i5-10210U/6,472

Okay it's 4 cores versus 2 cores but it should also be considerably better in single-threaded tests too I guess
X220, 2 *T520

hyde
Junior Member
Junior Member
Posts: 356
Joined: Fri Jul 08, 2011 8:12 pm
Location: New York, NY

Re: T490 is very sluggish

#7 Post by hyde » Fri Aug 21, 2020 6:34 pm

atagunov, I can share any specs/info if you need anything, I usually use HWiNFO64 for that.

Image


nikki, yours is i7, probably overall better, but even if it's the processor in my case I would like to know if that's the reason.
I upgraded the ram immediately with recommended Crucial 16GB RAM. I don't think my thinkpad is overheating, fan seems to work fine (the laptop does get pretty hot on the bottom, but the weather is hot).
Crystalmark scores are excellent for me, so I know it's not the SSD.

Image

For example, to illustrate my frustration:
I have an Excel file that's only 1.4MB where we keep really simple plaintext data, probably thousands of rows but it takes 20-22 seconds to pop up. I see the "excel" splash screen and stare at it for 20 seconds.

I don't have problems with things like copying or transferring files, or even encoding a video on Windows Movie Maker (occasionally merge my cellphone videos of our trips and it does feel slightly faster than my old T450s)
So I am not sure what to do or how to even check?

Did anyone try userbenchmark?

8/18/2011 - X220, i5-2540M, 12.5" IPS, FP, Cam, BT, Intel 6205 Wifi, 8GB, U2312HM
1/15/2012 - S405 (Wife's), AMD A6-4455M, 14", 4GB
7/02/2015 - T450s i5-5300U, 14" FHD IPS, FP, Cam, 12GB
7/1/2020 - T490 i5-10210U, 24GB, 14" FHD TS IPS, 512GB NVMe,

nikki605
Senior Member
Senior Member
Posts: 622
Joined: Fri Dec 08, 2006 2:39 pm
Location: Tampa, FL
Contact:

Re: T490 is very sluggish

#8 Post by nikki605 » Sat Aug 22, 2020 7:00 am

Have you tried using msconfig.exe to start the machine in Diagnostic mode? That will tell you if one of the services is causing a problem.

How to use msconfig :arrow: https://support.microsoft.com/en-us/hel ... configurat

Image
Last edited by nikki605 on Sun Aug 23, 2020 10:55 am, edited 2 times in total.
Gary A.

lenovo: T490 (20N20028US) | i7-8565U | 16GB | 512GB SSD | FHD LED | WiFi 9560 | Bluetooth | Webcam | Win10 Pro x64 | Full System Specs
lenovo: T410 (2516-CTO) | i7-620M | 8GB | 320GB 7200rpm | WXGA+ | WiFi 6300 | Bluetooth | Webcam | DVD-RW | 9 Cell | Win7 Pro x64 | Full System Specs

hyde
Junior Member
Junior Member
Posts: 356
Joined: Fri Jul 08, 2011 8:12 pm
Location: New York, NY

Re: T490 is very sluggish

#9 Post by hyde » Sat Aug 22, 2020 7:54 pm

Hi nikki,
I'll give it a try. Thanks.

8/18/2011 - X220, i5-2540M, 12.5" IPS, FP, Cam, BT, Intel 6205 Wifi, 8GB, U2312HM
1/15/2012 - S405 (Wife's), AMD A6-4455M, 14", 4GB
7/02/2015 - T450s i5-5300U, 14" FHD IPS, FP, Cam, 12GB
7/1/2020 - T490 i5-10210U, 24GB, 14" FHD TS IPS, 512GB NVMe,

nikki605
Senior Member
Senior Member
Posts: 622
Joined: Fri Dec 08, 2006 2:39 pm
Location: Tampa, FL
Contact:

Re: T490 is very sluggish

#10 Post by nikki605 » Sun Aug 23, 2020 10:56 am

Gary A.

lenovo: T490 (20N20028US) | i7-8565U | 16GB | 512GB SSD | FHD LED | WiFi 9560 | Bluetooth | Webcam | Win10 Pro x64 | Full System Specs
lenovo: T410 (2516-CTO) | i7-620M | 8GB | 320GB 7200rpm | WXGA+ | WiFi 6300 | Bluetooth | Webcam | DVD-RW | 9 Cell | Win7 Pro x64 | Full System Specs

UMPC2024
Junior Member
Junior Member
Posts: 250
Joined: Sun Nov 24, 2013 1:18 am
Location: Portland, OR

Re: T490 is very sluggish

#11 Post by UMPC2024 » Sun Aug 23, 2020 1:34 pm

Is it only an Excel problem? If so, some people have found a solution by turning off the Cortana feature in Windows 10.
Here's the source https://www.itprotoday.com/windows-serv ... windows-10

hyde
Junior Member
Junior Member
Posts: 356
Joined: Fri Jul 08, 2011 8:12 pm
Location: New York, NY

Re: T490 is very sluggish

#12 Post by hyde » Sun Aug 23, 2020 5:42 pm

UMPC2024 wrote:
Sun Aug 23, 2020 1:34 pm
Is it only an Excel problem? If so, some people have found a solution by turning off the Cortana feature in Windows 10.
Here's the source https://www.itprotoday.com/windows-serv ... windows-10
I use Excel daily and work on many files that I need to open and close when I am done so other can continue updating it. This is why I noticed excel being extremely slow.
I do have other issues with browser gradually slowing down to a crawl but I think I am not the only one with that problem. There is also slow operation of excel files too, overall when I scroll up/down or when I filter things I notice the results don't pop up instantly, like there is an unexplainable delay. I turned off windows animations too when I hover over menu items, it does not feel natural. When I move the mouse up and down it skips some of the items because supposedly I move the mouse too fast? However, the "20 second" is describing exactly what I am experiencing. If I can fix the excel I think I can live with other slowdowns.

The problem is, I don't even have cortana enabled on this computer. Seems like I may have to enable it, then go to setting to disable that option.

Also, how do I completely disable Windows Defender?
I thought it was disabled (it is disabled from options, and I get a little warning triangle on my shield icon that says Virus and Threat Protection is Off.
However I tested it, and I had to click through 3 different warnings for it to enable installation of an "untrusted" software. Is it possible to completely disable defender?
nikki605 wrote:
Sun Aug 23, 2020 10:56 am
More info about using msconfig :arrow: https://answers.microsoft.com/en-us/win ... 00e879ce17
Thanks for the link, I will try that tonight.

8/18/2011 - X220, i5-2540M, 12.5" IPS, FP, Cam, BT, Intel 6205 Wifi, 8GB, U2312HM
1/15/2012 - S405 (Wife's), AMD A6-4455M, 14", 4GB
7/02/2015 - T450s i5-5300U, 14" FHD IPS, FP, Cam, 12GB
7/1/2020 - T490 i5-10210U, 24GB, 14" FHD TS IPS, 512GB NVMe,

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: Bing [Bot] and 25 guests